Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Feature Transfer Error - Error:- 1612

03 Jul 2010   #1

Windows 7 Home Premium OEM
Feature Transfer Error - Error:- 1612

I am having some difficulty installing, uninstalling and reinstalling some OEM software supplied with a Video/Audio Grabber. By coincidence, the same software is also supplied with a USB DVB-Tuner that I also bought.
The disk that I am focusing on is the one supplied with the Video/Audio Grabber in the link below:

I bought it from Netto a few months ago.
The OEM software is supplied by ArcSoft, this is the link to their website:

The disk contains installations for:
a) Drivers
b) ShowBizDVD 2
c) TotalMedia 3.5
d) Video Downloader

My immediate issues are with a) and b) although it is apparent that neither of the other applications will work either.

I have tried to uninstall the above software after receiving error messages. I have used the disk supplied to attempt to carry this out.

The first message I get is:

USB Video/Audio Driver

Set up could not find a file on the specified path or disk.
Please check that the proper disk is inserted or specify a new path.
Unable to locate file: C:\Users\BRIANS~1\AppData\Local\Temp\{61B21240-486A-4B0B-9D0F-85435BECDD97}\USB Video Audio Driver.msi

This is accompanied by another message:

Feature Transfer Error

Error:- 1612. The installation source for this product is not available.

Verify that the source exists and that you can access it.

The strange thing is that after the first time that I installed the suite of programs from the disk, it all worked! I trialled transferring a short amount of footage from VHS to my hard disk and it actually worked. My cheif concern at the time was that the amount of memory it was taking up as it was transferring seemed rather large for the 5 to 10 minutes of footage.

I queried this on the ArcSoft Tech Support, who were initially quite helpful. They didn't send me an answer as such but did provide me with a patch which I assumed would allow things to work better in Windows 7, (the disk supported only up to XP). Since I ran that patch, everything seems to have deteriorated and there seems no easy way back! I have tried a system restore but the point which I created had been deleted so I went back as far as possible which evidently was not as far as needed!

ArcSoft have apparently gone quiet on me or they are on holiday! They are in the USA I believe, so it may be that July 4 may have something to do with their apparent silence.

Can anyone shed any light on this and what actions I should take?

I am classified at Base Level Experience, so please keep it as simple as possible!

My System SpecsSystem Spec
03 Jul 2010   #2

Microsoft Community Contributor Award Recipient


10315 Audio Video Grabber AGK Nordic A/S

Have try the Update for Windows 7 at the bottom of web page.
My System SpecsSystem Spec
04 Jul 2010   #3

Windows 7 Home Premium OEM

Quote   Quote: Originally Posted by theog View Post
10315 Audio Video Grabber AGK Nordic A/S

Have try the Update for Windows 7 at the bottom of web page.
Yes! This one of the first things that I did.

I tried this and it did something momentarily and then nothing. It gave no information as to what it was doing or even if it had completed. Pretty much the same as the patch that ArcSoft sent me - it seemed as though I had to take it for granted that whatever the patch or upgrade link did it had done it successfully.

Not brilliant from my point of view.
My System SpecsSystem Spec

04 Jul 2010   #4

Windows 7 Ultimate x64 SP1

You'll have to contact the hardware vendor. Arcsoft just provides the OEM software - that means it's up to the hardware vendor to get things working and to help you.
My System SpecsSystem Spec

 Feature Transfer Error - Error:- 1612

Thread Tools

Similar help and support threads
Thread Forum
Installation failing i keep getting feature transfer error
I'm at my wits end, i have no idea what to do
Feature transfere error
Hello people, I got windows7 64bit and lately, when I tried installing something or a game with InstalShield, I got this error: Or click here for the picture... (onherstelbare fout = Critical error / unfixeble error ) I've tried some fixes, but non...
Installation & Setup
USB3 install fail: feature transfer error: 2
I tried installing my NEC USB3 3.0 Host Controller File after a repair/upgrade install. Now, I get the above error during the driver setup. I downloaded the driver directly from Asus. Any ideas on the workaround? Thanks
Civ 4 feature transfer error
Hello all Installing civ 4 on windows 7 I got a "feature transer error", and windows tells me that access is denied on that file. anyone run into this problem before? a google search brought up some issues with xp but no one seemed to have an answer on 7. Page
Feature Transfer Error - Access is Denied?
I cannot install Oblivion on my computer because i keep getting this "Feature Transfer Error". Feature: Oblivion Component: Oblivion File: Error: Access is Denied Can anyone help? My OS: Windows 7 Ultimate 32-bit...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:36.
Twitter Facebook Google+