Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Need Help - HDD Not Detected in BIOS

10 Jul 2010   #1

Windows 7
Need Help - HDD Not Detected in BIOS

Hi All,

I'm new here and have dug around a bit but can't find anything that helps with my problem.

First the HW details:

PC is 5-6 years old
It was built by a local, well known computer shop that's been around for years
MOBO is an Asus K8VSE Deluxe
BIOS is AMI version 08.00.09, Build date 09/08/05, ID A0058002

Next a little back story:

The PC was running WinXP Pro until one day it wouldn't boot, saying that a critical file was missing. I played around with it and *thought* the HDD had failed. So I parked the PC for a while and just used my laptop, until this week, when I decided to get this pig working again.

While troubleshooting the issue (months ago) I noticed that my one and only SATA HD was not plugged into the standard SATA port on the Mobo, but on the SATA port on the on-board RAID controller. Why this was done is beyond me, but it was done when this machine was built.

Now the current situation:

I decided to go with a new WD Caviar Black, 1.0TB drive, and Windows 7 Pro. Plugged everything in, set the BIOS to boot to the Windows CD, and fired it up.

First thing is that the BIOS does not see a HDD, hit F1 to continue. So I did.

Windows 7 started loading files, and I thought I was in good shape. But alas, 7 could also not see the HDD but asked if I wanted to load drivers.

Now I am confused; drivers should not help if the BIOS can't even see the HDD, right?

So I futzed around with the BIOS, and can't see a whole lot of anything mentioning SATA. I thought that if you set the IDE type to auto detect, the BIOS would figure out there was a SATA drive, but apparently not in my case.

All cables are from HDD to mobo are plugged in firmly, the drive spins up. I even tried a new SATA cable and got the same result.

I reset the BIOS to factory defaults and got the same result.

I disabled and re-enabled the on-board Promise controller and got the same result.

At this point, I think it's either something so simple that I am overlooking it, or the MOBO is fried. But remember, when this all started all was fine save for a missing file that would not allow Win XP to boot, so . . . . .


Thanks in advance for any and all responses.

My System SpecsSystem Spec
10 Jul 2010   #2

Win7 Enterprise, Win7 x86 (Ult 7600), Win7 x64 Ult 7600, TechNet RTM on AMD x64 (2.8Ghz)

Can you pre-format the HD on another computer. Do you still have a MB driver disk ?

Might need to load SATA drivers on that old of MB.
My System SpecsSystem Spec
11 Jul 2010   #3

Windows 10 Pro X64

Where is the new drive plugged in? The mother board or the Raid controller? Try moving it to which ever one it's not plugged into. If not help, check BIOS and select the non-RAID settings.
My System SpecsSystem Spec

11 Jul 2010   #4

Windows 7 Pro X64 SP1

Is the new drive plugged into the primary SATA controller (not the "RAID" controller)? That may be required for the BIOS to detect the drive. (Was the old drive visible to the BIOS before, or only in the sub-BIOS for the third-party RAID controller?)

If the drive isn't defective, there's a chance that the mainboard's SATA controller does not like a 300MB/s drive. (The controller is a 150MB/s one.) The drive can be set to 150MB/s with a jumper. That may be worth a try.

This isn't relevant to whether the drive is detected, but you may need to install drivers for the Via chipset. Via doesn't list any for Win7, but the Vista ones will probably work:

Old (Socket 754) system. Good luck.
My System SpecsSystem Spec
11 Jul 2010   #5

Windows 7

Thanks for the responses thus far, everyone.

The new drive is currently plugged into the regular, non-RAID SATA1 port on the motherboard.

The old drive was plugged into the RAID controller (which is built in to this mobo). Bob, your 150 vs. 300 Mb/s comment is interesting and may very well explain why my single drive was plugged into the RAID controller instead of the normal SATA port in the first place.

I'll now try to plug things into the RAID controller and see if anything works. I'll report back once I've had a chance to play around some more.
My System SpecsSystem Spec
11 Jul 2010   #6

Main - Windows 7 Pro SP1 64-Bit; 2nd - Windows Server 2008 R2

If the computer is that old it predates the availability of 1TB drives. A simple BIOS update might fix you right up. :)

(Keep in mind that there is no such thing as "A simple BIOS update" - should you go this route be very careful and follow the MB manufacturers instructions to a "T".)

I would read the Release Notes for any newer BIOS's which might be available and see if they address detection of larger hard drives.
My System SpecsSystem Spec
11 Jul 2010   #7

Windows 7

OK - progress, but not much.

I plugged the new drive into the RAID controller. BIOS now sees the drive, but Windows 7 does not.

This is a fresh, new drive and I am doing a clean install of Win 7.

Someone suggested that I chuck the mobo cd into the drive and let the drivers load.
The problem is, I was not given that CD when I had this computer built.

I went to the Asus support web site and all I see for available downloads are several different BIOS versions.

I went to WD's site to look for help and didn't find anything there.

Where do I go next?
My System SpecsSystem Spec
11 Jul 2010   #8

Microsoft Community Contributor Award Recipient


My System SpecsSystem Spec
11 Jul 2010   #9

Windows 7

Quote   Quote: Originally Posted by theog View Post

How do I take a screen shot when the PC has no OS? This is a brand new, clean drive, and I am trying to install Win 7 on it. BIOS sees the drive but Windows 7 does not.
My System SpecsSystem Spec
11 Jul 2010   #10

Windows 7 Ultimate 64 Bit

Do we assume you have initiated the HDD already. If it is brand spanking new, you have to setup the drive first. And you may need to install a 3rd party driver for it, as Win7 may not have the driver pre-loaded for that drive.
My System SpecsSystem Spec

 Need Help - HDD Not Detected in BIOS

Thread Tools

Similar help and support threads
Thread Forum
new ssd not being detected in bios
My new samsung 250gb ssd is not being detected in bios. I have a gigabyte ga 970a ud3 motherboard. tried two different sata ports but no luck. I read on the samsung site that I might need to upgrade my bios, but having trouble with that too. I am running a 64bit version of windows 7.
Hardware & Devices
DVD Drive detected by BIOS but not Windows
Decided to install an aftermarket DVD drive from my old pc. It powers on and the tray works. It's the only IDE drive that is connected to my motherboard. It shows up in BIOS under boot device priority but can't be found once I log into windows. I've tried making adjustments in the registry,...
Hardware & Devices
No drives detected in bios
Hi guys, My corsair ssd and Samsung hard drive appear in the safely remove hardware and media icon in windows. I was told I could try disabling the hot plug option on my bios. When I looked the sata ports 1 and 2 say nothing present but both drives work and appear in the boot priority part of the...
Hardware & Devices
Hard drive not detected at bios
I have a machine that will no longer detect my samsung terra at bios. It seems to make the boot up noise and everything but it wont detect it at all. It does detect my other sammy but not this drive. I tried it in another machine and i get the same problem. I swapped the circuit board from my...
Hardware & Devices
Hard disk not detected by BIOS
Hi I tried to serach my problem on the forum but couln't find a solution.So request you all to help please. My laptop was working fine until last night.But when i switched it on this morning i got "operating system not found error message". I tried to fix the problem by using windows...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:52.
Twitter Facebook Google+