Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Missing CD/DVD Drivers

15 Jul 2010   #1
lukemc

Windows 7
 
 
Missing CD/DVD Drivers

Hello,

I'm trying to create a fresh install of windows 7 pro x64 but am getting the error that I'm missing a required cd/dvd driver. I also tried switching my SATA settings to AHCI as suggested (even though my DVD drive is IDE).

I had read that using a bootable usb drive can solve this issue so I original tried that only to find that my install dvd must have been corrupt (certain files wouldn't copy). I redownloaded a fresh version of the ISO and burned that to a new DVD and got the same issue. I then successfully copied all the files directly from the image file to the usb drive. That booted successfully but still gave me the same missing driver error.

At one point I even disconnected my only DVD drive and still received that error.

I'm installing to an x-25m SATA SSD. My mobo is an ASRock X58 Extreme. I created the bootable usb drive from win 7 x32, which some have said getting it to be bootable can be an issue since it's x64, but mine successfully booted.

Others have said this can be caused by a bad burn and solved by burning at 1x - but I got this error even booting directly from the usb drive. I copied the files directly from my hard drive as well.

Does anyone have any suggestions on how I can go about getting passed his error?

Thanks,

Luke


My System SpecsSystem Spec
.
15 Jul 2010   #2
Jonathan_King

Windows 7 Professional x64
 
 

Welcome!

Some users have reported that they solved this problem by deleting the recovery partitions that came with the computer.

Where did you get your copy of the ISO?
My System SpecsSystem Spec
15 Jul 2010   #3
lukemc

Windows 7
 
 

My original ISO is from an MSDN subscription. I'm currently downloading another ISO from Digital River (found the link for it here: MS/Digital River Student ISO Links). Just to see if it's my version.
My System SpecsSystem Spec
.

15 Jul 2010   #4
lukemc

Windows 7
 
 

As for partitions that came with the computer. I just bought the drive separately. Would it come with partitions standard?
My System SpecsSystem Spec
15 Jul 2010   #5
Jonathan_King

Windows 7 Professional x64
 
 

No, it should be blank and formatted.

Was the SATA setting on IDE before you changed it to AHCI? If not, change it to IDE and see what happens.

You should also change it to RAID, if IDE doesn't work.
My System SpecsSystem Spec
15 Jul 2010   #6
lukemc

Windows 7
 
 

It was on IDE originally. I'll try RAID to see what it does when I get home tonight. Thanks
My System SpecsSystem Spec
15 Jul 2010   #7
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

My System SpecsSystem Spec
15 Jul 2010   #8
lukemc

Windows 7
 
 

Thanks. I've gone to my motherboard manufacturer's website and tried to load the SATA2 driver they have there (ASRock > Products > Motherboard > X58 Extreme > Download) it just gave me a message saying it didn't find any drivers.

I don't think I've tried that since I unplugged my IDE drive though, so maybe I'll give that a try when I get home.

I've also updated my relevant system specs.
My System SpecsSystem Spec
15 Jul 2010   #9
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Quote   Quote: Originally Posted by lukemc View Post
Thanks. I've gone to my motherboard manufacturer's website and tried to load the SATA2 driver they have there (ASRock > Products > Motherboard > X58 Extreme > Download) it just gave me a message saying it didn't find any drivers.

I don't think I've tried that since I unplugged my IDE drive though, so maybe I'll give that a try when I get home.

I've also updated my relevant system specs.

Which one did you download?
My System SpecsSystem Spec
15 Jul 2010   #10
lukemc

Windows 7
 
 

The JMicron SATA2 driver ver:R1.17.52.02. I also just got a few others to make sure I hadn't gotten the wrong thing, including the INF Driver.

The Intel Matrix Storage Manager was an executable to install something, not a stand alone driver like I'd need.
My System SpecsSystem Spec
Reply

 Missing CD/DVD Drivers




Thread Tools




Similar help and support threads
Thread Forum
Missing drivers
I have just put a new hard drive in my laptop and re installed windows 7 32 bit, I cannot get it to find the router and when I troubleshooted it said that the network controller driver and the pci simple communications controller driver were missing, I downloaded the network drivers from intel onto...
Drivers
Missing Drivers?
Today i went to the device manager and i have seen several yellow warnings things like: Dritek General Port I/O, MpKsl392e8d3c, MpKslcf6bfef0, SASDIFSV and SASKUTIL. Anyone can help me fixing them? PS: I don't know if this matters but my laptop is an Acer Aspire 5737Z
Drivers
Missing USB Drivers???
Before I throw my laptop in the nearest canal, please can someone help me? Over the last few months I have bought 3 new memory sticks and today a new usb hub. With my old laptop (with XP) they all run fine. With my newer (and in theory main one) that is running Windows 7 I keep getting...
Drivers
Missing CD/DVD Drivers...
Hey! First of all, hope you don't mind me leeching of this forum, I'll try to contribute some in the future... I'm trying to install Windows 7 on an old computer. As the title suggests, the install won't start because "a required cd/dvd device driver is missing" I've tried all the...
Installation & Setup
Missing drivers
Hi guys I am new to this forum. I was running windows xp proffesional on a pc purchased from an old employer about a year ago. The pc has been running fine with no probs. I decided to purchase windows 7, I loaded this on the pc and it all seems to have gone on fine except for 2 issues. The first...
Drivers
Drivers missing and not available!
I have recently upgraded from Vista to Window 7 on my Acer Aspire 5520. The changeover went smoothly, except I can't burn a cd or dvd. I have opened the device manager and it is reporting 2 devices in "other devices"(base system device-PCI bus 1, device 4, function 3) do not have drivers...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App