Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HELP! VC-1 encoded .m2ts files = NO VIDEO in MCE/WMP12

05 Nov 2009   #21
dbone1026

W& x64 RC1
 
 

Quote   Quote: Originally Posted by MarcG View Post
Hi guys,

Turns out my media giving problems was 1080i VC1 which is rare and exotic. See interesting discussion here:

Help! 7RTM trouble with VC1 MKVs. Choppy! - AVS Forum

MEanwhile using MPCVideoDEc.ax seems good for more common VC1 progressive material.

Thanks for your help. Dbone, I will review your guide tonight. Thanks.

Marc
Using MPCVideoDec for my .ts VC-1 allows for HA which allows for much smoother playback. My codec writeup is nothing more then a summary of what Renethx had put together. I have this set up on my two HTPCs and my desktop PC and have yet to encounter any problems playing back my videos with full HA. No matter what you do, I always suggest you image or backup your system before you install any codecs/filters so you can revert back to a clean state incase something doesn't work.


My System SpecsSystem Spec
.
08 Nov 2009   #22
MarcG

Windows 7 RTM x64 (desktop), x32 (HTPC)
 
 

dbone-

Thanks for your reply. I've got MPCVideoDec enabled for VC1 and the progressive content I've got is working fine. I haven't explored working with the solution Renethx proposed. I may work with that this afternoon if time allows. I've been troubleshooting some MB 2.1.3 issues so haven't had much time for other stuff.

I've been meaning to thank you for some time, actually. In March I read your blog or website, and your posted experiences helped embolden me to take the HTPC leap.

I'll post back if I get an interlaced VC1 filter working.

Marc
My System SpecsSystem Spec
08 Nov 2009   #23
dbone1026

W& x64 RC1
 
 

Quote   Quote: Originally Posted by MarcG View Post
dbone-

Thanks for your reply. I've got MPCVideoDec enabled for VC1 and the progressive content I've got is working fine. I haven't explored working with the solution Renethx proposed. I may work with that this afternoon if time allows. I've been troubleshooting some MB 2.1.3 issues so haven't had much time for other stuff.

I've been meaning to thank you for some time, actually. In March I read your blog or website, and your posted experiences helped embolden me to take the HTPC leap.

I'll post back if I get an interlaced VC1 filter working.

Marc
Hey Marc,

Glad to hear you got things working. Rene actually just gave a brief sumamry regarding interlaced VC-1:

Win7 MC HTPC: FFDshow or default 7MC codecs? - AVS Forum

Sorry to hear you have run into some problems with Media Browser, I have the latest version running rather smooth right now (I wrote about my setup here - Review: Media Browser 2.1.3.0 (Phoenix) ).

Thanks for the kind words, building an HTPC doesn't seem as intimidating as when you first started I bet!!!
My System SpecsSystem Spec
.

08 Nov 2009   #24
MarcG

Windows 7 RTM x64 (desktop), x32 (HTPC)
 
 

Thanks again Damien,

I looked over the guides from Renethx and have decided not to pursue exotic measures just to be able to use 7MC to play Torchwood... it's my only VC1 interlaced content at the moment, and I can use PowerDVD to watch the content on the .iso. The guide suggests I need to disable media foundation and do other significant hacks which I don't feel like spending time on.

I don't do any HD audio (just plan DD and DTS over SPDIF to an older receiver). Given that, if there's a video codec you or anyone knows about that I can simply register and enable with FilterTweaker to let me watch interlaced VC1, I'll be happy to give it a whirl. For the moment the MPCVideoDec.ax is working fine for all non-interlaced VC1 that I've got.

About MB 2.1.3, I've had it go loopy on me in both x32 and x64, and I've sent the devs som log info to help investigate. I love that program and 2.1.1 has been rock solid for me (on Vista, W7RC, W7RTM). I'm anxious to know what about my W7 RTM is twigging version 2.1.3 out. If you're curious about details see the media browser forum. Most people don't run into my issues but I can see I'm not the only one, so I'm sure it will eventually be sorted and all will be right with the world again.

Meanwhile I'll backdate to 2.1.1. It does everything I want it to, pretty much the way I want to do it.
My System SpecsSystem Spec
Reply

 HELP! VC-1 encoded .m2ts files = NO VIDEO in MCE/WMP12




Thread Tools




Similar help and support threads
Thread Forum
Blu-ray M2TS Files - Software Help Needed
Hi, all My new Blu-ray re-writer will not play all of my Blu-ray films. The ones that will not work are made up of various M2TS files. Ones I've tried: VLC Player MPC Cinema
Music, Pictures & Video
MTS M2TS Video Editing?
Sorry if it's been answered, I searched and didn't find a good answer... I just got a canon vixia hf20, and it's videos are in the m2ts format. I tried loading in wmm 2.6 but it won't open. I tried with windows live movie maker, and it froze... I've heard bad things about adobe premiere...
Software
WMP12 BSOD on Video Play Back
Greetings all... I recently installed Windows 7 Ultimate on a new system that I put together. I've had no problems with it, other then my old DVD playback software was no longer compatible. No problem, as I was able to play and watch my DVD's on the included version of Windows Media...
Media Center
WMP12 Wont play video files!
Installed AC3Filter, all the codecs.. WMP player plays my AVIS fine before, now i updated my video card and all AVIS will not work! When i switch my sound to "Speakers" - it will not load the avi... but when i use Digital Audio High definition bus the avi VIDEO works fine, but there is no audio.....
Music, Pictures & Video
RE: WMP12 Streaming Video
Hello, Contemplating the possibility that we can use WMP12 to stream videos so that my people can watch movies that are on my HTPC from their homes. By movies, I mean, Some 700MB avi DVD Rips, which should stream just fine AND some mkv Bluray rips. Mkv files are 4GB to 11GB in size. So to you...
Music, Pictures & Video
WMP12 box at video play huge!
Okay so when I first started using WMP12 to play vids a little box would appear as it cached the vid for playback later. This was fine. But I let a friend use the computer and somehow he resized this little box before the video launched and now it it huge! This bothers me to no end causeing many...
Music, Pictures & Video


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:08.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App