Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Coreavc doesn't run under Windows7 7100 RC1

01 Jul 2009   #1
Matchbox

Windows 7
 
 
Coreavc doesn't run under Windows7 7100 RC1

Coreavc codec doesn't run when plaving mkv. WMP using native codecs and prevent other third party codecs (coreavc,ffdshow) for mkv.

How could I solve this problem?

Thank you.


My System SpecsSystem Spec
.
01 Jul 2009   #2
sirdan

Win Xp/7
 
 

My System SpecsSystem Spec
01 Jul 2009   #3
John Henry

Win 7 RC 64bit b7229
 
 

Quote   Quote: Originally Posted by Matchbox View Post
Coreavc codec doesn't run when plaving mkv. WMP using native codecs and prevent other third party codecs (coreavc,ffdshow) for mkv.

How could I solve this problem?

Thank you.
YOu may avoid this problem, using MPC HC and configuring coreavc as an external codec.
My System SpecsSystem Spec
.

01 Jul 2009   #4
garbanzo

7600 x86
 
 

as i alrady told you in the the thread you hicjacked earlier, coreavc works just fine in windows 7. your problem is that you're trying to use a crappy media player to view HD video. if you just follow our suggestions and switch to MPC, things will work just fine.
My System SpecsSystem Spec
02 Jul 2009   #5
Matchbox

Windows 7
 
 

Hi garbanzo,

As I said before, i dont wanna use MPC. I wanna user WMP with CoreAVG while watching especially 1080p mkv's.

Any advice differ from using MPC?

Thanks.
My System SpecsSystem Spec
02 Jul 2009   #6
garbanzo

7600 x86
 
 

My System SpecsSystem Spec
06 Jul 2009   #7
Matchbox

Windows 7
 
 

It did not work. (Changing registry, etc).

720p and 1080p mkv 's are very slow under W7 while using WMP.
My System SpecsSystem Spec
06 Jul 2009   #8
mikinho
Microsoft MVP

6x W2K8 R2 (x64), 6x W7 7600 (x64), 2x Gentoo (x64), 1x Ubuntu 9.04 (x64), 1x pfSense (FreeBSD)
 
 

Quote   Quote: Originally Posted by Matchbox View Post
It did not work. (Changing registry, etc).

720p and 1080p mkv 's are very slow under W7 while using WMP.
The registry settings really only set the perceived file type to video so that WMP\WMC will know that mkvs are video files.

To get WMP to use CoreAVC you'll need to do a bit more tweaking and currently this will only work in the 32-bit version of WMP (Note: Even in W7 x64 the default WMP is 32-bit...dumb).

You'll need to setup the proper Directshow filter. I'd recommend using the tool for that. See a guide at http://www.hack7mc.com/2009/06/prefe...windows-7.html
My System SpecsSystem Spec
06 Jul 2009   #9
Matchbox

Windows 7
 
 

Quote   Quote: Originally Posted by mikinho View Post
The registry settings really only set the perceived file type to video so that WMP\WMC will know that mkvs are video files.

To get WMP to use CoreAVC you'll need to do a bit more tweaking and currently this will only work in the 32-bit version of WMP (Note: Even in W7 x64 the default WMP is 32-bit...dumb).

You'll need to setup the proper Directshow filter. I'd recommend using the tool for that. See a guide at Preferred DirectShow Filters Tool for Windows 7
Thank you very much mikinho. Your post solved my problem...
See you.
My System SpecsSystem Spec
06 Jul 2009   #10
mikinho
Microsoft MVP

6x W2K8 R2 (x64), 6x W7 7600 (x64), 2x Gentoo (x64), 1x Ubuntu 9.04 (x64), 1x pfSense (FreeBSD)
 
 

Quote   Quote: Originally Posted by Matchbox View Post
Thank you very much mikinho. Your post solved my problem...
See you.
Glad I could help.
My System SpecsSystem Spec
Reply

 Coreavc doesn't run under Windows7 7100 RC1




Thread Tools




Similar help and support threads
Thread Forum
Failed install windows7 home to windows7 enterprise
I have an HP Compaq dx2000mt desktop that has windows7 32bit enterprise installed on it. I tried to install windows7 home 32bit to replace the enterprise OS. As I was installing it stated the old OS would be marked, XXX.old and it went forward, then came to a point where there were booting errors....
Installation & Setup
Windows7 doesn't load after Debian installation
Hello! I have the same problem as one described here https://www.sevenforums.com/installation-setup/128616-win-7-won-t-boot-after-installing-ubuntu-dual-boot.html (the last problem), excepting for having another linux distribution. So I won't describe it in more details. I've tried fixmbr and...
BSOD Help and Support
Windows7 64 reading windows7 32 drive?
My new computer arrived today with Windows7 64 installed. (happydance) My old computer has Windows7 32 installed. Before I start attacking both computers, thought I better ask beforehand or the b/f will 'kill' me :rolleyes: Can I remove the hard drive from the old computer, install it as a...
General Discussion
Compaq Presario F730 doesn't like 7100 x86
So I'm helping a friend set up his computer... or well... I'm trying. Two big problems, the graphics card (GeForce Go 6150) won't update drivers. For some reason, nVidia doesn't seem to support it? Second, it can't connect to the internet wirelessly. It detects the wireless router but can't...
Installation & Setup
build 7100 x64 doesn't boot anymore (presents wallpaper
I have finally managed to install build 7100 on a clean partition (installation took forever...). Now that I have installed some software, it doesn't boot up completely anymore. It presents my desktop wallpaper and my single gadget and then stops. I can use the mouse, but I cannot open a...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App