Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 7264 BSOD on wake when media center active

02 Jul 2009   #11
mtp

Server 2012 R2, Windows 8.1 , W7 ultimate x64
 
 
No disk Errors

USASMA

I ran the disk diagnostics (WD) as you suggested and did not find any problems on the disks. I ran the quick diagnostics as I have 2 1.0T disks. BTW i ran chkdsk /r on the disks a week ago and they came up clean as well.

I do not know if this matters, but i had to disable AHCI in the bios to get the diag disk to boot.

Thanks again for your help.

Mark


My System SpecsSystem Spec
.
02 Jul 2009   #12
mtp

Server 2012 R2, Windows 8.1 , W7 ultimate x64
 
 
New News AHCI and BSOD

When I disable AHCI and native SATA support in bios everything works.

AHCI seems to be somehow involved.

Mark
My System SpecsSystem Spec
02 Jul 2009   #13
zigzag3143

Win 8 Release candidate 8400
 
 
bsod on wake

Quote   Quote: Originally Posted by mtp View Post
When I disable AHCI and native SATA support in bios everything works.

AHCI seems to be somehow involved.

Mark
Mark you running a raid?

Ken
My System SpecsSystem Spec
.

02 Jul 2009   #14
mtp

Server 2012 R2, Windows 8.1 , W7 ultimate x64
 
 
No Raid

Hi Ken:

I am not running RAID.

I have done some further testing and it turns out that Native SATA support does not matter. AHCI and BSOD. No AHCI and everything works.

I would like to use AHCI as I have a portable SATA drive and I believe I require AHCI to be enabled to be able to Plug and Play or hot swap the drive.

Thank you all for your help.

Mark
My System SpecsSystem Spec
02 Jul 2009   #15
zigzag3143

Win 8 Release candidate 8400
 
 
bsod solved

Quote   Quote: Originally Posted by mtp View Post
Hi Ken:

I am not running RAID.

I have done some further testing and it turns out that Native SATA support does not matter. AHCI and BSOD. No AHCI and everything works.

I would like to use AHCI as I have a portable SATA drive and I believe I require AHCI to be enabled to be able to Plug and Play or hot swap the drive.

Thank you all for your help.

Mark
Glad its solved just curiosity for others. wonder why AHCI is giving you fits?

Ken
My System SpecsSystem Spec
02 Jul 2009   #16
mtp

Server 2012 R2, Windows 8.1 , W7 ultimate x64
 
 

[QUOTE=zigzag3143;153600]Glad its solved /QUOTE]

Thanks for the thought (and the help), but for me the problem is not really solved as I would like to be able to use AHCI to enable hot swapping of SATA drives. I am happy to have a work around though.

Mark
My System SpecsSystem Spec
02 Jul 2009   #17
usasma
Microsoft MVP

 
 

Ah, the problems with using beta software
There are issues with a particular section of the coding for storage drivers (I found this out from Microsoft when reporting a bug on the Connect site). You have to use Windows 7 drivers in order to ensure that the storage stuff will work - so I'd suspect that this would also affect the AHCI functions. In my case, it required that I purchase a new RAID card - since the company (HighPoint) wasn't going to make Win7 drivers for my old RAID card.

Neither Intel nor Gigabyte offers Win7 drivers for this chipset. You may want to try these drivers direct from Intel (using the Vista x64 one's)
Download Search Results!
Download Search Results!
Don't forget to install them in Compatibility Mode for ALL USERS - using "Run as Vista" and "Run as administrator".
Good luck!
My System SpecsSystem Spec
06 Jul 2009   #18
mtp

Server 2012 R2, Windows 8.1 , W7 ultimate x64
 
 
Vista drivers did not quite solve the problem

Quote   Quote: Originally Posted by usasma View Post

Neither Intel nor Gigabyte offers Win7 drivers for this chipset. You may want to try these drivers direct from Intel (using the Vista x64 one's)
Download Search Results!
Download Search Results!
Don't forget to install them in Compatibility Mode for ALL USERS - using "Run as Vista" and "Run as administrator".
Good luck!
Usasma:

Thanks for the suggestions and your continued help. Sorry for not getting back to you earlier but I had some big work things com up on Friday and I did not have access to the computer in question over the weekend.

Anyway, I tried the earlier vista drivers as you suggested and things went somewhat better - BSOD 1 out of 5 wakes (instead of every time), but I had other problems coming out of wake (sometimes USB devices did not work, other times apps would hang or restart).

So, reverted back to disabling AHCI and did a system restore to bring me back to the previous chipset drivers.

Here, it became interesting again. I got to the welcome screen and the machine sat there. After 5 minutes, the machine went to sleep. I woke it up ... it sat there for 5 minutes then went back to sleep. (note sleep is set for 5 minutes)

I repeated this 5 or 6 times, then reset the machine and booted into safe mode where the restore completed successfully. The machine now works as before and I will leave it like this until the RTM comes out.

Thank you very much for your help and triggering the thought that the problem could be related to AHCI and the storage system.

Best regards,

Mark
My System SpecsSystem Spec
11 Oct 2009   #19
mrsleeepy

Windows 7 RC
 
 

Hi Mark,

I'm not sure if you've since found a solution as the last post was a while back.

I've been struggling with the same problem on my HTPC - BSOD with kernel_data_inpage_error and the 0x7A error on wake from sleep - really annoying when you turn the machine on just before a show you want to watch!

I've upgraded to the latest intel chipset drivers and installed the Intel Matrix Storage Manager - both from the intel website (windows update seems to be a little bit behind). It only updated the ICH10R and the AHCI drivers during installation and I have't had any problems since.

Hope this helps.

Antony
My System SpecsSystem Spec
Reply

 7264 BSOD on wake when media center active




Thread Tools




Similar help and support threads
Thread Forum
Media Center PC random reboots and sometimes bsod
My HTPC randomly reboots and occasionally blue screens. Sometimes the system goes several weeks with no problem, and other times it may reboot and bsod multiple times in one day. I have the following hardware: I7 860 CPU Dh55tc mobo (Intel) 4 GB ram Evga gt 430 graphics card Samsung 128gb...
BSOD Help and Support
Media center power on (not wake) PC
I'm leaving town for a few days and want media center to continue to DVR my shows in my absence. Trouble is, we've been having intermittent power outages in the area and of course the computer is turned off when this happens. WMC wakes my PC fine from sleep or hibernation, Can it be configured to...
Media Center
XBOX media center won't connect to windows 7 media center computer
Hi, I've been looking through all these threads regarding this issue and I can't figure it out. For some reason I have an older desktop running XP MCE and without trying to configure anything it automatically sees the XBOX on the network. I'm not interested in running it through that computer...
Media Center
Media Center/dvd rip or watch BSOD
Hi, I have never had a problem before the last the month, every time i tried to either watch a movie or rip one with media center open i will get the BSOD. Im not sure how to read them so i have zipped up the required files to be read. Im running a year old maching with -amd x2 2.7 -win 7 32...
BSOD Help and Support
hp media center m8200n BSOD. PLEASE HELP!
Hello I have an hp media center m8200n pc. Ive had it for about 2 years now. My problem is I keep getting constant BSOD's on my pc. Ive looked up forums regarding problems with this computer and people report that around two years they experience freezing, automatic restarts, or BSOD's with the...
BSOD Help and Support
BSOD when resuming from sleep if media center running
When I put my machine to sleep (either allowing the power options to do it for me or selecting sleep from the shutdown mennu or from media center so how makes no difference) it fails to restart & I get a BSOD with kernel_data_inpage_error with the first code 7A and the second code of 20. I'm on...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:32.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App