Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sending Dolby Digital signals to external reciever?

24 Jul 2009   #11
mikinho
Microsoft MVP

6x W2K8 R2 (x64), 6x W7 7600 (x64), 2x Gentoo (x64), 1x Ubuntu 9.04 (x64), 1x pfSense (FreeBSD)
 
 

1- Can you specify what decoders\codecs you have setup for MC7 to use (install Preferred DirectShow Filters Tweaker for Windows 7).

2- Are you running 32-bit or 64-bit?

3- What version of AC3Filter?

4- Did you run through the Media Center speaker setup?


My System SpecsSystem Spec
.
24 Jul 2009   #12
mikinho
Microsoft MVP

6x W2K8 R2 (x64), 6x W7 7600 (x64), 2x Gentoo (x64), 1x Ubuntu 9.04 (x64), 1x pfSense (FreeBSD)
 
 

To add a little more. You have two routes you can go w/ either AC3Filter or FFDShow. I use FFDShow myself. So you'll need to:

1- Setup FFDShow to be used using the tweaker tool

2- Set AC3/DD5.1 & DTS options to SPDIF in FFDShow audio options

3- Disable Audio Mixer in FFDShow audio options

Btw, I read that MC7 was supposed to handle AC3 natively but I haven't seen it work.
My System SpecsSystem Spec
25 Jul 2009   #13
fraseyboy

Windows 7 RC1
 
 

I have FFDShow set to be used with the tweaker tool. Isn't that only for video codecs though?

Quote   Quote: Originally Posted by mikinho View Post
To add a little more. You have two routes you can go w/ either AC3Filter or FFDShow. I use FFDShow myself. So you'll need to:

1- Setup FFDShow to be used using the tweaker tool

2- Set AC3/DD5.1 & DTS options to SPDIF in FFDShow audio options

3- Disable Audio Mixer in FFDShow audio options

Btw, I read that MC7 was supposed to handle AC3 natively but I haven't seen it work.
I have done all these things. It still isn't working. I think the problem is that it is not using AC3Filter or FFDShow as my audio codec.
My System SpecsSystem Spec
.

26 Jul 2009   #14
CBers

Windows 7
 
 

Quote   Quote: Originally Posted by fraseyboy View Post
I have FFDShow set to be used with the tweaker tool. Isn't that only for video codecs though?



I have done all these things. It still isn't working. I think the problem is that it is not using AC3Filter or FFDShow as my audio codec.

No, FFDSHOW does video and audio.

What codecs, and versions, do you have installed ??

Are you running 32-bit or 64-bit W7 ??
My System SpecsSystem Spec
27 Jul 2009   #15
fraseyboy

Windows 7 RC1
 
 

Quote   Quote: Originally Posted by CBers View Post
No, FFDSHOW does video and audio.

What codecs, and versions, do you have installed ??

Are you running 32-bit or 64-bit W7 ??
I am running 32-bit build 7100 Win 7.

I have the Shark007 codec pack which really only includes AC3Filter and FFDShow. AFAIK it included the latest versions when I downloaded it a week or so ago.

I know FFDShow does video and audio, but I thought that win7 ds codec tweaker thing was only for changing the video codecs.
My System SpecsSystem Spec
27 Jul 2009   #16
mikinho
Microsoft MVP

6x W2K8 R2 (x64), 6x W7 7600 (x64), 2x Gentoo (x64), 1x Ubuntu 9.04 (x64), 1x pfSense (FreeBSD)
 
 

Quote   Quote: Originally Posted by fraseyboy View Post
I am running 32-bit build 7100 Win 7.

I have the Shark007 codec pack which really only includes AC3Filter and FFDShow. AFAIK it included the latest versions when I downloaded it a week or so ago.

I know FFDShow does video and audio, but I thought that win7 ds codec tweaker thing was only for changing the video codecs.
I would recommend uninstalling the codec pack and installing only the components you need. Troubleshooting codec packs is a nightmare and they generally are overkill for all but the most obscure anime fan.
My System SpecsSystem Spec
27 Jul 2009   #17
Shark007

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by mikinho View Post
I would recommend uninstalling the codec pack...
your advice comes from to many years of getting shafted by Klite.
My System SpecsSystem Spec
27 Jul 2009   #18
mikinho
Microsoft MVP

6x W2K8 R2 (x64), 6x W7 7600 (x64), 2x Gentoo (x64), 1x Ubuntu 9.04 (x64), 1x pfSense (FreeBSD)
 
 

Quote   Quote: Originally Posted by Shark007 View Post
your advice comes from to many years of getting shafted by Klite.
No. I've never used a Codec Pack. But I've helped many users with problems associated with them.

I've never used yours and I'm not critizing yours in any way, most of the feedback on this forum is positive with respect to your codec pack.

It is generally much easier to help a user with WMC problems when they install each component individually.
My System SpecsSystem Spec
27 Jul 2009   #19
Shark007

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by mikinho View Post
No. I've never used a Codec Pack.
Being a dev, you mostly have a testbox or partition where you do work without the worry of destruction. On that note, I promise you it installs without touching the native codecs and that it uninstalls cleanly leaving no foul residue.

You really should have a look at my pack. I think you'll be impressed with the Settings interface that I have created which is a fantastic tool for troubleshooting with.
My System SpecsSystem Spec
27 Jul 2009   #20
mikinho
Microsoft MVP

6x W2K8 R2 (x64), 6x W7 7600 (x64), 2x Gentoo (x64), 1x Ubuntu 9.04 (x64), 1x pfSense (FreeBSD)
 
 

Quote   Quote: Originally Posted by Shark007 View Post
Being a dev, you mostly have a testbox or partition where you do work without the worry of destruction. On that note, I promise you it installs without touching the native codecs and that it uninstalls cleanly leaving no foul residue.

You really should have a look at my pack. I think you'll be impressed with the Settings interface that I have created which is a fantastic tool for troubleshooting with.
I've got more virtuals than I'd care to admit, as I'm sure you do as well . (I do love being able to boot into a VHD with W7)

I will give your pack a look
My System SpecsSystem Spec
Reply

 Sending Dolby Digital signals to external reciever?




Thread Tools




Similar help and support threads
Thread Forum
Dolby Digital 5.1 volume control
Does anyone know how to fix volume control in b7000?
Media Center
System Sending Signals That I'm In Indonesia
The thread title might be misleading: I don't KNOW that my system is sending signals that I am in Indonesia, but I believe it might be. Something is very wrong and here are the symptoms seen and steps taken to discover what it is: (1) I have TweetDeck with a filter set up to see certain...
System Security
HDMI / Dolby Digital problem
Hey everyone, this looks like a good forum and I'm glad to have discovered it. So on to first post/problem; I bought a new amplifier, mostly for listening music and for watching movies with (Kenwood RV7000). My laptop is Acer 5755G, and these two are connected with a HDMI-cable. My ampliefier...
Sound & Audio
Windows 7 No Dolby Digital Sound - Please HELP!
Hello, I am coming here for help as I have tried everything possible to get Dolby Digital sound to play my games in. My setup: Custom built desktop with AMD 965 BE Quad Core, Asus M4N98TD EVO motherboard, eVGA GeForce 470 Superclocked graphics card. The motherboard supports native 7.1...
Sound & Audio
5.1: DTS Works, Dolby Digital Doesn'td
Okay, I'm using an ASUS motherboard to output the S/PDIF signal to my Onkyo TX-SR607 receiver. When I go to the device in Windows 7 and do a DTS test I get sound from all 5 speakers, works great. The test for Dolby Digital the front 3 and the sub work, but the sounds for the two back speakers are...
Sound & Audio
Dolby Digital works for DVD's but not mpeg.
I have an a-bit ip-35 pro with the ACL888 audio onboard. There is an optical spdif output that I have running to my receiver. If I put a dvd in the drive I get the dolby digital plus logo in the lower left corner and great sound using Windows Media player. When I play an mpeg, the receiver...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:02.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App