Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Use 64bit media center with 32bit media player

25 Jul 2011   #1
ratulupadhyay

Windows 7 Ultimate x86
 
 
Use 64bit media center with 32bit media player

Hello guys,

I'm in grave problem here. I just installed windows 7 x64 a few days back. And initially I installed the 32bit version of k-lite codec pack for my windows media player. The media center worked fine then. It was loading my ffdshow and ac3filter along as I checked it.

But then yesterday I noticed that the same pop-up od recommended/express install of WMP came again. Initially I thought that it must be some bug or something, but then when my MKV and AVI files didn't work in WMC, I realized that somehow WMP x64 got triggered, and now it is using the x64 bit of WMP in WMC. And I just wanna revert back to 32-bit WMP in WMC.

The problem is that I use avisynth with ffdshow. And many of the codecs don't work in the 64bit version, as they were never released for the x64.

Please help me out.


My System SpecsSystem Spec
.
25 Jul 2011   #2
razy60

windows 7 64 bit and dual boot Pinguyos
 
 

Are you sure you are running 64 bit your specs say it is 32bit?(x86=32bit)
My System SpecsSystem Spec
25 Jul 2011   #3
ratulupadhyay

Windows 7 Ultimate x86
 
 

Yeah I just installed it a few days back, as I mentioned it above.
My System SpecsSystem Spec
.

25 Jul 2011   #4
razy60

windows 7 64 bit and dual boot Pinguyos
 
 

Yeah sorry read it but wasn't looking.
When you open WMP on its own and play a file what does it show in task manager? then try the same in wmc if it shows WMPlayer.exe*32 then you have a codec problem and you need to uninstall the codec pack and redownload the latest version and install, when you install choose custom and then select to associate all files with WMP.

Link which may help
http://www.thehtpc.net/htpc-tips-and...-media-player/
My System SpecsSystem Spec
25 Jul 2011   #5
ratulupadhyay

Windows 7 Ultimate x86
 
 

Well, as it turns out it is the 32-bit wmplayer running in the taskbat. I thought that WMC was loading the 64bit version. So I uninstalled all the codecs, restarted the PC, installed the latest version, and well it didn't work out. It's still the wmplayer*32.exe running in both cases, but my ffdshow and ac3filter loads only in WMP and not in WMC.
My System SpecsSystem Spec
25 Jul 2011   #6
razy60

windows 7 64 bit and dual boot Pinguyos
 
 

when you reinstalled did you choose custom then ensure that all the file associations were clicked for wmp cinema(i think it is)
My System SpecsSystem Spec
25 Jul 2011   #7
ratulupadhyay

Windows 7 Ultimate x86
 
 

Well You mean the WMP. Well, yeah, I don't install the Media Player Classic at all. So all file associations were made for WMP.
My System SpecsSystem Spec
26 Jul 2011   #8
razy60

windows 7 64 bit and dual boot Pinguyos
 
 

Did you use the mega codec pack or the normal one?
You could try, Uninstall klite and all its components run CCleaner then download shark007 codec pack and install that from what i hear it works well.
Shark007's FREE Codec solutions - Windows 7 codecs
My System SpecsSystem Spec
26 Jul 2011   #9
ratulupadhyay

Windows 7 Ultimate x86
 
 

Well I've always used the standard pack. The main problem here is that it was working without any troubles till yesterday. And then suddenly when I planned to watch a movie, bam, everything from ffdhsow, directvobsub and ac3filter, stopped loading. Well I'm working on finding a probable solution, before going onto the final resort, i.e changing my beloved k-lite.

I've been using it for 2-3 years without any troubles.
My System SpecsSystem Spec
26 Jul 2011   #10
ratulupadhyay

Windows 7 Ultimate x86
 
 

Well, I've noticed some things. I use ffdshow to resize/upsacle every format on my computer. So in WMC, when I play the avi files, ac3filter and directvobsub do load, but the ffdshow doesn't. And when I'm playing some MKV files, nothing loads up. And haali which is the default renderer in both cases doesn't load up too.

What does this mean?
My System SpecsSystem Spec
Reply

 Use 64bit media center with 32bit media player




Thread Tools




Similar help and support threads
Thread Forum
Windows Media Center & Media Player icons are missing
When I click Start, All Programs, there are no icons/listings for Windows Media Center or Windows Media Player. How do I get them back? How do I re-install Windows Media Center and Windows Media Player? I am running Windows 7 Home Premium 64bit
Media Center
Windows Media Player vs Zune Software vs Media Center?
I have 3 media options on my computer right now. I have the all purpose Media Player, the Television connecting Media Center, and the Zune compatible Zune Software. Could someone please provide the pros and cons to each maybe, and help me decide which should be my preferred choice? Thanks. What...
Music, Pictures & Video
media player (& media center) library data gone
feel like a noob. but after moving a few files and folders around last night in order to 'better' organize my media, i seem to have done something that i cannot identify that's caused all the library data in my media player (and thus my media center) to disappear. i've tried to 'restore...
Music, Pictures & Video
DVD playback stops in Media Center and Media Player
Hi, I have checked two seperate DVD movies and they stop after the splash screens, FBI warning and Corporate logos, and never make it to the DVD menu. This DVD player is an external player and I have no problem with playback on my Dual boot with Vista Home Premium. Any suggestions?:p ...
Media Center
Media center 'jump' unresponsive but media player fine
Hi everyone, I'm having trouble with MCE being unresponsive to user input. I have an AVI file ,(properties are listed below,) which plays back fautlessly in media player but media center seems unresponsive to user input during playback. In particular it is nearly impossible to be able to jump...
Media Center
Media Player and Media Center Hang when playing videos
I have recently installed Win 7 Ultimate When playing video files in Media Player or Media Center they will hang up periodically a few secs / mins then continue again. No errors show up in the event logs, except for alot of services entering start and stop state. I have the latest Win 7...
Media Center


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App