Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Quality drop in 7MC compared to WMP12 (X64)

23 Jul 2009   #1
chessdragon136

Windows 7
 
 
Quality drop in 7MC compared to WMP12 (X64)

Hi

I think the title sums up my problem. The quality in Media center is worse than it is in WMP. I understand that the default WMP is x86 and media center always uses x64 but i cannot believe that is the problem. My videos seem more grey/whitewashed in 7MC and have lost their colour.

Was using sharky's Win7Codec and the x64 addon. However uninstalling both thoroughly hasnt improved things.

(Edit: Thought id include a screenshot (not the best: http://ioj.com/v/mchhj )

Any thoughts appreciated.


My System SpecsSystem Spec
.
23 Jul 2009   #2
mikinho
Microsoft MVP

6x W2K8 R2 (x64), 6x W7 7600 (x64), 2x Gentoo (x64), 1x Ubuntu 9.04 (x64), 1x pfSense (FreeBSD)
 
 

What build are you running? If 7100 or below I'd probably wouldn't spend much time troubleshooting as many fixes have been made since then.

What file type are you using an issue with?

To start with I'd download the Preferred DirectShow Filters Tweaker for Windows 7 and see if there is any difference for 32 and 64

Btw, I'd stay away from codec packs. Most do not uninstall well and they are not needed. It is much easier for troubleshooting to manually install ONLY what you need.
My System SpecsSystem Spec
23 Jul 2009   #3
chessdragon136

Windows 7
 
 

Yeah running 7100. The problem is i need to use this for a couple of months...

Well most of my stuff is avi or mkv and probably therefore mostly Xvid.

And no theres no difference there all set to using microsoft. Its the only option there. Im half tempted to install x64 ffdshow and set it using that to see if theres any difference...
My System SpecsSystem Spec
.

23 Jul 2009   #4
mikinho
Microsoft MVP

6x W2K8 R2 (x64), 6x W7 7600 (x64), 2x Gentoo (x64), 1x Ubuntu 9.04 (x64), 1x pfSense (FreeBSD)
 
 

Quote   Quote: Originally Posted by chessdragon136 View Post
Yeah running 7100. The problem is i need to use this for a couple of months...

Well most of my stuff is avi or mkv and probably therefore mostly Xvid.

And no theres no difference there all set to using microsoft. Its the only option there. Im half tempted to install x64 ffdshow and set it using that to see if theres any difference...
I would suggest trying Haali and ffdshow x64. After installing you'll need to use the Preferred Tool.

Out of curiousity have you tried WMP x64 as an comparison. This could rule out x64 vs x32 decoders\codecs.

And I'm not suggesting piracy but some of the leaked non-RTM builds (i.e. 7268) are widely available and the RC keys will work with them.
My System SpecsSystem Spec
23 Jul 2009   #5
chessdragon136

Windows 7
 
 

Ok Haali and ffdshow X64 showed no improvement.

WMP x64 is the same as WMP x86... So its now WMP v 7MC

And i would try 7264 but im too set into 7100 now with programs, setting and the like.. Its not that its unwatchable but the greyish look is distracting.

Thanks again
My System SpecsSystem Spec
23 Jul 2009   #6
mikinho
Microsoft MVP

6x W2K8 R2 (x64), 6x W7 7600 (x64), 2x Gentoo (x64), 1x Ubuntu 9.04 (x64), 1x pfSense (FreeBSD)
 
 

Have you run through the Media Center setup, specifically the display setup?
My System SpecsSystem Spec
23 Jul 2009   #7
chessdragon136

Windows 7
 
 

Yeah done the display setup but most of the later setup changes it on the monitor and not in the program.
My System SpecsSystem Spec
23 Jul 2009   #8
mikinho
Microsoft MVP

6x W2K8 R2 (x64), 6x W7 7600 (x64), 2x Gentoo (x64), 1x Ubuntu 9.04 (x64), 1x pfSense (FreeBSD)
 
 

Well if your video card drivers are up-to-date then I think you may be out of luck, could just be a RC issue. Sorry I couldn't be more help.
My System SpecsSystem Spec
Reply

 Quality drop in 7MC compared to WMP12 (X64)




Thread Tools




Similar help and support threads
Thread Forum
WMC Playing Recorded Wtv Video quality compared to (WMP or VLC)
My computer's build is quite new. I have a Hauppauge TV card, and with a cable card. The jig is this: When I watch recorded TV within 'Windows Media Center' the quality is not good - The framerate is noticeably lacking and often the audio and video is out of sync (I realize this is a common...
Media Center
Graphics Card Picture Quality and Video Quality
Hello, I'm having problems with my the graphics card on my laptop. It's an APU and I have picture and videos problems. Whenever I watch movies or look at pictures I see most things fuzzy, (if that makes any sense). I tried to watch a DVD and the video quality was unbearable. The most...
Graphic Cards
Low fps in games compared to XP
I somewhat managed to improve my framerate alot by: 1.Downgrading my drivers to WDDM1.1(I dont know why but for my rig 11.2 drivers are horrible) 2.Turning off catalyst AI , which gave me big framerate boost(again why??, In xp there were no difference turning it on or off). 3.Setting...
Gaming
SSD performance in seven compared to Xp
I've been messing with different OS's and comparing performance of the intel 80gb gen 2 ssd with different benchmark tools. I have found the ssd performs better in Xp pro 32 bit than in either 7 32bit or 7 64 bit. I tried different drivers, intel and Microsofts, on the different OS's. The...
Hardware & Devices
windows 7 compared to XP Pro
I subscript to several PC magazines each month and most of the reviews are written comparing Win 7 to Vista.:cry: I never ran a vista machine and don't plan to, but i have 3 XP units up and well. The point being, the articles are for Vista folks. Have the XP millions just left the Planet...
General Discussion
Poor video quality on all players except WMP12
Hi, i've seen that its a common problem but i couldn't find a solution to it. Only Windows media player plays the videos well. others just give very poor quality. i installed Latest versions of Nvidia Driver, and then tried Old version as Well. I even tried Vista drivers, but Nothing Worked. What...
Music, Pictures & Video


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:02.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App