Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WMC can not open the program because of a software restriction policy

06 Jan 2013   #1

Win 7 64bit ultimate
WMC can not open the program because of a software restriction policy

I can't no longer start Windows Media Center, when I try It get out the message "can not open the program because of a software restriction policy". I have Win 7 Ultimate 64bit
It is the only program that not starts and that occurred a few days ago after installing and uninstalling some alternative such mediacenter softwares as Mediaportal and Nextpvr.
I've tried everything.
1 System restore..... impossible!: Mc:
2 Malawarebytes, ComboFix, thinking of a virus .... nothing!
3 Uninstalling and reinstalling Windows media center .... nothing!
4 Reinstall and reuninsinstalling of Mediaportal and Nextpvr nothing!
5 Event Log does not show any event at the error msg!
6 Local Security Policy. I entered a new rule with the path to the Wmce ehshell.exe making explicit without restriction .... nothing!
7 Installing all new updates of Win 7 ....
8 Searching on the internet ... not much!
9 Lourdes or a miracle ???
Who can give me a hand before thinking about formatting!

My System SpecsSystem Spec
09 Jan 2013   #2

Windows 7/64 HPremium.

Why is System Restore impossible? Please explain/ Also, a short list of you System Spec's would help.

I think you must be aware that the answer to your problems lies with the way you have installed (and then uninstalled) various different Media Players. You may have several conflicts set up in your sysytem by this: there will probably be leftover garbage in the Registry from it all. Do you have CCleaner, or another Registry Checker? If not, instal CCleaner from here:

CCleaner - PC Optimization and Cleaning - Free Download

and use the 'Registry Cleaner' to find any leftover garbage, such as pieces of software that did not uninstall. You could also carefully explore the registry using <regedit> to find anything which refers to the programmes you installed and then uninstalled.

I don't think the problem lies with any "nasties" on your PC, more that you have a software conflict, caused by installing the alternatives. As a rule, if I am tempted to try another version/alternative to any software I have on my PC, I uninstall the original before installing the alternative. Or you could run it in a Virtual box.

If you try to install Windows Media Center again, have you tried to do it by a right click and "Run As Administrator"?
My System SpecsSystem Spec
09 Jan 2013   #3

Windows 10x64 Build 1709

Have you tried running a sfc/scannow? It'll find and repair any corrupted system files ........ thinking you might have messed something up with all those install/deletions. Run it three times , rebooting after each.

SFC /SCANNOW Command - System File Checker

Also..... have you reset the defaults?
My System SpecsSystem Spec

11 Jan 2013   #4

Win 7 Pro x64 x 3, Win 7 Pro x86, Ubuntu 9.04

Reinstall Windows. Doesn't sound like the system is in that good of a state, and reinstalling will only take a few hours, probably end up being faster than all of the troubleshooting you're doing.
My System SpecsSystem Spec

 WMC can not open the program because of a software restriction policy

Thread Tools

Similar help and support threads
Thread Forum
Problems in config software restriction policy to restrict all apps
I don't want any standard user to run any application expect those which are already installed, so I created a path rule in software restriction policy and disallowed all applications (.exe, .msi & .msp) except those which are present in windows & program files folder. But problem is that some...
System Security
SRP (Software Restriction Policies) blocking local Administrator
I implemented SRP on a Windows 7 Pro PC that I was logged into as the Local Administrator. In Enforcement I ensured that "All users except local administrators" was selected. I then set the default Security Level to Disallow. At this point I attempted to open Windows Update from the Start menu and...
System Security
Software Restriction Policies is wrongly applied to Administrator
I have Windows 7 64-bit and have configured Software Restriction Policies so that "Disallowed" is the default security level. I also have Path Rules defined so that software in C:\Program Files, C:\Program Files (x86), and C:\Windows can execute. I also want it to apply to only my limited user...
General Discussion
Local Policy restriction issue
I'm working with a Window 7 Enterprise 64-bit system. It seems that anyone in the Administrators group that tries to open Internet Explorer gets the error "Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item." First off, anyone...
General Discussion
restriction software
hi am new here i need a good internet restriction softwares

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:13.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App