Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WMC no longer properly playing movies from library

02 Dec 2009   #1

Windows 7 Ultimate
WMC no longer properly playing movies from library

So I've copied a few of my Blu-Rays to my computer for ease of viewing, and when I originally did that, the movies would play fine when I opened WMC and clicked "Movie Library", then clicked the movie I wanted to play.

Now, for some reason, when I hit "Play Now" it goes to a screen that basically is looking for a disc in the BD-DVD player. On this screen I have the options to Resume, Restart, Chapter Viewer, Eject, Settings, and something else. This screen is still in WMC, but it has the PowerDVD wording across the top. (I use PowerDVD 9 Ultra for my Blu-ray viewing).

I don't recall doing anything from between the time the video library worked and now, besides rebooting a couple times perhaps or listening to music. To watch these movies I have to open up WMP and open the appropriate AVCHD file, an annoyance to say the least.

Any ideas whats up? If you need anymore information let me know.

My System SpecsSystem Spec
03 Dec 2009   #2


Digital Content Protection.
My System SpecsSystem Spec
03 Dec 2009   #3

Windows 7 Ultimate

Um, nah I don't imagine that is it. Like I said it worked fine for a few days, and anytime one usually runs afoul of digital content protection whatever program I'm using is "nice" enough to let me know.
My System SpecsSystem Spec

04 Dec 2009   #4


OK, I am glad you have solved your issue.
My System SpecsSystem Spec

 WMC no longer properly playing movies from library

Thread Tools

Similar help and support threads
Thread Forum
New library for Movies only from C to E
Hii everybody I know there are lots of tutorials for Library. It help me to transfer all my library To E partition. Thx to Brink tutorial and repair downloads.:) As you can see I called the Map on E:LIBRARY and I merged the maps with my users, so I'm always using the same folders with to...
General Discussion
The Movies Not Installing Library Not Registered
Okay so I have the Movies the game and when I try to hit autorun it tells me the library is not registered. So I googled it and found out that I had to find the setup file and run it as the administrater. So when I open the movies in a new folder everything comes up fine but when I try to hit into...
Changing Videos Library name to Movies?
I try to rename the Library Videos to the name Movies and after i hit okay, it returns to the name Videos. I tried opening the library in notepad, and the title of notepad is Movies, but the name still remains Videos in my library directory. I even tried to delete videos and create a new library,...
How do I delete movies from my movie library?
Hello, new to Windows 7 Media Center and these forums. I have begun backing up my movies onto an external hard drive, and have encountered a slight annoyance: I have a few "movies" showing up in my movie library that don't have any files associated with them, and I'm not even sure how they got...
Media Center
Not found movies in my library
My library is empty today. Yesterday was working fine. I have reseted WMC and I added the folder with movies in the setup. It doesn´t work. I have created a new user for a test and it´s not working. I have deleted the media player's database and the same problem. What can I do? Thanks!
Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App