Windows 7 Forums

Frog Frog is offline

Junior Member

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 18 Dec 2017
  • Join Date: 19 Nov 2013

System Spec

    Computer type
    PC/Desktop
    Computer Manufacturer/Model Number
    custom build
    OS
    Microsoft Windows 7 Professional 64-bit SP 1
    CPU
    Intel(R) Core(TM)2 Quad CPU Q9400 @ 2.66GHz
    Motherboard
    MICRO-STAR INTERNATIONAL CO.,LTD P45 Neo3 (MS-7514)
    Memory
    6.00 GB
    Graphics Card(s)
    NVIDIA GeForce GTX 650 Ti
    Sound Card
    (1) High Definition Audio Device (2) High Definition Audio
    Monitor(s) Displays
    2x Dell 2007FP, 1x Dell U2711
    Screen Resolution
    Dell 2007FP 1600x1200 - Dell U2711 2560x1440
    Hard Drives
    Crucial_CT128M550SSD1 ATA Device
    WDC WD20EADS-00R6B0 ATA Device
    PSU
    Corsair HX620 (I think)
    Case
    Case
    Cooling
    Xigmatek - not sure the model
    Keyboard
    Logitech G110
    Mouse
    Microsoft 1113
    Internet Speed
    Slow! ADSL approx 3 Mbps on a good day
    Antivirus
    Norton Internet Security
    Browser
    Firefox 53.0, Chrome Version 58.0.3029.81
    Other Info
    Default System BIOS - V1.1

Mentions

No results to display...
Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:28.
Twitter Facebook Google+