Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: I can't print my documents after disabling a bunch of Windows services

24 Dec 2014   #1

Windows 7 Ultimate x64
I can't print my documents after disabling a bunch of Windows services

I have an old and low-performance laptop. It was working very slow and using too much CPU. I decided to turn off (disable) unnecessary services to give it a boost. And I did so; now my system works much faster. The complete and exact list of disabled services are listed below.

Application Management
Base Filtering Engine
    IPsec Policy Agent
    IKE and AuthIP IPsec Keying Modules
Bonjour Service
Cryptographic Services
Desktop Window Manager Session Manager
Diagnostic Policy Service
Distributed Link Tracking Client
Extensible Authentication Protocol
Extensible Authentication Protocol
    WLAN AutoConfig
Function Discovery Provider Host
    HomeGroup Provider
Function Discovery Resource Publication
Human Interface Device Access
Intel(R) Rapid Storage Technology
IP Helper
Network Connections
Network List Service
Network Location Awareness
Offline Files
Peer Name Resolution Protocol
    Peer Networking Grouping
Peer Networking Identity Manager
Program Compatibility Assistant Service
Protected Storage
RtVOsdService Installer
Sandboxie Service
Security Center
Shell Hardware Detection
SQL Server VSS Writer
Windows Font Cache Service
Windows Media Player Network Sharing Service
Windows Presentation Foundation Font Cache
(Note: The indented service names are dependent to the preceding ones in the list.)

I have been using my system for one or two months with those services disabled without any problem. Today, I tried to print an MS Word document into a PNG file. But I saw that no printers are listed. I clicked on the "Add Printer..." button and got this error message:

[File in the directory]
The Active Directory Domain Services is currently unavailable.

Note: I don't have a physical printer, instead I have installed a virtual printing software called "PDF Creator", which prints documents to PDF or PNG files. It was working perfectly fine.

The problem is definitely due to those disabled services. It looks like I disabled a critical service among all those unnecessary ones. I really don't want to re-enable all those services one-by-one and try restart the system after each one. Can you please tell me which service is causing this problem?

Windows Version: 7 Ultimate x64 SP1
Office Version: Professional Plus 2013

My System SpecsSystem Spec
28 Dec 2014   #2

Windows 7 Ultimate x64

I saw that the "Print Spooler" service was not running. I tried starting it. It wasn't disabled; it was in the "manual" mode. Once it started, I was able to print my document. I don't know why, but somehow, the programs are not able to manually start the Print Spooler service on their own. I will be glad if someone explains the reason for this.
My System SpecsSystem Spec
28 Dec 2014   #3

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1

Print Spooler service should have startup type=automatic
When I stop the service.... printer dialog doesn't popup so no job can be sent to printer queue.
My System SpecsSystem Spec

28 Dec 2014   #4

Windows 7 Ultimate x64

Can I make a simple .bat file which will start PS service when I run it? If yes, what commands should I write in it?
My System SpecsSystem Spec
28 Dec 2014   #5

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP

A service set to automatically start should be started after booting up or rebooting.

Some suggestions on the batch file question:
My System SpecsSystem Spec
29 Dec 2014   #6

Windows 7 Ultimate x64

Would this work?

Toogle Print Spooler.bat
for /F "tokens=3 delims=: " %%H in ('sc query "Print Spooler" ^| findstr "STATE"')
    if /I "%%H" NEQ "RUNNING"
        net start "Print Spooler"
        net stop "Print Spooler"
My System SpecsSystem Spec

 I can't print my documents after disabling a bunch of Windows services

Thread Tools

Similar help and support threads
Thread Forum
Have to stop/start Print Spooler to get documents to print?
(Windows 7 Home Premium 64-bit, HP LaserJet CP1215) When printing from Word (or any other normal application) the documents just sit in the print queue with Status = "Error - Printing". If I stop, then re-start the Print Spooler service, they then print. Strangely enough, this does not...
Hardware & Devices
Can't get on computer after disabling services.
I use a fingerprint reader to get onto my account. I swipe my finger and it lets me on. I also have a password on my account, but I haven't had to use it in a long time and I forgot what it was. I was having a problem with Visual C++ 2008 Redistributable, so I performed a clean boot. I...
General Discussion
Disabling Windows 7 Services
I don't use most of the Windows 7 services... like Windows search, Windows Update, Bitlocker etc and I'm looking for a list of unnecessary services that are safe disable.. Thanks.. :confused:
General Discussion
Disabling Windows 7 Services
To skip the reason for my question below you can go directly to the bottom of the post "My question is:" Over the last week I decided to take some steps to improve the amount of available Physical Memory and Performance on my main use computer. I have already posted that I was able to pick up...
Performance & Maintenance
Dealing with disabling services in XPMode
Does anyone know if xp mode uses any specific services that are crucial to its startup in windows 7 that I should avoid disabling in following the black viper website, in order to speed it up a little? Also, I am a bit disappointed in learning that xp mode doesn't support the installation of...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:39.
Twitter Facebook Google+