Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Office Click-to-Run Extensibility Component can't modify registry keys

13 Aug 2016   #1

Dual boot - Win 7 Pro 64-bit and Win 10 Pro 64-bit
Office Click-to-Run Extensibility Component can't modify registry keys

In installing and re-installing Office 365 Home (64-bit install on Win 7 Pro 64-bit), I get approx. 137 Warnings in Event Viewer like the following:

Product: Office 16 Click-to-Run Extensibility Component. The application tried to modify a protected Windows registry key \msinkdiv.InkDivider.1.

I did a deep uninstall and reinstall just to see if this could be avoided, but no. It happens on each install or repair or reinstall.

Here's all the info for one of these - but keep in mind there are 137 different ones (different keys being named):
Log Name:       Application
Source:        MsiInstaller
Date:          8/13/2016 1:48:06 AM
Event ID:      1039
Task Category: None
Level:         Warning
Keywords:      Classic
User:          SYSTEM
Computer:      WINDOWS-[my PC]
Product: Office 16 Click-to-Run Extensibility Component. The application   tried to modify a protected Windows registry key   \msinkdiv.InkDivider.1.
Event Xml:
<Event xmlns="">
    <Provider Name="MsiInstaller" />
    <EventID Qualifiers="0">1039</EventID>
    <TimeCreated SystemTime="2016-08-13T05:48:06.000000000Z" />
    <Computer>WINDOWS-[my PC]</Computer>
    <Security UserID="S-1-5-18" />
    <Data>Office 16 Click-to-Run Extensibility Component</Data>
[/INDENT]- System  

  - Provider  

 [ Name]MsiInstaller 

  - EventID1039  

 [ Qualifiers]




  - TimeCreated  

 [ SystemTime]2016-08-13T05:48:06.000000000Z 



 ComputerWINDOWS-[my PC] 

  - Security  

 [ UserID]S-1-5-18 
  - EventData  

Office 16 Click-to-Run Extensibility Component 







7B39303136303030302D303038432D303030302D313030302D3030303030303046463143457D[INDENT]Binary data:
 In Words
 0000: 3130397B 30303036 30302D30 302D4338 
0008: 2D303030 30303031 3030302D 30303030 
0010: 43314646 7D45 
 In Bytes
 0000: 7B 39 30 31 36 30 30 30 {9016000
0008: 30 2D 30 30 38 43 2D 30 0-008C-0
0010: 30 30 30 2D 31 30 30 30 000-1000
0018: 2D 30 30 30 30 30 30 30 -0000000
0020: 46 46 31 43 45 7D FF1CE}
SO - What do you think?

My System SpecsSystem Spec
13 Aug 2016   #2

Windows 7 Home Premium 64 bit sp1

It seems this might be a problem associated with Windows 10. I see you have both Windows 7 & 10. This website might offer some solutions.

There might be some info here as well.
My System SpecsSystem Spec
18 Aug 2016   #3

Dual boot - Win 7 Pro 64-bit and Win 10 Pro 64-bit

Ranger - thanks for interesting links.

However, FYI, I have installed O365 only on my Win 7 Pro 64-bit, not my Win 10 Pro 64-bit.

Your links are interesting, esp. the lennytech, but I have NOT had the worse app-crash issues described in Lenny's artcle. As far as I can tell, my Office 365 Home (which gave me Office 16) is working. But I certainly don't like the numerous Warnings in Event Viewer I describe above.

What's interesting about the lennytech is that when I first installed the O365 with the help of the MS call-in team, the MS tech installed the 32-bit version of O365. I asked him to uninstall and re-install the 64-bit version, and he did. Maybe that first install set up those registry keys and locked them somehow. They have apparently remained locked even though I ran the DEEP O365 uninstall twice.

Not yet ready to try the regedit and uninstall surgery described at lennytech. But it might be an experiment next weekend if no luck elsewhere.

More info:

I went to one of the registry keys in the Warnings and found that its Permissions are Read Only and its Owner is TrustedInstaller.

There are way too many of these keys for me to try to change Owner and Permissions (and then change Owner back).

Is there a generic script for taking a list of keys, changing their owners and permissions, then changing their owners back?

What is MS doing if its own installation program doesn't deal with this?
My System SpecsSystem Spec

18 Aug 2016   #4

Windows 7 Home Premium 64 bit sp1

So we are dealing with Windows 7. This Dell website might be of help, as well as the previous lennytech one with the registry key removal.

How to uninstall Microsoft Office 365 from your Dell PC | Dell US

Is there any reason you want the 64 bit version of Office. MS actually recommend the 32 bit one, unless you have huge spreadsheets or databases to work on. I have the 32 bit version of Office 2013 Pro, running on my 64 bit version of Windows 7 & it works perfectly.

I think you might be on the right track with the 64 bit interfering with the previous 32 bit version registry settings. I don't know of any script for removing registry keys. other than manual deletion & that can be very time consuming, doing a Find search & then deleting.

This MS website might help with what Office version to install. This is just for your info.
My System SpecsSystem Spec
25 Sep 2016   #5

Dual boot - Win 7 Pro 64-bit and Win 10 Pro 64-bit

To all - my many weekend days with MS O365 Help has gotten nowhere. With the help of a MS tech2 in India, an unbelievably thorough UNinstall and REinstall of O365 home still generated my 70 Warnings that something "tried to modify protected registry keys", many of which are about msinkdiv.InkDivider.

The tech2 insisted this is normal. What total garbage.

Has anyone else ever had this?
My System SpecsSystem Spec
05 Jul 2019   #6

Dual boot - Win 7 Pro 64-bit and Win 10 Pro 64-bit

FYI - This is still a problem three years later, after many updates to my O365 Home 64-bit and my Win 7 Pro 64-bit. The only difference is that there are "only" 21 Warnings on each update of O365 Home 64-bit.

Anything new out there?
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
windows component based servicing missing sub keys
Problem with my system. Cannot update windows at all, cannot run sfc, found the servicing to be missing in registry. Trying to install it in some way, also missing all the sub keys in the compononet tab. Help! Getting an error code 8007000d as well as a
Windows Updates & Activation
Can't modify registry key even after changing permissions
I'm trying to modify the HKEY_CLASSES_ROOT\InternetShortcut\shell key in the registry to add a "Open with Chrome" entry so that I can right-click a shortcut and choose whether to open it in IE (default) or Chrome. I know how to create and write this type of key/command, I've done it successfully...
General Discussion
How to modify Cyberfox right click context menu?
I have a couple of questions about the right click context menu in Cyberfox. How do remove the "share this page" entry as shown in the screenshot. Where did it come from? I've tried the context menu editor add on for Firefox but that doesn't remove / hide it.
Browsers & Mail
How to modify permissions registry path
Hello! I need to be able to give permissions back to the users to edit the registry which has been disable by GPO. I am trying this: set KEY="HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Environment" Icacls %KEY% /t /c /grant:r "USERS":f I get: "The system cannot find the path...
General Discussion
UI Extensibility in Office 2010

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:44.
Twitter Facebook