Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Microsoft Excel Application entry missing in DCOMCNFG

20 Jan 2010   #1

windows 7
Microsoft Excel Application entry missing in DCOMCNFG

Hi I'm using windows 7 home premium. I have an application in ASP.Net which uses Excel Application Object. It used to work fine in XP but in Windows 7 I'm getting an error as mentioned below:

Retrieving the COM class factory for component with CLSID {00024500-0000-0000-C000-000000000046} failed due to the following error: 80070005.

I need to give permissions to Microsoft Excel Application in DCOM config but I can't seem to find this in windows 7. It used to be there in earlier versions but now its not there. I tried to reinstall Office 2007 but still I couldn't find it in DCOM config. Please suggest where I can give permissions to MS Excel Application so that my application runs without errors.


My System SpecsSystem Spec
20 Jan 2010   #2

Windows 7 Ultimate x64 Service Pack 1 (Build 6.1.7601)

1. Control Panel -> Administrative Tools -> Component Services
2. Console Root -> Component Services -> Computers -> My Computer -> DCOM Config
3. Right-Click 'Microsoft Excel Application' and choose Properties
4. Click 'Security' tab
5. Customize 'Launch and Activation Permissions'
6. Add the local ASPNET user and give it all permissions
My System SpecsSystem Spec
20 Jan 2010   #3

windows 7

Thanks for the reply.. the problem is that there is no "Microsoft Excel Application" in dcomcnfg.. I'm not able to find it there. I reinstalled Office 2007 also, but still I couldn't find it there.
My System SpecsSystem Spec

26 Apr 2010   #4

Windows 7 Profesionnal 64bits

I have the same problem. I took a look in the registry to find the correct CLSID from the appID but I did not found anything. Is there any workaround or solution ?

Best regards
My System SpecsSystem Spec
28 Apr 2010   #5

windows 7

I found a solution to this problem by giving permissions at system level by following the steps below
1. go to DCOMCNFG
2. In the left tree structure, right click on My Computer and select Properties
3. Click on COM SECURITY tab
4. Give Permissions to Network Service and Users in the "Access Permissions" and "Launch and Activation Permissions" by clicking the Edit Default buttons.

Now check your application.
My System SpecsSystem Spec
04 Aug 2011   #6

Windows 7 64Bit

This does not fully work. Having changed the settings according to your solution, I could create excel reports (via, iis and office). however, a day later, this no longer worked although the permissions are still assigned to the network account (and the account of the iis pool). There must be another setting that affects using Office/Excel in IIS 7.5 on Windows Server 2008/Windows 7

Any help is appreciated
My System SpecsSystem Spec
22 Jun 2012   #7
sam constantine


Use MMC comexp.msc /32 on win7 x64
My System SpecsSystem Spec
05 Jul 2012   #8

windows 7 64

This solution is ...
・Windows 2008 Server x64

Please make this folder.
・Windows 2008 Server x86
Please make this folder.
My System SpecsSystem Spec

 Microsoft Excel Application entry missing in DCOMCNFG

Thread Tools

Similar help and support threads
Thread Forum
Excel data entry issue
Respected sir I hv a excel issue on my win 7 The average of the data not changed wen i change my data the formula is correct n every thing is correct but there is an issue Wen i save the file the data is instantly changed Kindly resolve my issue
Microsoft Office
Application keeps recreating Start Menu entry
I recently switched to Panda Free Antivirus as the previous product I had used started causing problems. thus far, Panda has been great - until the most recent update. With the most recent update, the program keeps recreating its entry in the Start menu, an entry I don't want. Is there any way...
General Discussion
problem reinstalling, missing file or entry
i tried to install windows 7 using the installation cd.i selected the option to download latest installation files from the Internet. After about an hour, it said one of the setup files was missing. I chose repair your computer, and this message appeared: the selected entry could not be loaded...
Installation & Setup
Boot entry missing
I just went to msconfig to check that all my cores were enabled and there is NO boot entry there so I can't access anything on the boot tab (See attachment) What can I do about this please. Andy
Installation & Setup
An entry in registry missing
I want gain an access to com ports and require changed in registry entry of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PNP0501 but it seems the folder is not there. I have tried regcleaner and reg fix did not help. thanks

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:12.
Twitter Facebook Google+