Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Bizarre Office install problem on Windows 7

05 Jul 2010   #1

windows 7
Bizarre Office install problem on Windows 7

I'm trying to install Office 2010 on my Windows 7 PC but neither of my DVD drives can 'see' the program and they both eject the disk when I try to view the disks contents through windows explorer and ask me to insert a disk.

Presuming there may be something wrong with the install disks I tried them on another computer (laptop running XP) to check but it reads the disk fine and I can see the install files with no problem.

So far I've tried, without any success:
- re-booting, several times
- using the other two disks: one works fine which is just the Windows Communicator program install disk, but the other one also can't be read
- cleaning the disks - which were spotless to start with - plus I've had a really good look at them and there are no marks or damage to be seen anywhere
- using other program install disks on both my drives - which all work fine and I can see all the files on the disks

My internal DVD drive is a recently installed Samsung DVD writer and the other one is an Iomega external (USB) DVD writer (which has worked reliably for years), both of which can see ALL other disks whether they are movies, files or install programs, or anything else - and work flawlessly.

So, my PC refuses to read these Office install disks - but the disks themselves are fine and work on other computers and my drives can see ALL other disks. I'm completely baffled.

Anyone have any ideas? Could it be something in the operating system that is preventing the PC from reading these disks?

System is:
Intel Core2Duo E8400
Asus P5N-MX BIOS (Revision 0610)
Windows 7 Home Premium ver 6.1.7600 build 7600
Memory: 2Gb
DVD: Samsung TSSTcorp CDDVDW SH-S223C ATA drive
External DVD: Iomega DVDRW 8440E2D-B USB
Soundcard: Realtek (onboard)
Graphics card: NVIDIA GeForce 8600GT 500Mb
HDD: C: 500Gb NTFS SATA II drive - 231Gb free space (main drive)
External HDD: I: FAT32 500 Gb USB - 46 Gb free space
HDD: K: 1000 Gb NTFS SATA II - 681 Gb free space
AntiVirus Prog: AVG Free v9

My System SpecsSystem Spec
05 Jul 2010   #2
Capt.Jack Sparrow

Windows 7 Ultimate - 64-bit | Windows 8 Pro - 64-bit

Hello !! Welcome to SF !!

From what i understand it could be a defective DVD. That's could be the reason why it's not reading the contents maybe the DVD might not have visible damage but somehow the contents didn't rite to the DVD properly can result this behavior. If its a new disk i would suggested to get a replacement disk from Microsoft. Or check under Microsoft website for a trial version download.

Hope this helps,
My System SpecsSystem Spec
05 Jul 2010   #3

Windows 8 Pro

Just something to test before you return the discs...

Can you make a copy of the discs on the drive that can recognize them? Burn the contents to a CD-R at a reasonable speed. (Don't burn with the highest speed)

Then see if the coppies you made are readable.
My System SpecsSystem Spec

05 Jul 2010   #4

windows 7

It's not a disk problem - they are fine on other computers (I have since tried them successfully on another computer) it's my system refusing to read them..... so duplicate copies will do the same presumably?
My System SpecsSystem Spec
05 Jul 2010   #5

Windows 8 Pro

Some drives are more sensitive to read errors than others. I've had a few brand new DVD's that one drive would read, and the other wouldn't.

It's worth a shot...
My System SpecsSystem Spec
05 Jul 2010   #6

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86

You can extract the contents of the Office install dvd (on the computer which reads the disk) using an app like winrar, then save those to an external hard drive or flash drive. Then install Office 2010 on the misbehaving computer by hooking up the external to it and clicking on the Setup.exe. You can get a trial version of winrar from
My System SpecsSystem Spec
05 Jul 2010   #7

windows 7
Solved it!

Downloaded and ran the automatic firmware upgrade prog for my Samsung drive and it sorted the problem. As this drive is only a couple of months old it seems strange that this has such a dramatic effect - it would never have occurred to me to check for firmware upgrades....

Thanks everyone for your suggestions.
My System SpecsSystem Spec
05 Jul 2010   #8

Windows 8 Pro

Glad you got it sorted.
My System SpecsSystem Spec
05 Jul 2010   #9


Another solution, you dont have to install from the cd itself. You can just copy the files to a computer and run them from there.
My System SpecsSystem Spec

 Bizarre Office install problem on Windows 7

Thread Tools

Similar help and support threads
Thread Forum
Bizarre Problem in Windows Explorer
I have a very strange issue in Windows 7 which I am hoping you can help with. General symptoms are that the system is just running incredibly slowly at times, and has actually driven me to go for an upgrade. Examples of the kinds of things happening now are: When I open my computer, I get a...
General Discussion
Bizarre problem regarding installers
Hello guys. I'm trying to find the cause for my error for almost a year, and had no success so far. I asked on other forums, but never recieved a reply either. I have to give a small background to maybe enlighten the problem for you. My PC had two disks last year: a SSD for the OS (mapped c:\)...
General Discussion
Bizarre Buffalo USB3.0 problem with Windows 7
Hello, I recently, well I say recently but it was late 2011 I decided on building a new RIG, the final hardware change was my external HDD which I bought last week and a couple of days ago I connected and copied everything from my old HDD to the new one. It's insanely fast, USB3.0 is really...
Hardware & Devices
Bizarre Wireless Problem
The main problem is that my ONE computer's security settings do not and will not match to my router. I'll try and list everything I did. Hopefully I won't miss anything. 1. Obviously, I try to look at the settings and see why they don't match. My netbook is also running on 7 Ultimate (32bit),...
Network & Sharing
Bizarre lockup problem
I've been having a weird problem with my new rig for the past few days. Since Monday, it has been randomly locking up. Just freezing solid, forcing a cold reboot. It's less than a month old, and I have only done a test OC to 3800 and it was stable with the core voltage at only 1.34. I have...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:08.
Twitter Facebook Google+