Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: problem with windows seven

23 Apr 2011   #1
Enas

windows 7
 
 
problem with windows seven

Hi,

I have an application for displaying dicom images using delphi 7 and leedtools 13
The application performance is very fast in windows seven

but When I am trying to use windows seven the loading of large images is very slow and applying any filter to this large images is also very solw (while loading small size images is still very fast)

when we try to run this application on windows 7 virstual machine installed on windows 7 the performane is very fast (same as the performane on windows xp)

The technical support of the toolkit leedtools told me that they never use any third parity software

So I need to know if there is any setting in the windows 7 that makes it act like the windows 7 virsula machine

Please help me if you can as this problem is very urgent


My System SpecsSystem Spec
.
23 Apr 2011   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Enas View Post
Hi,

I have an application for displaying dicom images using delphi 7 and leedtools 13
The application performance is very fast in windows seven

but When I am trying to use windows seven the loading of large images is very slow and applying any filter to this large images is also very solw (while loading small size images is still very fast)

when we try to run this application on windows 7 virstual machine installed on windows 7 the performane is very fast (same as the performane on windows xp)

The technical support of the toolkit leedtools told me that they never use any third parity software

So I need to know if there is any setting in the windows 7 that makes it act like the windows 7 virsula machine

Please help me if you can as this problem is very urgent


Can we start by getting your system tools so we know what hardware we are dealing with?
My System SpecsSystem Spec
23 Apr 2011   #3
Shootist

Windows 7 Pro x64
 
 

Quote   Quote: Originally Posted by Enas View Post
Hi,

I have an application for displaying dicom images using delphi 7 and leedtools 13
The application performance is very fast in windows seven

but When I am trying to use windows seven the loading of large images is very slow and applying any filter to this large images is also very solw (while loading small size images is still very fast)

when we try to run this application on windows 7 virstual machine installed on windows 7 the performane is very fast (same as the performane on windows xp)

The technical support of the toolkit leedtools told me that they never use any third parity software

So I need to know if there is any setting in the windows 7 that makes it act like the windows 7 virsula machine

Please help me if you can as this problem is very urgent
No not really.
I think what is going on in the virtual machine is everything is loading from a virtual hard drive, which is compressed, and or stored more in memory so it seems to load faster.
On native Win 7 the program and whatever you are loading into it is being taken directly from the hard drive which are slower then a compressed VM hard drive and or RAM.
What you can do is get yourself a couple SSDs (Solid State Drives) and load the OS and that program and whatever files you are loading into that program and you will see a great improvement in the overall loading speed of the OS , the Program and the files you are loading into the program.

And then it all depend on the overall system performance. So it would be good for yo to fill out your system specs.
My System SpecsSystem Spec
.

23 Apr 2011   #4
mrdemon

Windows 7 Home Pre
 
 

Have you got a USB stick, Use if for "Ready Boost" see if this makes any difference.

Regs...
My System SpecsSystem Spec
23 Apr 2011   #5
Layback Bear

Windows 10 Pro. 64/ version 1709
 
 

No not really and no system specs makes it very hard for anybody to help.
My System SpecsSystem Spec
Reply

 problem with windows seven




Thread Tools




Similar help and support threads
Thread Forum
Printer problem needs guru. Looks like Windows not Brother problem.
Windows 7 Professional Haven't had the need to use my printer in a couple of weeks, so I don't know when the problem started. It is a Brother HL-2270DW that has been problem free. There are tests that can be tried using the printer itself and it says it has a good connection and should be...
General Discussion
UI Problem/ minimized windows Display problem
Hi windows 7 community, I have a problem with windows 7 since the first day i've installed the OS (couple of years), and i haven't been able to solve it yet. The problem is that when i have a main application window, and different documents(windows) open in that main application window, when i...
General Discussion
Laptop Windows 7 Problem/Software/Hardware? Keyboard problem
Okay, right now I'm currently trying to find out whats wrong with a keyboard that is on a laptop, after the computer starts there are some script errors, I don't know exactly what they are but I ran combo fix without safe mode and restarted the scripts went away...and it started working after...
Hardware & Devices
Moving windows/icons down problem!! Move right/left/up - no problem
New system i7 3930K CPU Sabertooth X79 Mortherboard GeForce GTX690 GPU Intel 520 series SSD 32GB RAM Dell U2711 27" Monitor Win 7 Pro
General Discussion
Windows 7 Not genuine Problem. And 404 error (security?) Problem.
Hi, ive had both of these problems for about two weeks and have tried to fix it myself. No luck at all. Dont no of their connected. Help on how to fix it would be greatly appreciated.
BSOD Help and Support
Windows Media Player Problem - Sound/skipping problem.
Oh look, another windows media player problem, lol. Well, it's something really weird, at first i thought it was just my computer being all slow or the file was messed up, No matter what movie or format i play it makes this weird screeching noise. It also lags pretty bad. I tried the scans, i did...
Music, Pictures & Video


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:54.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App