Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Codecs not showing up in Sony Vegas and VirtualDub

18 Aug 2009   #11
Hahaiah

Windows 7 Ultimate
 
 
Solution for LAME and other Codecs in x64 systems

I had issues using LAME in Virtualdub in both Vista 64 and W7 64. Nothing with an installer worked for me and codec packs are usually trouble down the road.

Here's the solution: You can replace LAME with any ACM codec I believe.

CMD PROMPT:
Change directories: CD c:\windows\syswow64
UNZIP your ACM codec to C: (or wherever you want)
TYPE: rundll32 setupapi.dll,InstallHinfSection DefaultInstall 0 c:\lameACM.inf

Won't show up in device mgr because they are 32 bit, but your apps should see them now.


My System SpecsSystem Spec
.
26 Sep 2009   #12
dope

Win 7 Build 7100
 
 

Quote   Quote: Originally Posted by Hahaiah View Post
I had issues using LAME in Virtualdub in both Vista 64 and W7 64. Nothing with an installer worked for me and codec packs are usually trouble down the road.

Here's the solution: You can replace LAME with any ACM codec I believe.

CMD PROMPT:
Change directories: CD c:\windows\syswow64
UNZIP your ACM codec to C: (or wherever you want)
TYPE: rundll32 setupapi.dll,InstallHinfSection DefaultInstall 0 c:\lameACM.inf

Won't show up in device mgr because they are 32 bit, but your apps should see them now.
Hahaiah! You are the freakin man, I was having huge problems getting LAME to show up in VDM until I came across your post! It worked, hell yeah! Props to you!
My System SpecsSystem Spec
Reply

 Codecs not showing up in Sony Vegas and VirtualDub




Thread Tools




Similar help and support threads
Thread Forum
Sony Vegas does Not Open?
Hey guys, I'm new here and trying to sort this out frantically so sorry if it's the entirely wrong place! I was editing on Sony Vegas Premium 10.0 yesterday, but when I came to it today it refuses to open when I click it. Might this have something to do with a newer version of Windows 7? Please...
Hardware & Devices
Sony Vegas launching error
Hey guys. I have already reported to Sony to but i heard their take their time but thats the one thing what i dont have at the moment so i know many people here know about that stuff to. So anyway. Some time ago SP1 launched for W7. I installed but it but something went it wrong and it didn't...
Software
Sony Vegas 11 - Simple Help Needed.
Hi there. Does anyone know how i can get the 'Text' option back that's usually next to 'Media Generators' and 'Video FX'. It randomly disappeared. Please see the picture to see what i mean. http://img802.imageshack.us/img802/3531/capturenq.png Thankyou.
Software
Sony Vegas 9
I have audio but no video it just shows black. This works on my vista but not my windows 7 :(? http://i922.photobucket.com/albums/ad70/jessejw/sonyvegas.png
Software
Sony Vegas & Photoshop
Hey fellars. So first off check my specs, you're going to see that my computer could run these programs with 1/25th of it's capabilities. Now recently, my whole computer has gone to shit, gaming and everything. But that's a different thread. I am going to buy a new GFX card and PSU but, what if...
Music, Pictures & Video
Sony Vegas 8
I installed Sony Vegas 8.0a and i keep getting low memory errors. It doesn't even go above 30% and it says that. This never happened when i had Vista but since i got Windows 7 installed, its been happening. Is there a way to fix it, if you please post. Thanks.
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:37.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App