Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Explorer not showing MP3 tags

12 Jun 2013   #11
Ezway

Windows 7 Home Premium 64bit
 
 
Thank You

Quote   Quote: Originally Posted by General Gilliam View Post
Alright, problem solved. To anyone who's having this problem, and all the posts online saying "oh convert to this tag, or use this program, or make sure it's not 2.4" ect..., try this:

SFC /SCANNOW Command - System File Checker

1. Click start (Windows Icon)
2. Click All Programs
3. Click Accessories
4. Right Click Command Prompt
5. Run As Admin
6. type "sfc /scannow" without the " "
7. Press Enter

Just let it do it's thing, it should detect the corrupted files causing this and automatically replace them.
Thank you so much for posting this! I just discovered this very same problem on my own computer and started freaking out. I tried sfc /scannow and it worked like a charm. Here I thought I was going to have to reorganize all of my music again. It is a very weird thing to happen though. I wonder what caused the problem in the first place though...


My System SpecsSystem Spec
.
12 Dec 2015   #12
PeaceGuard

Windows 10 Pro N x64
 
 
Unfortunately this solution doesn't work for everyone.

I'm having an exactly the same problem. I know I have a Windows 10 operating system, but I know it's not very relevant for this case and this thread exactly fits the problem.

I tried the sfc /scannow solution in cmd, but it only says "Windows Resource Protection found corrupt files but was unable to fix some of them" and nothing changes. I attach the screenshot.

Can you please help me with this?


Attached Thumbnails
Windows Explorer not showing MP3 tags-2015-12-13_021035.png  
My System SpecsSystem Spec
15 Feb 2016   #13
Hashim

Windows 7 Ultimate 64-Bit
 
 

Quote   Quote: Originally Posted by PeaceGuard View Post
I'm having an exactly the same problem. I know I have a Windows 10 operating system, but I know it's not very relevant for this case and this thread exactly fits the problem.

I tried the sfc /scannow solution in cmd, but it only says "Windows Resource Protection found corrupt files but was unable to fix some of them" and nothing changes. I attach the screenshot.

Can you please help me with this?
Hey, mate, I know it's been a few months so I'm not sure whether you've managed to resolve the issue since, but I've just had the same problem with my own PC over the last few days and managed to fix it. Do you/did you have a program called dBpoweramp installed on your computer? This was the problem for me, and I managed to figure it out thanks to the earlier posts in this thread. The problem seems to be that the program makes registry changes to the metadata, and when uninstalled, doesn't restore Windows Explorer's default metadata. The first time I uninstalled the program I did so with a power installer (IOBit Uninstaller), which I think may have contributed to the problem.

To fix the issue, I first ran sfc /scannow from the command prompt. I then re-installed the latest version of the program from the website (it will be a trial version) using largely the same configuration as I did the first time I installed it. I then uninstalled it again, but this time using Windows' default uninstaller rather than IOBit. Note that you'll need to install two different programs. By this point, Windows Explorer should be displaying metadata as normal.
My System SpecsSystem Spec
.

19 Feb 2016   #14
PeaceGuard

Windows 10 Pro N x64
 
 

Hey Hashim.

Thanks for your reply. My problem is still present.
Unfortunately I don't have such a program installed and I never had. And the problem is present since a fresh Windows install, when none of the additional programs were installed.
So unfortunately your advice doesn't solve it for me.

But thanks anyway.
My System SpecsSystem Spec
Reply

 Windows Explorer not showing MP3 tags




Thread Tools




Similar help and support threads
Thread Forum
Tags of FLAC files not showing in Explorer
Hi. For a few days, my portable Avidemux had stopped working for no apparent reason - a 'crash' message occurred with whatever type of video I tried to load. I thought it might be codec related so I installed the Shark007 codec pack (even though I don't believe in using codec packs). Avidemux...
Software
MP3 details window not showing tags.
Yesterday I formated my SSD because of several problems with ATI drivers. Everything looks fine except that MP3 details window doesn't show editable tags like artist, title, album, etc. Here an image of what it looks like currently: http://img201.imageshack.us/img201/4843/xw2e.jpg I'm using W7...
Sound & Audio
Can't view or edit mp3 tags in explorer
I am new to Windows 7, but have been using Windows for many years. I have researched other threads on this issue, but nothing has resolved the problem for me. All my MP3 files are tagged and I can see the data in iTunes and in Windows Explorer on my Vista PC, but in Windows 7 Explorer, all I see is...
Music, Pictures & Video
Photo Tags showing only in Library and not in the original folder
I was under the impression that an entry in the Photo library was a "pointer" to the original file in its folder. Why then does a tag added in the "Pictures library" not show in the file in its original folder. I thought that the advantage of tagging was that the tag went with the photo when...
Music, Pictures & Video
Win 7 Explorer column settings (id3 tags and width)
Hey all, first post here.. I'd like to apply some custom columns to my windows explorer folder views, mainly showing id3 tag info and remembering column widths. I have folder c:\music\, which has ~1200 subfolders so I'm looking for way to make custom settings to c:\music and then applying...
Customization
Can't edit mp3 tags in explorer pane
I can't enter the tags and all I have is the title of the mp3 showing. Something makes me think it has to do with the tag editor I used and maybe not though. I'm using Win7 Home premium. It seems like there is something in the registry blocking modification. I hate to lose all the mp3s that want...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App