Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't play dvd's - AutoPlay isn't available anymore

26 Jul 2011   #1

Windows 7 Home Premium (64-bit Edition)
Can't play dvd's - AutoPlay isn't available anymore

For some unknown reason, I am having trouble playing dvd's on my computer. Before my problems started, I had zero troubles playing a disc. I would pop in the disc, and be able to play/activate the movie one of several ways. For instance, as soon as the disc went in, a pop-up screen would say autoplay - and it would offer a few different ways to play the dvd. Or the other main way, I would click once on the dvd drive just to highlight it, then I would go up to one of the toolbars and click the button "AutoPlay", which would open up a drop-down list and I would select what player I wanted to use.

Here's a screen-cap, showing the AutoPlay button as missing:

Can't play dvd's - AutoPlay isn't available anymore-no-autoplay-button.jpg

Well, none of that is working now. Now when I insert a disc, Windows doesn't give me anyway to play the movie. There's no more pop-ups, and the AutoPlay button is just not available. The only buttons that toolbar offers me -
Burn to disc
System Properties

Where the word "Eject" appears, is where the AutoPlay button always used to be. I also tried right clicking on the dvd drive to bring up the Context Menu, even that doesn't help - because I used to be able to right click and choose the option "Open With" and select a movie player (ie. VLC, MPC, WMP, etc...), but now thats gone too.

I know the dvd drive works, because I can still play dvd's if I go into Windows Media Player and play the movie thru that backdoor way.

I don't know exactly what caused this problem, but I have a few general ideas. Over the past 5 days I been adjusting my RAM timing & voltage settings. I also just did a successfull Update of my BIOS, and installed the most current version of the BIOS - and that flashing went well with no problems. I checked my dvd Drives drivers, and they are all up to date. I also just installed, less than a week ago, a new internal 2TB Hitachi Hard Drive.

Now, I have tried to resolve my problem on my own, with no success. So, let me explain everything I've tried thus far:

I tried to "reset all defaults" - in the Control Panel, AutoPlay section.
I've got the "Use AutoPlay for all media and devices" box selected with a check mark and for all of the other options, I have set "Ask me everytime"

Then I located Shell Hardware Detection (from Services console), and made sure that the “Service Status” is Running, and “Startup Type” is Automatic.
It is running, here's a screen-cap:

Can't play dvd's - AutoPlay isn't available anymore-shell-hardware-detection.jpg

Made sure that CD-ROM AutoRun is not disabled in registry - under this subkey section:
It is enabled, here's a screen-cap:

Can't play dvd's - AutoPlay isn't available anymore-cd-rom-autorun.jpg

I also read somewhere that I should make sure that the correct NoDriveTypeAutoRun and/or NoDriveAutoRun policy value is set - for this subkey section:

But there wasn't any registry key for "NoDriveTypeAutoRun" - under this subkey section:
Here's a screen-cap:

Can't play dvd's - AutoPlay isn't available anymore-nodrivetypeautorun.jpg

And this where I get lost. I read that I should change one of the entries of the "NoDriveTypeAutoRun" - under this different subkey section:
But there are two entries. So, which one of those entries do I touch. Secondly, what should I change it too?
Here's a screen-cap:

Can't play dvd's - AutoPlay isn't available anymore-nodrivetypeautorun-current-user.jpg

My System SpecsSystem Spec
27 Jul 2011   #2

Microsoft Windows 7 Home Premium x64

What program do you want to play them with? If I'm not mistaken you can change an option in whatever program you use to automatically play upon inserting a disk. You may want to check there.
If worst comes to worst and that doesn't do anything, you can always add a shortcut to the program on your desktop.
My System SpecsSystem Spec
27 Jul 2011   #3

Windows 7 Home Premium (64-bit Edition)

I normally play dvd's with Media Player Classic and Windows Media Player, and yeah I can still play dvd's through that backdoor way.
But I need my computer back to the way it was before. I can right click on the dvd drive and open the Context Menu - but the Autoplay option is gone and I no longer have the "Open With" option available either.

Hell, I even tried to do a System Restore, but even that didn't work. I keep getting a error message saying that Restore didn't work because it failed to extract this file:
C:\Program Files (x86)\Adobe\Adobe Premiere Elements 7.0\0x0407.ini

So, I booted into safe mode and I deleted every single Adobe Premiere Elements file on my pc. Then I tried to do system restore again, this time from safe mode - but restore still didn't work. I keep getting the same error message.

I really do feel like I could solve all my problems, if I could get System Restore to work correctly. Can you help me do that?

Can't play dvd's - AutoPlay isn't available anymore-system-restore-adobe.jpg

What about this idea also - When I right click the dvd drive and open the Context Menu, there's an option to "Format" - should I click that, to Format my dvd drive?

My System SpecsSystem Spec

27 Jul 2011   #4

Windows 7 Home Premium (64-bit Edition)

I got autoplay to finally start working, here's what I did:

I went to

and deleted both NoDriveTypeAutoRun

Here's a screen-cap of what I deleted:

Can't play dvd's - AutoPlay isn't available anymore-autoplay-reg-fix-via-delete.jpg

Then, I went to

and added - NoDriveTypeAutoRun 0×00000091 (145)

Here's a screen-cap of what I added:

Can't play dvd's - AutoPlay isn't available anymore-autoplay-reg-fix-via-add.jpg

So as far as the Autoplay issue is concerned - I'm fine now since it's fixed.
But I still need help with fixing this system restore issue. Can someone please help me get system restore working properly. Thanks

My System SpecsSystem Spec
31 Jul 2011   #5

Windows 7 Home Premium (64-bit Edition)

Well, my same problem is back again and I don't have a clue what caused this to happen again. I have done absolutely nothing to my pc, that might explain this repeat issue. I haven't downloaded anything, I haven't altered any computer settings - I haven't done any system restores, so I'm baffled here.
And the steps I took last time, to fix this Autoplay issue, are no longer working. To fix this issue the first time - as you know, I went into the registry and deleted two specific keys from HKCU & I added that one specefic key to HKLM. Well, I just checked those parts of the registry and my initial fix is still in place. Those two files are still gone and that one file is still in place - just like they are supposed to be. So, why isn't my autoplay working, because the registry is exactly the way it should be (I double and triple checked this time).
And I'm telling you, I did nothing to cause this - last night everything was working fine, and as soon as I turned on my pc this morning; surprise, Autoplay problem is back again, and with the usual fixes not working now.

What the heck is going on?
My System SpecsSystem Spec
31 Jul 2011   #6

Windows 7 Home Premium x64 SP1

Have a look here.See if it helps you as it did me - How to disable the Autorun functionality in Windows

There is a Microsoft fix it towards the bottom of the page to enable/disable autoplay

Regards Danny
My System SpecsSystem Spec
31 Jul 2011   #7

Windows 7 Home Premium (64-bit Edition)

Nope, that doesn't help. My Autoplay is still broken
My System SpecsSystem Spec
03 Aug 2011   #8

Windows 7 Home Premium (64-bit Edition)

Well, autoplay started working again, even though I did absolutely nothing to fix it. Then I had to turn off my computer, because I was leaving the house for awhile - and guess what, when I got home and turned my pc back on, the damn autoplay problem was back again.

It's like my computer can't make up its mind. Why does the autoplay issue keep coming and going, even without me changing a single thing on my pc, in between the "working & not working status".

This is really strange.
My System SpecsSystem Spec

 Can't play dvd's - AutoPlay isn't available anymore

Thread Tools

Similar help and support threads
Thread Forum
Multiple BSODs - 3B, 7e, 10, 50, can't play games anymore
Hi, I have a computer with hardware capable of running almost all current titles, EG Bf3, Dota2, counter strike GO, that was until a few months ago. I started experiencing serious ping issues / packet loss in games causing me to completely freeze, then re-appear where I would have been. On counter...
BSOD Help and Support
Can't play a blu-ray region B title anymore.
Hi guys, I own this title on blu-ray: It's a region B title im in America. I've always been able to play...
Music, Pictures & Video
My netbook won't play audio anymore?
I checked the gateway manuals and there's no information on this.
Sound & Audio
SOME .ogg files can't play anymore
Suddenly I've noticed that certain .ogg files aren't able to be played in Windows Media Player. It only occurs with some files; others play perfectly fine. For the files that do not work, they open fine but there is no audio or visualisation at all; however, the time bar (or whatever it's called)...
Music, Pictures & Video
media player wont play web wmv files anymore
Since i installed service pack 1 everything has been ok apart from one or two little programmes ive learned to do without.The only problem i have at the moment is more of a nuisance really.When surfing if i click on a wmv file media player will play the file with sound only and it runs a...
Media Center
Why doesn.t my autoplay come up anymore? Help?
When I insert any type of media, cd, dvd, flash drive anything it doesn't show me that window anymore? Is there a way to fix this?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App