I want my MS Photo Editor back!

Page 2 of 3 FirstFirst 123 LastLast

  1. Posts : 4
    Windows 7 Home Premium 32bit

    The editor of win7 is powerful. If you find a professional photo editor, the photoshop is a good choice.
      My Computer

  2. Posts : 2
    Windows 7 Ultimate 64bit

    A patched Photoed executable fixing long-standing problems with image file size limitation, bad behavior on restoring from taskbar, image corruption when zooming in on 32 bit displays, ..... See earlier post at

    MS Photo Editor
      My Computer

  3. Posts : 3
    Windows 7 Ultimate x32

    If MS Photo Editor won't open jpg/jpeg files, chances are the graphics jpeg codec found in root drive:\Program Files\Common Files\microsoft shared\GRPHFLT is corrupt. Download a copy (search for JPEGIM32.FLT ) and replace. Has worked every time for me when there's been a problem.

    I too incidentally agree that MS Photo Editor is very hard to beat and really don't know why on earth MS discontinued it!

    Thanks very much indeed to the member posting a download link for it!
      My Computer

  4. Posts : 1
    windows 7 home premium 32 bit

    I got it to download on Windows 7, but I can't drag & drop a picture. Any idea what the problem could be?
      My Computer

  5. Posts : 3
    Windows 7 Ultimate x32

    I'd uninstall then re-install it. Drag and drop works for me even in Win 7 x64 bit. Otherwise could be a corrupted graphics filter. Have you tried drag and drop for different images, different image formats?

    I sometimes get a problem that Photo Editor won't open, stays on the task bar. If this happens close Photo Editor via the task manager (or reboot),
    open Regedit (type regedit at the start menu) go to HKEY_CURRENT_USER, Software, Microsoft, Photo Editor, 3.0, Microsoft Photo editor and right click on the Initial_Position key and delete this key.
      My Computer

  6. Posts : 19
    Windows 7 Home Premium 64-bit

    I also get the same error about the registry when I run it. when I try to save - it crashes silently (just disappears).

    Tried uninstall/reinstall - same results.

    Running on Win 8.1
      My Computer

  7. Posts : 4
    Windows 7 home premium 64 bit

    I am having the same problem. I miss microsoft photo editor, it was a quick and easy way to make some simple adjustments and since I have Windows 7 now, it's not longer working. I have downloaded it again from the links on this forum and keep getting the same message: "No file format can be found in the Registry". I want to know how to create directories to get this program working....does anyone have any other suggestions??? Please, I really want this to work!
      My Computer

  8. Posts : 2
    Windows 7 64 bit

    I downloaded through the link suggested by MissMinerva but althought it downloaded perfectly when I tried to open the photo I wanted to edit it said it couldn't find it!
      My Computer

  9. Posts : 1,519
    Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP

    I posted a reply to an older posting but I'll blame it on testing with Win10TP, didn't properly take notice of the date of the last response.

    I installed Photo Editor from my Office 2000 Premium disc on Win7 Home Premium to see if it worked, it did. Then I installed it on Win10TP, it worked but there were a couple of file issues before the program opened [may have deselected too many things in the Tools]. It still has the default 3MB size limit but I've not had to the time to check that out. Both Win7 and Win10TP are Notebooks running the 64-bit OS. I did the Customize install and deselected everything but Photo Editor in the Office Tools section, ended up with a 44MB install size. [TIP: Office 2000 is the last version not to need activation but does require the Product Key.]
      My Computer

  10. Posts : 2
    Windows 7 64 bit

    I downloaded recommended link for Microsoft Photo Editor but it didn't

    I downloaded the recommended link
    http://sites.google.com/site/probeit...attredirects=0 and installed it but when I try to use the program I get an error message that "No file format can be found in the Registry." Is there a fix for this?https://www.sevenforums.com/images/smilies/confused.gif
      My Computer

Page 2 of 3 FirstFirst 123 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:16.
Find Us