Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WMP freezes playing Xvid avi

04 Oct 2009   #11
ranjan2001

Windows 7 Ultimate x64 build 7600
 
 

Seems some misunderstanding,
I meant that all media players are able to play these files but they all hang the OS for few mins then continue again, this happens with all the xvids (for sure) but lately .flv files downloaded from youtube are also doing the same now.


My System SpecsSystem Spec
.
30 Oct 2009   #12
ranjan2001

Windows 7 Ultimate x64 build 7600
 
 

Seems my problem is solved today when I tried playing the xvid in Jriver media center, I watched the whole movie without any problem, though I still don't know the source of the problem but I will keep my finger crossed & try other xvids next few day to confirm.
My System SpecsSystem Spec
27 Dec 2009   #13
ranjan2001

Windows 7 Ultimate x64 build 7600
 
 

Quote   Quote: Originally Posted by lug View Post
I had a similar problem with both the 32 and 64bit versions of 7. I solved the problem by turning off the "write-cache buffer" on the hard drive.
I have 4 hdd do I need to turn off "write-cache buffer" on all drives or just the OS drive (seagate 1.5TB HDD)?
My System SpecsSystem Spec
.

27 Dec 2009   #14
InternetLord

Windows 7 Eternity Build 7600 RTM Activated x86
 
 

Quote   Quote: Originally Posted by ranjan2001 View Post
Quote   Quote: Originally Posted by lug View Post
I had a similar problem with both the 32 and 64bit versions of 7. I solved the problem by turning off the "write-cache buffer" on the hard drive.
I have 4 hdd do I need to turn off "write-cache buffer" on all drives or just the OS drive (seagate 1.5TB HDD)?
only turn off if you are using an ssd drive. if you have to turn it off on a sata drive there is some other problem.
My System SpecsSystem Spec
27 Dec 2009   #15
ranjan2001

Windows 7 Ultimate x64 build 7600
 
 

What kind of problems on sata drives can you give more details?
My System SpecsSystem Spec
30 Dec 2009   #16
lug

Windows 7
 
 

Quote   Quote: Originally Posted by ranjan2001 View Post
What kind of problems on sata drives can you give more details?
I have removed it from my (non SSD) 1.5Tb SATA drive and it did solve the video problem and I have never had a problem with the setup. The computer is used solely as a media centre using Windows 7 media centre software (x64), with it I watch all sorts of media files (mostly full HD 1080p using K-Lite Mega Codecs x32 and x64), TV, mp3, pictures you name it... The setup is very stable and works like dream. Before removing the write cache avi, mkv files were unwatchable because they used to stop and restart. Personally I don't see a problem in removing the write cache on all your drives - it should make the system more responsive.

See http://www.windowsreference.com/wind...s-server-2008/ for a brief description of what write cache does.

Hope that helps.
My System SpecsSystem Spec
26 Sep 2010   #17
NPeete

Windows 7 Professional 32bit
 
 

Hi!
I have the same issue, first it came with the new PotPlayer. Later it did with KMPlayer then with WMP as well. The problem occurs with only xvid videos, every x264-encoded stuff was good except one.
I disabled the write cache but the issue has remained.
I almost forget it: I bought a new HDD (WD5000BEVT, changed from another WD), the problem occurs only since then.
My System SpecsSystem Spec
Reply

 WMP freezes playing Xvid avi




Thread Tools




Similar help and support threads
Thread Forum
Output files are too big after hardsubbing using XVID
I used to hardsub videos using xvid codes using VirtualDubMod. When i hardsubbed a 700mb avi, the file produced is normally 400 - 500mb and i used xvid codec. But now when i hardsub a 700mb avi, the file produced would be 800mb++ And i remember when i click xvid under compression, it will start the...
Music, Pictures & Video
Xvid is installed but the video still asks for it.
I have a .wmv file. When I click on it I get a window that says the file was built with Xvid and I will need an Xvid codec to play it. I already have Xvid installed. The window has a link to install the necessary codec but when you click it you end up at a Gygan installer. I installed Gygan but...
Music, Pictures & Video
Xvid to Quicktime
I am tying to convert a couple of xvid files to quick time, and would like to know if anyone knows a free converter program. Thanks jack
Media Center
Convert to XviD
Right, here goes, I bought a surround sound system with DVD upscaler and the unit/upscaler has a USB slot and the instructions say flash drive. I want to use my Hard drive in it but I don't know if it works. Here's the two drives I have: Freecom, 2.5" SATA, 160GB, NTFS, USB powered...
Software
Can not Play some xvid (avi) files
I am having a problem playing a number of xvid encoded .avi files. about 16 to 20 minutes into the video I get a message saying "Cannot Play video -windows media center can not open the file" This happens on 7229x64 and 7264x64. It also fails at the same point in WMP (both the x86 and x64...
Media Center


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:34.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App