Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Essentials won't download error 0x80070643

05 Dec 2014   #11

Win-7-Pro64bit 7-H-Prem-64bit

Hi done the .exe still functions as it always has and displays all of the proper prompts...
Check out this download list of languages for we2012 and see if they will install,
Windows Essentials download options - Free Email, Instant Messaging, and Photo Editing Software from Microsoft
Use the custom install and only install photo gallery and movie maker.

My System SpecsSystem Spec
05 Dec 2014   #12

Win-7-Pro64bit 7-H-Prem-64bit

On a more docile side,
See what this does,
I believe you will be prompted to select issue with installing or uninstalling programs,
At this point installing would be the option to select,
Fix problems that programs cannot be installed or uninstalled
My System SpecsSystem Spec
05 Dec 2014   #13

Win 7 64bit

Well, I finally got WMM 2012 installed (don't ask me how), but it still won't run.
Here is a post from another user with exactly the same problem:
Movie Maker cannot start - Does not meet system requirements - Microsoft Community

"Windows Live Movie Maker 2011 used to work but doesn't anymore?

"So, I have Windows Live Movie Maker 2011 on my laptop; I think that means it's like version 15 or 15.4 or something? Anyways, it's WLMM 2011..

"It used to work just fine; I made almost 25 videos for my YouTube channel on it. Then, almost exactly a week ago (tomorrow will be a week), I saw that it could update, so I figured okay, why not update to the latest version? BIG mistake. It updated to the 2012 version, which cannot run on my computer, since my laptop is about 3-ish years old, so it doesn't meet the minimum requirements and such. I completely uninstalled it, and then went to go and re-download the 2011 version so I could go back to making videos, but then once I did that... WLMM 2011 no longer works on my computer! It says my computer doesn't meet the minimum requirements. I found that strange, considering that's what I was using before, yet now that I got it back, it keeps giving me that error message.

"I looked at the minimum requirements, and apparently it says that your processor needs minimum 2.4GHZ, but mine apparently only has 2.2GHZ? I don't get how that's possible if my computer used to run WLMM 2011 before?"

[NOTE: one official MS site says that the minimum is 2.4GHz, yet another one--the one you get by clicking the link in the "can't open" popup--says 1.6GHz.]

"I tried restoring my computer to an earlier time before I updated to WLMM 2012 and ruined everything, but before I had that idea, I ended up removing/uninstalling a bunch of other programs I didn't need on my computer, so now the earliest time I can restore my computer to is already past the point where I've been having this problem, so it won't help me."
And there are many similar tales out there.
My System SpecsSystem Spec

05 Dec 2014   #14

Win-7-Pro64bit 7-H-Prem-64bit

After it downloaded and apparently installed,
Once you first opened mm did you get the terms of usage agreement popup to agree too ?
Version 2012 build 16.4.3528.0331
My System SpecsSystem Spec
05 Dec 2014   #15

Win-7-Pro64bit 7-H-Prem-64bit

One thing that came with the download was this,
Microsoft SQL Server 2005 Compact edition enu 1.65MB 3.1.0000
My System SpecsSystem Spec
05 Dec 2014   #16

Win 7 64bit

All I got was the same "cannot open" as always.

I did some more fruitless digging and doing.

?Error code: c945000e Sorry, Movie Maker can't start - Microsoft Community

"The following video cards and corresponding driver versions below have been identified as having issues that prevent Movie Maker 2011 and Movie Maker 2012 from working correctly. Movie Maker will not start with the following video cards and driver combinations." There follows a list of cards that "prevent Movie Maker 2011 and Movie Maker 2012 from working correctly." A couple of mine were included, so I updated them.


"To resolve the issue, install the latest video card driver version"

Installed NVIDIA Graphics Driver v. 306.14
Installed Intel Management Engine Interface (MEI) Driver
2012-02-24 , Version8.0.0.1262, 23.5M


Bottom line, I appreciate your input but I'm sick of messing with this. NO OTHER vid program, from PE12* to the simplest video trimming program, has given me any trouble. Therefore, I quit. This one was nice and simple while it lasted, but for me that party is over.

*It is interesting that on one MS site the sys req for WMM are considerably higher than for the far more complex and feature-rich PE12. Sloppy programming.
My System SpecsSystem Spec
05 Dec 2014   #17

Win-7-Pro64bit 7-H-Prem-64bit

For the record which codec packs did you install then uninstall ?
I asked originally but never got a response :/
Use it/ don't use it ?
My System SpecsSystem Spec
05 Dec 2014   #18

Win 7 64bit

Codec pack was:
K-Lite Full Codec Pack.
Free Download K-Lite Codec Pack 10.8.5 Full, Standard and Basic

I can't prove that this was the cause, but the problems started after I downloaded it. The purpose was to enable full screen video capture with DVD VideoSoft. (That never worked, either.)
Interestingly, all other video editors I have still work just fine, including the old MS Movie Maker 2.6.
My System SpecsSystem Spec
05 Dec 2014   #19

Win-7-Pro64bit 7-H-Prem-64bit

Well that is interesting
I've never seen the need for any third party codec packs
If I ever needed a codec I would simply use vlc media player it plays just about everything ever recorded,

The same link that had the 2012 version just above the languages list is a drop down to select the 2009 version which it too has movie maker,
But yea life is short but obviously something is a miss,
My System SpecsSystem Spec
06 Dec 2014   #20

Win 7 64bit

For anyone with the same download/installation problem:
After wasting two days trying the many solutions proposed on a number of sites, including MS sites, I was able to download and install easily after disabling the password to my computer.
Unfortunately this does not solve the "cannot open" problem.
Meanwhile all other programs, including a new GOPRO editor which I easily downloaded and tests a few minutes ago, present no such problems.
My System SpecsSystem Spec

 Windows Essentials won't download error 0x80070643

Thread Tools

Similar help and support threads
Thread Forum
Security Essentials Install error 0x80070643
Error code 0x80070643 comes up whenever I try installing Microsoft Security Essentials. I had Security Essentials installed earlier but after I used the .net cleanup tool (since I had a problem with .net) it shut down and wouldn't start back up again, so I uninstalled it. I have also tried...
System Security
Windows 7 Service Pack 1, error 0x80070643
Hi, I have been trying to install the Windows 7 SP1, unsuccessfully, for most of a week now. The update does not appear in my Windows Update program, so I used the online version on The update installs correctly, but after restarting and beginning the "configuring windows"...
Windows Updates & Activation
Cannot install IE10 on Windows 7 64 bit. Error Code 0x80070643
Hello, I have tried unsuccessfully to install IE10 on my Windows 7 64 bit system. First, I wanted to say that yes, I am planning on following the posting instructions (system update readiness tool, and SFC scan posts), but first, I wanted to introduce the problem that I am having. I was...
Windows Updates & Activation
Deploying IE10 for Windows 7 from WSUS - Error: 0x80070643
Hi We use WSUS 3.0 and have recently manually added Ie10 which has been sent to a few test users. It appears looking at the windows update logs it tries to install IE10 but fails daily with the error code 0x80070643 153c Report REPORT EVENT:...
Windows Updates & Activation
Microsoft Security Essentials Error Code 0x80070643
Whenever I try to install Microsoft Security Essentials I get the error code 0x80070643 I have tried lots of fixes, but none of them have worked I look forward to repsonses Thanks

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:04.
Twitter Facebook Google+