Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: MPC-HC won't display subtitles

15 Nov 2009   #1
KazeNoKoe23

Windows 7 Professional x64 SP1
 
 
MPC-HC won't display subtitles

This problem is on a friend's computer, as I have Shark007's codec pack installed alongside MPC-HC x64 with absolutely no problems, but my friend recently made the jump to Windows 7 x64 (clean install), and subtitles won't load in MPC-HC for him. I've tried Shark's codec pack + MPC-HC x64, fiddling with the x64 components settings, and I've also tried CCCP + MPC-HC x86, but that doesn't work either. I think I've narrowed the problem down to MPC itself. The Subtitles option under Play is greyed out, where it isn't on mine. The Output is set to Haali Renderer, as it is under mine, and the Haali Splitter icon does show in system tray and it says subs are enabled, but the option is still greyed out in MPC, and the subs aren't showing up. Does anybody know why this is? I googled the issue but the solutions I found were ofter 4 years old and didn't work. Thanks for any help.


My System SpecsSystem Spec
.
15 Nov 2009   #2
Lee

Win 7 Pro x64, VM Win XP, Win7 Pro Sandbox, Kubuntu 11
 
 

Like yours mine works fine, try this set of codec—Media.Player.Codec.Pack.V3.3.1.Setup—and see it works. Good Luck.
My System SpecsSystem Spec
15 Nov 2009   #3
sirdan

Win Xp/7
 
 

Change renderer to EVR Custom. You may check autoload subtitles option. If subs name dont match video name, just drag&drop sub file on player window.
My System SpecsSystem Spec
.

15 Nov 2009   #4
Shark007

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by Lee View Post
Like yours mine works fine, try this set of codecMedia.Player.Codec.Pack.V3.3.1.Setupand see it works. Good Luck.
Lee, PLEASE stop recommending that users should submit thier systems to codec hell just because you are there and don't even know it. Your lack of knowledge of anything codec related is completely astounding. Worse yet, you're inability to solve playback issues in an informed manner is prevelent with your recommendation of installing something as archaic as "Media.Player.Codec.Pack.V3.3.1" which installs 179 OLD VERSION files to the users system32 directory of which 85% have been already installed with current versions by the Win7codecs into private pathing where they belong.
Several files of your recommended installation are PROVEN to crash Windows 7 systems!
My System SpecsSystem Spec
16 Nov 2009   #5
KazeNoKoe23

Windows 7 Professional x64 SP1
 
 

Quote   Quote: Originally Posted by sirdan View Post
Change renderer to EVR Custom. You may check autoload subtitles option. If subs name dont match video name, just drag&drop sub file on player window.
EVR Custom didn't work either. Also, there are no separate sub files, sorry for not mentioning this earlier. The problem occurs with MKV files.

Quote   Quote: Originally Posted by Shark007 View Post
Lee, PLEASE stop recommending that users should submit thier systems to codec hell just because you are there and don't even know it. Your lack of knowledge of anything codec related is completely astounding. Worse yet, you're inability to solve playback issues in an informed manner is prevelent with your recommendation of installing something as archaic as "Media.Player.Codec.Pack.V3.3.1" which installs 179 OLD VERSION files to the users system32 directory of which 85% have been already installed with current versions by the Win7codecs into private pathing where they belong.
Several files of your recommended installation are PROVEN to crash Windows 7 systems!
I didn't try that method anyway, Shark. A quick google search of that codec pack name revealed some pretty shady websites. Do you have any idea as to why MPC would have the Subtitles option greyed out? Haali Media Splitter still loads in system tray and it says that subs are enabled, but they still don't load in MPC.
My System SpecsSystem Spec
16 Nov 2009   #6
harpua

Windows 7 Ultimate x64 (Retail)
 
 

I'm not sure but this may help: In MPC-HC go to options, playback, and make sure the boxes for auto load audio files and auto load subtitles are checked.

I would also make sure you are running one of the more recent beta versions of MPC-HC. They have incorporated a lot of fixes to various things related to subtitles, among other things. Don't be afraid of these beta MPC releases. They are usually stable. I update weekly and have never had a problem with any of these releases.
My System SpecsSystem Spec
18 Nov 2009   #7
harpua

Windows 7 Ultimate x64 (Retail)
 
 

Another thing that may work to get subtitles working in MPC-HC is to make sure you are using the "EVR custom pres." renderer in Options, Playback, Output. Not all renderers work with subtitles in MPC but this one does.
My System SpecsSystem Spec
19 Nov 2009   #8
KazeNoKoe23

Windows 7 Professional x64 SP1
 
 

Quote   Quote: Originally Posted by harpua View Post
I'm not sure but this may help: In MPC-HC go to options, playback, and make sure the boxes for auto load audio files and auto load subtitles are checked.

I would also make sure you are running one of the more recent beta versions of MPC-HC. They have incorporated a lot of fixes to various things related to subtitles, among other things. Don't be afraid of these beta MPC releases. They are usually stable. I update weekly and have never had a problem with any of these releases.
Auto-Load Subtitles wasn't checked, but I checked it and now everything works! Thanks a lot. Rep for you.
My System SpecsSystem Spec
19 Nov 2009   #9
harpua

Windows 7 Ultimate x64 (Retail)
 
 

That's great that it fixed the problem. Thanks for the rep. Much appreciated.
My System SpecsSystem Spec
05 Jul 2011   #10
sund

Windows 7 Ultimate x64
 
 

Was facing the same problem, checking the box solved the prob which was pestering me for long... Thanx a Lot...!!!!

Quote   Quote: Originally Posted by KazeNoKoe23 View Post
Quote   Quote: Originally Posted by harpua View Post
I'm not sure but this may help: In MPC-HC go to options, playback, and make sure the boxes for auto load audio files and auto load subtitles are checked.

I would also make sure you are running one of the more recent beta versions of MPC-HC. They have incorporated a lot of fixes to various things related to subtitles, among other things. Don't be afraid of these beta MPC releases. They are usually stable. I update weekly and have never had a problem with any of these releases.
Auto-Load Subtitles wasn't checked, but I checked it and now everything works! Thanks a lot. Rep for you.
My System SpecsSystem Spec
Reply

 MPC-HC won't display subtitles




Thread Tools




Similar help and support threads
Thread Forum
wmp doesn't display subtitles
I am trying to see a movie (mkv file) with srt subtitles on windows media player - Windows 7 32 bit Home but I cannot. I have searched all the internet and tried different solutions but still no result. I have also installed and uninstalled various codecs and programs. Now I have installed...
Music, Pictures & Video
SRT subtitles
hi i have a trouble in displaying .srt subtitles back in windows xp i was using k-lite mega codec and everything works fine on win7 x64 im using the same k-lite bundle and its not working even in WMC any solutions ?!
Media Center
Forign Subtitles Not Displaying Properly (Russian Subtitles)
Hey, this problem has been giving me a headache for days and a million Google searches later: I downloaded subtitles that are Russian (.srt), however when I open up the video file in Windows Media Player or VLC the subtitles are displaying as gibirish, like this: " ...
Music, Pictures & Video
WMP 12 - PS3 - Subtitles
Hi, after following some of the tutorials or topics posted here I managed to get MKV and subtitles working in WMP12. Mostly through installing Shark. I also managed to link my PS3 and Media Streaming goes very well. The only thing that is nog working are subtitles. I get subtitles when...
Media Center
Need help with subtitles
I have a problem with subtitles on my videos in both Windows Media Player and Divx, which used to work just fine on Windows Vista. Two different movies I have tried, one being an .avi file, the other being a .mp4 file and both subtitles being .srt files. I read up on some other forum, and found...
Music, Pictures & Video
No subtitles in mp4 with aac
HI EVERYONE I recently configured WIN 7 Media Center with ffdshow codecs. All movies play good excpet MP4 movies which I have sound but no subtitles I usue spdif pasthrough for the audio I have done thousands of mixtures in the codecs but the problem stil remains The Direct Vob Sub does not...
Media Center


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App