Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: MP4 files work until I copy them to my generic usb mass storage device

22 Nov 2017   #11

Windows 7 Ultimate 32 bit

I did not see that, but I have now bat. Thanks. I guess that's the problem then. What a waste of money. I should have read the description.

My System SpecsSystem Spec
22 Nov 2017   #12

Linux Mint 18.2 xfce 64-bit (VMWare host) / Windows 8.1 Pro 32-bit (VMWare guest)

Quote   Quote: Originally Posted by cyclonis View Post
So basically I bought something that can't do it's job?
It appears that in this instance you bought something that can't do its job. I would be very suspicious of a 512 GB flash drive that cost only about 12 pounds. I would expect to pay a lot more for a flash drive of that capacity.

Here is a name-brand 512 GB flash drive (Corsair) from a name-brand vendor (New Egg). The price is $290.99, which is 218.42 pounds. That price makes a whole lot more sense than the 12 pounds that you paid.

Corsair 512GB Voyager GT USB 3.0 Flash Drive, Speed Up to 350MB -
My System SpecsSystem Spec
23 Nov 2017   #13

Windows 7 Ultimate 32 bit

Yea I thought I just found a great deal. Thanks for your help. I'd call this solved now.
My System SpecsSystem Spec


 MP4 files work until I copy them to my generic usb mass storage device

Thread Tools

Similar help and support threads
Thread Forum
Mass Storage Device error
Hello everyone. I have a PC with Windows 7 Professional 64-bit installed. My problem is that with some usb devices I get an error 28. These devices are working on other PC. For example I have 2 usb sticks 16gb. The one is working fine, and the other has an error 28. I searched for viruses with...
Hardware & Devices
USB Mass Storage Device Problems
Hello People I need help pretty bad i tried alot of things and took me 4 hrs just attempting every single fix i find. OK lets get started Problem is i can't connect any kind of Portable Hard Drive in this laptop, i am able to connect in a different computer actually 4 different computers except...
USB Mass Storage Device/Unknown Device
In Device Manager, there is a USB Mass Storage Device or an Unknown Device, even when there isn't anything plugged in. This is occurring on a Dell Dimension 5100. This is not the pc in my system specs. How do I fix this? Here are some Device Manager screenshots:
Hardware & Devices
USB Mass Storage Device
Hi All, Been using the new Windows 7 for a week or so now, everything is great! But i have one big issue. Every time i plug in a USB pen drive or my tomtom device, a window appears with a message saying that the device drivers can not be installed. When i click on the ballon message it just...
Mass Storage Device
i have a Gateway 7803u notebook WIndows 7 64-bit specs are i hook up my external HD and it will not show up Mass Storage Controller with the yellow ! driver properties say

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:29.
Twitter Facebook Google+