Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Media Player 12 won't close properly

3 Weeks Ago   #1
UserXP

Windows 7 Ultimate x64
 
 
Windows Media Player 12 won't close properly

Hi again. I am writing this on behalf of another computer running Windows 7 x64 OS. It has a strange issue with Windows Media Player.

This happens ONLY in Skin Mode:

When I start WMP and do nothing, and then click on the close button, the window goes away but the wmplayer.exe process remains in the Task Manager and won't go away. If I try to start WMP again at that point, nothing happens. WMP doesn't display its window and about 30 seconds later a get the "Server execution failed" error popup. Wmplayer.exe still resides in the processes list.
Only when I kill the process can I start media player again.

Now, I have tried:
- disabling WMP Network Sharing Service,
- re-registering vbscript.dll and jscript.dll files,
- disabling and re-enabling WMP in Windows Features,
- performing system scan and recovery,
- full computer scan against malware,
all to no avail.

But I did discover something interesting with Process Monitor. When I start WMP and simply just click on the Play menu within the skin mode's menu bar, Process Monitor displays a bunch of new entries made by the wmplayer.exe process. Upon clicking on the Close button, WMP really closes and removes itself from the process list, so I can start it up again with no problems.
Now, something clearly initates something that WMP does and completes when clicking on the Play menu which makes it work and close as intended.

All this happens also if a media file is opened (it doesn't matter if it is an audio or video file). Actually, it is not even required to opean a media file because WMP reproduces this behaviour every time even when simply loaded with no file. Unless I click on the Play menu, WMP will not close properly and remove itself from the memory. Any ideas what else to look for?
Thanks in advance.


My System SpecsSystem Spec
.
2 Weeks Ago   #2
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Hello UserXP

If the problem only occurs in WMP after you have applied a skin, then I'd first assume that the chosen skin is incompatible with Windows 7. What happens if you choose a different skin? A built-in skin, for example?
My System SpecsSystem Spec
2 Weeks Ago   #3
UserXP

Windows 7 Ultimate x64
 
 

It is already using the default skin. I didn't download nor applied any additional skins.
Both skins that come pre-installed with WMP produce the same behaviour.
My System SpecsSystem Spec
.

2 Weeks Ago   #4
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Does this problem occur in one user account?
Had you tried starting WMP in a different User Account - create a new user profile if necessary ?
My System SpecsSystem Spec
2 Weeks Ago   #5
UserXP

Windows 7 Ultimate x64
 
 

The computer already has only one account. Everything works fine but WMP. It's acting out for no apparent reason.
I have read before about the possible solution via creating new accounts, but it didn't change anything.
WMP working normally in skin mode only after clicking on the play menu is weird as hell. I tried all the suggestions listed on the Microsoft's community boards also and none of them gave results.
My System SpecsSystem Spec
2 Weeks Ago   #6
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

when you "disabling and re-enabled WMP in Windows Features" did you re-boot the computer before re-enabling?
My System SpecsSystem Spec
2 Weeks Ago   #7
UserXP

Windows 7 Ultimate x64
 
 

Of course I did. Windows suggested to restart the computer for the changes to take effect, so I did. I always restart the computer whenever I install or uninstall any piece of software.

Do you now where WMP calls for this "server execution". Does it start a separate process for it? Maybe some change of settings should be made to that "server". And maybe WMP "executes" it properly when clicking on the play menu.

Now, clicking on the Play menu is really just that. Just by displaying the menu WMP fixes itself. I don't even have to point to any option or submenus within the Play menu.
My System SpecsSystem Spec
.
Reply

 Windows Media Player 12 won't close properly




Thread Tools




Similar help and support threads
Thread Forum
Media Player Classic - close file after playback?
I can't figure out how to get MPC to close the file after playback. For instance, if I want to delete or move the file, I can't do it unless I close MPC or select File>Close. From what I read, there's an option in MPC to automatically close the file when playback stops, but I can't find the option....
Software
Laptop will not close down after using Windows Media Player
I am using a new Dell laptop (Latitude 3540) and it seems to have a strange fault. When I play a DVD using WMP the laptop will not close down - there is no message about programmes that are open and there is nothing shown under applications in the task manager. I click on "shutdown, it goes through...
General Discussion
Open Windows Media Player Inside Windows Media Player
Hi, I wanted to ask if it is possible to set Windows media player to open as the default player inside media center. The reason that I ask this is that I find media center sound is very low quality. I am using it inside windows 7 ultimate X64. I also use Media Browser and have set it to use...
Media Center
VLC Media Player Won't Play Certain DVDs Properly!
:mad: This is hugely annoying! I can play most DVDs without any bother with VLC. I recently got 'The World at War - Ultimate Restored Edition', but the discs won't play! First, VLC just wouldn't open the DVD. I kept trying, and eventually it opened the DVD, but the audio and video were...
Software
windows media player not installed properly
Hi im running windows 7 home basic and i have done a file transfer from a vista machine but now my media player wont open gives me an error saying it was not installed properally I have tried to uninstall it but when i go to turn windows features off there is nothing in the box any ideas please
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:13.
Twitter Facebook