Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: AVI playback all of a sudden stopped working

27 Nov 2009   #1
Rugger1

Windows 7
 
 
AVI playback all of a sudden stopped working

Weird issue here. Some of my avi's just stopped being able to play on one of my Windows 7 machines. Weird part is; if I connect to that machine via remote desktop the videos work!

I tried reinstalling ffsdshow tryouts and even creating a new account. This machine was working fine not to mention all the other machines are still playing them fine. Some of the other avi's still work and all my mkv's still work fine.

However I keep getting "Windows Media Player cannot play the file. The Player might not support the file type or might not support the codec that was used to compress the file" whenever I select certain avi's. Like I mentioned though, if I connect to that machine via remote desktop they play fine. Any ideas?


My System SpecsSystem Spec
.
27 Nov 2009   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Rugger1 View Post
Weird issue here. Some of my avi's just stopped being able to play on one of my Windows 7 machines. Weird part is; if I connect to that machine via remote desktop the videos work!

I tried reinstalling ffsdshow tryouts and even creating a new account. This machine was working fine not to mention all the other machines are still playing them fine. Some of the other avi's still work and all my mkv's still work fine.

However I keep getting "Windows Media Player cannot play the file. The Player might not support the file type or might not support the codec that was used to compress the file" whenever I select certain avi's. Like I mentioned though, if I connect to that machine via remote desktop they play fine. Any ideas?
Hi and welcome
when you connect via rdt it uses the codecs on that machine not the one that is broken. What format doesn't play? has anthing else happened on the broken machine, like a crash, or uninstall of an app?

Ken J+
My System SpecsSystem Spec
27 Nov 2009   #3
Rugger1

Windows 7
 
 

No crashes or anything that I'm aware of. It's only certain avi's that stopped working, and only on that one machine. Some avi's do still work. All four of the machines have codecs installed following the guide MKV's for Minimalists on Windows 7 web page (MKVs for Minimalists on Windows 7). The other three machines are not having any issues and can play all avi files.
My System SpecsSystem Spec
.

27 Nov 2009   #4
Rugger1

Windows 7
 
 

Finally figured it out. When I had installed the Creative drivers for my Creative Audigy 2 ZS it ran an update where it wanted to install programs called Creative Alchemy and Creative MediaSource 5. The culprit was Creative MediaSource 5. I attempted to restore to previous point before MediaSource was installed but still no good. I have to restore to the point before the installation of the Creative audio drivers. At this point my AVI's started working again. I reinstalled only the audio drivers and Alchemy and everything is still working smooth.

Note to creative users: Creative MediaSource may screw up your ability to play SOME avi's through Windows Media Player and Windows Media Center.
My System SpecsSystem Spec
27 Nov 2009   #5
Rugger1

Windows 7
 
 

Another update. When I went into the Creative Audio Console and changed my speaker setup from 2.0 to 5.1 the avi's stopped playing again! I changed it back to 2.0 and then they would play. So I went to Windows control panel and when I selected Sound a message popped up saying:

Windows has detected that audio enhancements for the following devices are causing problems:
Speackers (Creative SB Audigy 2 ZS (WDM))
Would you like to disable Driver Enhancments for this device?

I selected yes and then selected 5.1 from the Windows Speaker Setup box and the avi's are still working.

It amazes me how buggy Creative's software is! Hope this information helps somebody else!
My System SpecsSystem Spec
28 Nov 2009   #6
harpua

Windows 7 Ultimate x64 (Retail)
 
 

Thanks for coming back and posting the solution you've found. I'm sure it will be helpful to others in the future.
My System SpecsSystem Spec
Reply

 AVI playback all of a sudden stopped working




Thread Tools




Similar help and support threads
Thread Forum
Windows installer has stopped working or setup.exe has stopped working
HI, I'VE INSTTALED WINDOWS 7 PROF.ON MY PC. I M TRYING TO INSTALL WINDOWS7ULTIMATE BY CLICKING ON SETUP.EXE AN ERROR MASSAGE APPEARED SAYING: THEN I TRIED TO INSTALL WINDOWS 8 ON MY PC.. BUT THE ERROR MASSAGE APPEARED SAYING SAME THING AND ALL OTHER SETUP IN THAT DRIVE ARE SAYING SAME...
General Discussion
Blu Ray playback - stopped working...
I'm hoping that someone else has had these issues and know's how to fix it, or at least some ideas as to what I could try out. Annoyingly the help from Sony is 'format/recovery' :rolleyes: The laptop is a Sony Vaio VPCF11Z1E running Win 7 x64. AFAIK I have the latest drivers for the 330M...
Music, Pictures & Video
Normal mode has stopped working all of a sudden
Ok, so I was trying to figure out how to set up a Minecraft server. Tried some things... downloaded this program Bukkit (seemed safe?). Some minutes after using it my computer slows down, and ALT+CTRL+DEL stopped working. I'm restarting my computer, and after Windows 7 loads the first 30 seconds...
BSOD Help and Support
All of a sudden window media player just stopped.
I am in the middle of a road trip and I have been watching a number of tutorials that were downloaded after purchasing them. There is a combination of .mov, .avi or mp4. The player will start and play about 3 seconds and then it says it is quiting and will offer a solution if one is found but it...
Media Center
RDC stopped working all of a sudden
Hi, I had my work PC (XP pro) connected through RDC to my home laptop (Win7 Pro) and it was working perfectly for a couple of days and then just stopped. I have port forwarded 3389 and have enabled it on my home PC. I have allowed 'remote desktop' on my home PC and still no luck. In services...
Network & Sharing
WMC all of a sudden stopped playing movies
Very odd. I've been using WMC to play movies stored on a home server forever. Recently it stopped working. It will flash up the start of the movie for a split-second, then stop with no error that I can see. Windows media player does the same thing. What is odd is that I can remote into the...
Media Center


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App