Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Wireless is conected, but no network access

06 Apr 2012   #11

Windows 7 Ultimate 64bit

Quote   Quote: Originally Posted by sinshan23 View Post
If you are experiencing problems with getting out to the internet, but your Networking and Sharing Center states you have Excellent signal and you are connected but it say "Limited Acess" this basically means you have no internet and their is no gateway. This happened to me after removing an application used to Manage a Wifi device such as AT&T Communication Manager. Once I restarted it blocked the connection.

Here is what WON'T work:

- Rebooting router
- Rebooting Modem
- Hard Wire Connection
- Changing Security method
- IPconfig/renew/release
- IPconfig/FlushDNS
- Turning off Firewalls
- Static IP
- Changing wireless profilee settings

Here is what WILL work and worked for me, follow these steps:

Scroll to the "Command Prompt"
Highlight "Command Prompt"
Hold Shift and Right-click on "Command Prompt"
Choose "Run as Administrator"
You are now in the System32
Run this command: netsh winsock reset
It will prompt you to reboot your pc.
Reboot and try to reconnect to your preferred wireless.

Somone who tries this, please post with a Result
I found this thread through Google and thought I should add my anecdotes regarding AT&T Communication Manager. Hopefully this will help other people identify issues related to it.

I work for a small cable ISP and have encountered at least two other cases of Windows getting broken/botched after uninstalling AT&T Communication Manager.

Yesterday, I spoke with a new customer. His previous provider was AT&T, and the AT&T Communication Manager software had been installed on his computer. Though his connection was working fine, the AT&T Communication Manager was nagging him constantly, so he decided to uninstall it. After removing it, he could no longer get DHCP on the wireless connection and didn't have any way to test the direct-wired connection. He couldn't even get DHCP when connecting to an unsecured wireless network. We performed a System Restore to a point before the AT&T software had been uninstalled. Clearly, System Restore failed to fully restore the AT&T software because we got an error message on boot indicating that Windows couldn't find something in Program Files and the path\filename referenced AT&T Communication Manager. So it restored the startup entry in the registry, but it didn't restore everything to %programfiles%.

Side-note: If System Restore can't properly keep track of %programfiles% contents, then what good is System Restore? Every time I've *ever* needed System Restore to work in a situation like this, it consistently fails. I'm not exaggerating.

The previous case was a customer with a Toshiba laptop that couldn't get online after removing the AT&T software. The AT&T software had originally bundled some kind of McAfee security software and there were indicators that it wasn't fully removed. If I recall correctly, DHCP still worked but all protocols (HTTP, FTP, POP, IMAP, SMTP, etc) were blocked...except ICMP ping. I could ping out just fine. The customer blamed us because she said it had worked with her previous provider (many months earlier). She got some free computer work out of it. Of course, System Restore didn't work. I had to back up the customer's files (just a few pictures) and perform a factory restore. The factory restore took an entire day because Toshiba's restore process is full of FAIL. Even after the restore was complete, the hard drive turned out to have a bad sector which would cause Windows to freeze shortly after reaching the desktop on each boot.

1) This is a problem with bloatware, botching systems by not removing itself properly.

2) It's also a problem with Microsoft Windows, allowing itself to be botched in ways that aren't easily-reversible with System Restore.

Oh, and thanks for the winsock reset info. It worked this time. The previous time this happened, the system botched itself too badly after failing System Restore.

My System SpecsSystem Spec
24 Apr 2012   #12

Windows 7 Ultimate x64

Thank you sinshan23 you helped my internet
My System SpecsSystem Spec
22 Aug 2016   #13

os x
Reset Winsock worked!

Thank you Sinshan23!
My System SpecsSystem Spec


 Wireless is conected, but no network access

Thread Tools

Similar help and support threads
Thread Forum
Cannot access Network Shared Drives over Corporate Network on Wireless
hi guys, so I have this weird problem that is driving me nuts since some weeks... here's the thing at work we have a corporate set up with Win 7 Professional, everything is setup on a "domain". we all have Dell computers and we can connect either via cable or via wireless, pretty...
Network & Sharing
limited access wireless network
Hi, I have a problem, I cant access internet, when i try to connect, i got a message that i have a limited access. Also, i can access internet easily using my mobile, and i have another laptob which access internet without problems. The problem just in my laptob. I tried to reset the router and...
Network & Sharing
Limited access on wireless network
Hi, My PC has crashed yesterday and since then i can't connect to any wireless netwrok. i am sure it's my pc and not the network itself because i can connect from my phone. when i open the troubleshoot manager it says: "the dependency service or group failed to start" i've googled it but i...
Network & Sharing
No internet access on wireless network
Hello, I've been battling this problem for a few months now. On my lenovo x100e laptop with windows 7 I can connect to my wifi network and sometimes go to a website before it says "no internet access" while still being connected to the network. Any other laptop or phone connects and has internet...
Network & Sharing
Limited Access to wireless network
Hey guys, I have an issue with my wireless. It comes up now (for no apparent reason) that the network has Limited Access. Any suggestions please on what to do?
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:06.
Twitter Facebook Google+