Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Reserved list in router doesn't seem to work

08 Sep 2010   #1

Reserved list in router doesn't seem to work

Some time ago I was discussing ways and means of stopping my kids changing their IP addresses to get around ACLs I'd created on my DLINK router.

Two solutions were offered: OpenDNS, which I'm still using, and setting up a DHCP reservation using MAC addresses.

Recently I had to replace one of the machines. Lets say the original machines mac address was 0A:0A:0A:0A:0A:0A (just for convenience), and it's IP address was

When I replaced the machine the MAC address is completely different.

I completely forgot to update the DHCP reservation. Yet, the PC can access the internet.

If I change the address on the machine, of course, it still connects to the internet, I guess because the MAC address is not in the DHCP reservation list. So I updated the entry in the router.

The computer still accesses the internet with (as I would expect), but if I change the address to (for example), it still works.

So.. Without the mac address in the router (but with a reservation using the IP address), there appear to be no restrictions. I hoped the router would match the MAC address to the requesting IP address and go "Nope, these dont match. Sorry, I'm not letting you connect".

Obviously I've done something wrong when I set it up.

Can anyone suggest why this might not be working?


My System SpecsSystem Spec
08 Sep 2010   #2

Windows 7 Ultimate x64 SP1 | OSX Lion 10.7 x64

There are 2 things in here: First, if you created your ACLs based on MAC Address, there is still a way to bypass it: by changing local MAC Address -- many NICs do allows that.

Second, if you created ACLs based on the IP address, you should also update the DHCP to offer the old IP address to the new MAC Address.

What I could suggest you, then, is to create a rule in the very bottom, to deny any unknown MAC Address, and then update the rules to allow your kids to browse -- either via their computer's MAC Address or via IP with the updated DHCP reservation. Pretty much you had done all of this, but missed the "deny all" in the bottom.
My System SpecsSystem Spec
10 Sep 2010   #3


Thanks HQuest.

The ACLs are IP address based

I think your "second" is the step I missed for that PC when I repalced it, otherwise all other machines have IP and MAC and machine name in the DHCP reservation list.

However, even after correcting it (That is the MAC address and machine name matched, but the IP address didn't) the PC still could access the internet.

I have a network printer, PS3, XBox and Wii consoles that are not in the DCHP list, basically because the router only allows 15 addresses, and I had used them all up.

So, if I add the deny all, will that kill the console access?
My System SpecsSystem Spec

20 Sep 2010   #4


The answer to my question was "Yes". It killed console access. It also killed Internet access for all computers in the house.
My System SpecsSystem Spec

 Reserved list in router doesn't seem to work

Please note  Please note
        When your issue is fixed please remember to thank those that helped you and mark the thread as solved.
Thread Tools

Similar help and support threads
Thread Forum
can i know the files list included in the system reserved partition?
hi i used parted magic and active boot disk 10 and in my legit w7 sp1 64bit system reserved partition i found a weird file without extension i added a screenshot can please somebody compare my screenshot and tell me if it's normal to have this file the file is LPTSG without extension...
General Discussion
My bluetooth doesn't work. bttray doesn't open.
Hello. I am quite new here, but I've been wanting to get this problem solved for a long time, and I haven't seemed to get any answer. So here's my problem: I bought my Asus N53SV for around a year ago, and it worked great. But for some reason something changed. When I try to open bluetooth,...
Atheros Wifi adapter doesn't work with "n" router
Hello I have an HP pavillion desktop (s5360f) with Atheros 802.11 a/b/g/n Dualband Wireless Module and D-Link router DIR-615. My numerous Laptops and iPhons / iPads work fine, but this desktop which is further away from the router (in another room, about 20 meters) only shows 1-2 bars of wifi....
Network & Sharing
HELP: power option doesn't work - screen saver doesn't start!
I have an ASUS notebook running windows 7 64-bit. I am using the QuietOffice power profile, however the screensaver won't kick in no matter what I do, and the display does not turn off even though I set it to be after 5-minutes of inactivity. I don't know if there is something running in the...
General Discussion
List.exe multifile search doesn't work
The resource kit command line utility list.exe works OK in Windows 7, except multifile search doesn't work. The command to invoke multifile search is F4; apparently list.exe running under Win7 doesn't properly process function keys. Tested with 2003 version of list.exe (I think that's the latest...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:49.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App