Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Network Adapters gone after MS update

17 Sep 2010   #1
Jason Carlton

Windows 7 Ultimate x64
Network Adapters gone after MS update

Hi all,

New to the board, and glad to find it! Precious little help out there for Win7.

I have a HP G60-630US laptop, running Win7 64-bit. A couple of nights ago, Microsoft loaded a critical update. After that, all of my network adapters had errors, and I had no network connectivity on wireless or wired. Hovering over the network icon said "No connections are available" (wired or wireless).

I tried doing a System Restore first, which had no impact. I then went to Device Manager, and found errors with the following:

Atheros WiFi Adapter
Realtek PCIe FE Family Controller
WAN Miniport (IP)
WAN Miniport (IPv6)
WAN Miniport (Network Monitor)

And under Non PnP, errors with:
NativeWiFi Filter
QoS Packet Scheduler
WFP Lightweight Filter

I uninstalled, then reinstalled, the WiFi Adapter and Realtek adapter (I've tried both with the driver downloads from HP, and the newest drivers on the manufacturers' sites). Then, using devcon, I reinstalled the following adapters:


This removed the Network Adapter errors from Device Manager, but I still have errors with the Non PnP devices. I have no idea how to reinstall them. I also show that WLAN is on, but still there's no network connection. I still get the same "No connection available" error, and troubleshooting gives me this error (for both wired and wireless):

Windows couldn't automatically bind the IP protocol stack to the network adapter.

I tried resetting the IP and Winsock, but this had no impact.

Under Network & Sharing Center, I tried clicking on "Change adapter settings", but this just gives me a blank page, with no adapters at all.

However, "msinfo32 > Summary > Components > Network > Adapter" shows that WAN Miniport (SSTP) is there, along with the others, but "Adapter Type" for all of them say "Not Available", and the IP Address, IP Subnect, Default IP Gateway, and DHCP Server all say "Not Available".

Last but not least, I can ping myself with no packet loss, but nothing else. So I don't think the NIC is bad; there has to be a conflict with that last MS update, but I just can't find it.

ANY insight at all would be greatly appreciated. This laptop belongs to the office manager, and I've been working on it for 3 days now! She's getting no work done, and neither am I, so this is becoming a bit of a problem.



My System SpecsSystem Spec
17 Sep 2010   #2

Windows 7 Ult, Windows 8.1 Pro,

Microsoft does provide support for problems caused by Windows updates. There is a good chance they will know what caused this problem and how to fix it.
My System SpecsSystem Spec
18 Sep 2010   #3
Jason Carlton

Windows 7 Ultimate x64

For anyone following this in the future, I'm working with Microsoft here:

Network adapters disappeared after critical update
My System SpecsSystem Spec

18 Sep 2010   #4

Windows 7 Ult, Windows 8.1 Pro,

Thanks for the update Jason, this looks like a tough one to solve. If you run out of options I might consider reinstalling Windows 7 and clearing the cmos on the problem machine and starting over again.
My System SpecsSystem Spec
18 Sep 2010   #5
Jason Carlton

Windows 7 Ultimate x64

Unfortunately, chev, I've read where other people with a similar problem had reinstalled Windows, but it still didn't solve the problem. I purchased a USB network card, thinking that would bypass the problem, but it didn't work, either.

This absolutely blows, though; the laptop isn't 3 months old, and it's starting to look like an expensive paperweight
My System SpecsSystem Spec
18 Sep 2010   #6


what you should try, since a system restore didn't work, is uninstall the offending updates, uninstall the network adapter drivers, remove them from device manager, then restart windows and let the OS "find" the "new hardware".. It's worked on a few machines I've worked on recently.. you may have to install the drivers afterwards, but it should fix your problem
My System SpecsSystem Spec
18 Sep 2010   #7
Microsoft MVP

Windows 7 Ultimate 32bit SP1

Did you happen to install the 'critical' update for Cisco wireless Lan Controller?
MS--September 9th and 14th updates
US-CERT Current Activity
My System SpecsSystem Spec
19 Sep 2010   #8
Jason Carlton

Windows 7 Ultimate x64

Thanks for the info, madtown. I did all of that on the first day, and that corrected the errors under Device Manager, but I still show no adapters under Network and Internet/Network Connections.

Jacee... maybe. I thought that I had set the laptop to not automatically install ANY updates, but it turns out that neither of my Win7 laptops remember that setting and update automatically, anyway. So, it did install a critical update on the 14th on its own, but I don't know what those updates were.

I do not have a Cisco wireless lan controller, though (at least, not to my knowledge). The adapters are Atheros AR9285 802.11b/g/n WiFi Adapter, and a Realtek PCIe FE Family Controller.
My System SpecsSystem Spec
19 Sep 2010   #9

Windows 7 Ult, Windows 8.1 Pro,

I would definately reinstall the OP system and avoid that update like the plague.

You may need to clear the cmos first but that will fix the problem as it will give you a clean slate.
My System SpecsSystem Spec
19 Sep 2010   #10
Jason Carlton

Windows 7 Ultimate x64

I don't suppose you know of an easy way to clear the CMOS on the HP G60-630 laptop, do you? Getting to the mobo isn't an easy task, and I'm sure it would void the warranty.
My System SpecsSystem Spec

 Network Adapters gone after MS update

Thread Tools

Similar help and support threads
Thread Forum
Different network adapters
Hi all, Besides the basic Ethernet and Wifi adapter, what are the other adapters used for. Microsoft Virtual WiFi Miniport Adapter #1 Microsoft Virtual WiFi Miniport Adapte #2 Thanks
Network & Sharing
Unidentified Network; No Network Access - Powerline Adapters
Hello 7Forums. I'll start off with the scenario that brings me here. Today, I managed to redecorate my bedroom; where my computer sat on top of a shaky, wooden desk. That desk is now gone, caput, and replaced by a much bigger, sturdier and prettier glass replacement. Before I dissasembled...
Network & Sharing
Network adapters disappeared
Hello. I joined this forum a few hours ago as I need help with something my pc has been having a long time now. My network adapters of my pc disappeared at the very moment and I really don't know what the cause is. I've let it check by a system admin and even he doesn't know what is causing it....
Network & Sharing
Many Network Adapters
Hi, I just noticed I had over 200 adapters but everytime I reboot it creates new ones Its the 6to4 adapter ... I have a red cross on the network icon on the right clock toolbar and everytime I try and open up a browser it freezes but I can get onto skype and update windows Any ideas ...
Network & Sharing
Need network adapters
I've reinstalled Windows 7 HP 32-bit on my mates Acer Aspire 5551 laptop. Everything is fine with the exception of the network adapters. Both the Ethernet and Network controller listed in the Device Manager have the yellow exclamation mark. As there is no Internet connection listed how do I...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:54.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App