Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No internet access on wireless network

20 Sep 2010   #1
durtdonthurt

64
 
 
No internet access on wireless network

Hello, I've been battling this problem for a few months now. On my lenovo x100e laptop with windows 7 I can connect to my wifi network and sometimes go to a website before it says "no internet access" while still being connected to the network. Any other laptop or phone connects and has internet just fine except for mine. Just one day out of the blue this started and I cannot find what's wrong and this is only with my laptop. The strange thing is that my laptop connects just fine with other wifi networks and has internet. What I have tried is re installing my wireless router countless times and also I re formated my laptop and re-installed windows twice. Problem is still re accuring. What could this possibly be?!


My System SpecsSystem Spec
.
20 Sep 2010   #2
patwhatsthat

Windows 7 Ultimate 64bit
 
 

My first thought would be DNS name resolution. When the problem occurs, open a browser and type 64.233.169.99 into the address bar and hit enter. If google comes up, then you can be pretty sure that your problem is linked to DNS.
If that is what's happening then perhaps you could hard code a couple public dns server addresses into the properties of IPv4 for your wireless card. Try 8.8.8.8 preferred and 8.8.4.4 alternate and see if that helps.
Also open task manager and under the processes tab, look for something called mdnsresponder.exe, if that is running then it may be causing your issue. If present, post back and we'll explain how to either uninstall or disable it.
My System SpecsSystem Spec
20 Sep 2010   #3
Prof Kerfuffle

Windows 7 Professional (x64/SP1) /Linux Mint 16
 
 

I would at a guess say its the adapter, try another spare or borrow an adapter, connect to the internet with it and see if the problem reoccurs.
My System SpecsSystem Spec
.

21 Sep 2010   #4
durtdonthurt

64
 
 

Thanks for the help pat and kerfuffle. Still having problems. I put in 64.233.169.99 and google did not come up. So then I looked in task manager and mdnsresponder.exe was not running. It's just the weirdest thing that it works perfectly on other wireless networks with no problems. This is really throwing me off because my brothers laptop and our phones work on the network and have no problems. Kerfuffle: I know its not my card because I can connect and have internet constantly on other wifi hotspots. Any other suggestions? Why wouldn't re formatting my comp fix it?! That's what I really don't get.
My System SpecsSystem Spec
21 Sep 2010   #5
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by durtdonthurt View Post
Hello, I've been battling this problem for a few months now. On my lenovo x100e laptop with windows 7 I can connect to my wifi network and sometimes go to a website before it says "no internet access" while still being connected to the network. Any other laptop or phone connects and has internet just fine except for mine. Just one day out of the blue this started and I cannot find what's wrong and this is only with my laptop. The strange thing is that my laptop connects just fine with other wifi networks and has internet. What I have tried is re installing my wireless router countless times and also I re formated my laptop and re-installed windows twice. Problem is still re accuring. What could this possibly be?!
Have you tried updating the firmware on your router or have you tried another router yet?
My System SpecsSystem Spec
21 Sep 2010   #6
Prof Kerfuffle

Windows 7 Professional (x64/SP1) /Linux Mint 16
 
 

I wouldn't see how reinstalling you're is would help, I agree. Maybe you could upgrade the firmware as chev65 mentioned. Maybe it isn't compatible with the router.

I can't give a definite answer because I have never read about an issue like this.



My System SpecsSystem Spec
22 Sep 2010   #7
durtdonthurt

64
 
 

yes, I updated the firmware on the router already as well..... keep in mind my laptop was fine and this happened all of a sudden. Only with my laptop. everything else connects and works just fine with no internet interuptions. Also, my laptop works just fine on other wireless networks....
My System SpecsSystem Spec
22 Sep 2010   #8
Prof Kerfuffle

Windows 7 Professional (x64/SP1) /Linux Mint 16
 
 

Add some rep for Chev65 (and me if you want) for his help
My System SpecsSystem Spec
22 Sep 2010   #9
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

In that case I would go through the routers wireless settings and make sure to use WPA2-PSK with AES encryption "only" and set to use G and N "only" plus you need to create the SSID.

After that use the manual wireless connection set up in Windows 7 to use the same settings, don't use mixed security settings then type in the SSID and try to connect again.

It may be required that you reset the router and start over again, once you get the router working save the settings with a .gsw file which you can do with most routers.
My System SpecsSystem Spec
22 Sep 2010   #10
durtdonthurt

64
 
 

well I went into basic wireless settings and changed the network mode to "N" only, changed the SSID, security mode was already on WPA2 personal, changed encryption to AES. Looked at my properties on the laptop for the network card and didn't have to change any settings....just re type the password after I changed the SSID..... Still acting the same...
My System SpecsSystem Spec
Reply

 No internet access on wireless network




Thread Tools




Similar help and support threads
Thread Forum
Suddenly Wireless Network says No Internet Access
Hey guys, I've read numerous threads and have been trying for the past six hours trying to get my stupid computer to connect to the wireless network. I have a Dell Studio XPS 1340 laptop, wireless card is "Dell Wireless 1510 Wireless-N WlAN Mini-card", router is cicsco E4200. I don't know that...
Network & Sharing
Wireless Network Connected but No Internet Access
Hey guys, I've been searching this forum and other resources for days now with no luck. I'm connected to our apartment's wireless network, but about a week ago I found the infamous yellow triangle and "No Internet Access." I was going along fine for about a month and this came out of nowhere. ...
Network & Sharing
Connected to Wireless Network, But No Internet Access
Hi, As said, I am connected to my Wireless Network but have no Internet access. So far I have looked through the forums and done the following: - unticked the ipv6 box - pulled any Firewalls down - disabled and re-enabled my network adaptors - tried the ipconfig/release and renew - left...
Network & Sharing
No Internet Access on wireless network
I'm usin HP 630 laptop with Win 7 Home Basic OS, and I have trouble connecting to a wireless network, in fact I can connect to a network but I dont have internet access, I'm using TP-LINK (TD-W8901GB (Annex B)) router. Does anyone know how to fix this?
Network & Sharing
No Internet Access on wireless network (TP Link)
I'm using DELL D620 laptop with Win 7 Ultimate OS, and I have trouble connecting to a wireless network, in fact I can connect to a network but I dont have internet access, I'm using TP-LINK (WR 741 ND (Annex B)) router. Does anyone know how to fix this? My boardband connection is working on a...
Network & Sharing
Wireless Network "No Internet Access" problem
I've got Windows 7 Professional and I've been having trouble with my wireless network. I can connect with the network but it always gives me a "No Internet Access" message and I can't use the internet. I try release/renew connections using ipconfig which sometimes work but mostly only briefly. ...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:20.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App