Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't Create Homegroup, Only Join.

21 Sep 2010   #1

Windows 7
Can't Create Homegroup, Only Join.

Hey everybody. I have 1 computer. It's a bran new computer with a bran new install of Windows 7 64bit (so all settings are default). I created a homegroup on a home network and Windows had me write down a password. I accidentally left the home group. Whenever I try to create it again, I don't get the create homegroup option, but rather a "Join Homegroup" option. I thought I got rid of it when I left. I typed in my written down password with no luck.

Real quick, how do I get the "create a homegroup" option back instead of the "join homegroup" option?

My System SpecsSystem Spec
21 Sep 2010   #2

Windows 7 Ult, Windows 8.1 Pro,

The fix for this problem seems to be Deleting the file idstore.sst under C:\windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking

There is also a registry adjustment for this problem which should be corrected with the following procedure. This is from Technet.

1. Temporarily disable Firewall and third party antivirus program on the computer for a test.

2. Verify relevant services
a. Click "Start", type "services.msc" (without quotation marks) in Search Bar and press Enter.

Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

b. Right click the "Peer Networking Grouping" service and choose Properties.
c. Please check if the service is started; if not, please click the Start button and see if it works.
d. You may also choose Automatic next to Startup type.
e. Click OK.
f. Please repeat the above steps with another service: PNRP Machine Name Publication Service.

3. Modify IPv6 registry key to enable IPV6
a. Click Start, type regedit in Search Bar, and then click regedit in the Programs list.

Note: If you are prompted for an administrator password or confirmation, type your password or click Continue.

b. Locate and then click the following registry subkey:


c. Check whether the "DisabledComponents" registry key exists. If so, let's move on the next steps.
d. Double click the "DisabledComponents" registry key and modify the value to 0.

(If the key doesn't exist, please create the key above and assign the value 0)

e. Exit Registry Editor, and then restart the computer.
My System SpecsSystem Spec

 Can't Create Homegroup, Only Join.

Thread Tools

Similar help and support threads
Thread Forum
Unable to join homegroup, homegroup creating computer is no more
The computer that originally created the homegroup on my network is no more. It seems that because of this that my new computer is unavailable to join the homegroup that already exists. Other computers that were part of the homegroup before the "host" computer died are still part of the homegroup...
Network & Sharing
Cannot create Homegroup, Only Join...
Hi there, I'm there are some threads on this but I couldn't find any answers. My Problem is, I re-installed windows 7 on my computer containing the Homegroup. Now I can only join the homegroup that should no longer exist. :confused: Is there a way to reset the homegroup on an Operating System...
Network & Sharing
Unable to create/join HomeGroup
G'day, I have recently tried to create a HomeGroup on my Win 7 Home Premium machine and it is not possible for some reason. When opening the "Network and Sharing" section and then clicking on "HomeGroup", I get a message stating that "This computer can't connect to a HomeGroup". Running the...
Network & Sharing
Unable to create homegroup, no join button
Hello, I'm trying to create homegroup with my pc at home and my laptop. Both computers connected to the same wireless network. My home pc is running windows 7 ultimate x64 eng, and my laptop is running windows 7 pro x64 eng. My router is TP-LINK 941ND, both the computer are not connected...
Network & Sharing
Homegroup encountered an error / This computer cannot join a homegroup
I get a "Homegroup encountered an error" message when I try to join my laptop and desktop to a homegroup. It does not matter which one sets it up and which one tries to join. It errors in either direction. I have tried leaving and creating, no use. The desktop is wired to a Belkin 300N router and...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:29.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App