Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: RDC Disconnects When You Type [RDC v2, Mac OS X]

28 May 2009   #1

Windows 7
RDC Disconnects When You Type [RDC v2, Mac OS X]


I'm using the Remote Desktop Connection v2 Client for Mac OS X. I'm able to connect to my Windows 7 machine from my Mac OS X using RDC without any problems or issues. However, as soon as I hit a key on my keyboard, it Disconnects.

I don't understand this. I didn't have this problem using the same machine (remote & client) when I was running Windows Vista. This is a Windows 7 issue. I can do whatever I want but I can't hit any key on the keyboard, it just disconnects.

Anyone else experience this? Any solutions?


My System SpecsSystem Spec
18 Aug 2009   #2

Windows 7 Pro (x64)
same issue

I installed Windows 7 Pro RTM last night and I was configuring it from my Macbook pro via RDP, it was working fine... I restarted the system and connected again this morning, again it was working fine-- I restarted the system remotely today and now I'm having the exact same problem. I can connect, use the mouse, but the instant I hit a key, I get disconnected.

I found that if I use the old version of RDC for mac (1.0.2) it still works fine but with version 2.0.0, I can't stay connected. What I find strange is that 2.0.0 was working fine last night and earlier today... The workaround is less than ideal, because the 1.0.2 has other issues.

Did you ever figure out what the issue was?
My System SpecsSystem Spec
03 Sep 2009   #3

Windows 7

I have been experiencing the exact same problem. Did you ever get a fix/work around for this?
My System SpecsSystem Spec

04 Sep 2009   #4

Windows 7 Pro (x64)

Lately it is only happening from my G5 when using the version 2.0 RDC program-- if I connect from my Intel Macbook Pro it works fine with version 2.0, but the G5 always disconnects the instant I press a key.

The workaround I've been using is still just to use the older version 1.0.2 Remote Desktop Connection client for Mac on my G5 machine.
My System SpecsSystem Spec
27 Oct 2009   #5

Windows 7, Mac OS 10.6, Windows XP, Mac OS 10.4
PPC computers / Remote Desktop Disconnect.

We have 3 PPC computers, and all have the same problem with Windows 2008 R2 when connecting with version 2 of Remote Desktop.

Please, if someone finds a great fix, we are all ears.:)
My System SpecsSystem Spec
10 Jan 2010   #6


seeing same problem from a ppc mac mini using RDC 2.1 to connect to a Win7 box. Has anybody got any news on this?

thanks all!
My System SpecsSystem Spec
20 Jan 2010   #7

Windows Server 2008 R2
Same issue, Windows Server 2008 R2

It seems to be an issue with the new RDP stack or authentication or something?

Any advice or solutions would be greatly appreciated. Our Mac OSX users are being left out in the cold.
My System SpecsSystem Spec
16 Mar 2010   #8

Windows 7 x64 / Mac OS X 10.5.8
Have you tried CoRD?


Have you tried the application CoRD? ( CoRD: Remote Desktop for Mac OS X ).

I find it a little choppier than Microsoft's RDC but I can definitely type without disconnecting.
My System SpecsSystem Spec
31 Aug 2010   #9

Windows 7 Professional

I have the same problem on a Power Mac G4 system running Tiger (10.4.x) trying to connect to a Windows 7 Enterprise system. Typing anything disconnects RDC v2, but RDC v1 works fine. Also, RDC v2 works fine from a MacBook running Snow Leopard (10.6.x) to the same Win 7 system.

I wonder if the problem has something to do with one of these issues:

o Compression
The fix documented in the following kb article resolved an issue on the same Win 7 Enterprise box. RDC would hang when I logged off of a remote system from the Win 7 box:

MSTSC.EXE (Remote Desktop) from Windows Server 2008 R2 to Windows 7 client crashes

According to the article, you modify the compression setting on the client side. I looked in the .rdp file on my Power Mac G4 for a similar compression setting, but couldn't find one. Web searches for the appropriate key led nowhere. If compression is even supported over Mac-to-PC connections, I would at least like to verify whether turning it off makes a difference.
o Network settings
On a Microsoft forum, a moderator suggests that hard coding the MAC address for a network card may fix some RDC problems. But the network card on my Win 7 system lacks this setting, so I was unable to test it:

Windows 7 hangs after successful Remote Desktop
I've given up for now, but maybe somebody can make something out of these two suggestions? Best of luck...
My System SpecsSystem Spec
10 May 2012   #10

Windows 7 Professional 64 bit

I realise that this thread is old, but for the record, this problem seems to have been fixed in RDC for mac version 2.0.1
I Started getting the problem yesterday when my target machine went from XP to Windows 7 and I was connecting using RDC for Mac version 2.0.0. I upgraded to RDC for Mac Version 2.0.1 and the problem went away.
My System SpecsSystem Spec

 RDC Disconnects When You Type [RDC v2, Mac OS X]

Thread Tools

Similar help and support threads
Thread Forum
Is default email account type deteremined by type of device?
I set up an Outlook account on a new-to-me laptop. I had been unable to download email for several months, since I didn't have a computer. I had been saving the emails I wanted to keep and had planned on downloading them into my new computer. After setting up the account, it appeared the system...
Microsoft Office
how to deal with photo files Type 1 and Type 2
I found a few pix in my files that I want to edit with Photoshop. I can't open them in PS because they are Type 1 or Type 2. When I try to open them, PS says they are .jpg.1 or. jpg.2. How do I get rid of the .1 and .2 so they become normal JPG photo files? I can look at them with Windows...
Music, Pictures & Video
Internet disconnects for a second
Hello, I just got a new computer and I'm having internet problems. I used to use an old XP desktop with direct connection and it stayed connected, used my vista laptop with direct connection and it stayed connected, and now with my new W7 desktop the internet does not stay connected. It just...
Network & Sharing
Internet Disconnects
So heres the deal. Ive recently upgraded from windows XP 32 bit to Windows 7 64bit, this ofcourse means Ive formatted my harddrives and made a clean install. But now Ive realised, that whenever I try to download a large file which takes several minutes, my computer will disconnect from the router...
Network & Sharing
VPN disconnects INTERNET
Hi, I am using CISCO Anyconnect. But regardless of what VPN, what happens is that connecting to VPN disconnects me from Internet which doesnot happen with XP. Is there a solution for this with anyone, please.
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:54.
Twitter Facebook