Problem with Atheros AR5007 802.11b/g adapter on laptop running Vista

  1. Posts : 1
    Windows Vista 64

    Problem with Atheros AR5007 802.11b/g adapter on laptop running Vista

    Hi, yesterday I purchased a Linksys E2000 Router. It immediately hooked up to my wired desktop running Vista and a laptop running Windows XP. However it had a problem hooking up to my wife's HP laptop running Vista. It would not let me hook up to the secured link but would let me hook up as a Guest with limited functionality. I called Linksys and they informed me that the Atheros AR5007 802.11b/g wifi adapter had compatibility issues with the Linksys E2000 and suggested I update with new drivers. I searched online but it seems I have the latest driver. I hope someone can help me since I have read other issues regarding the same subject. I am not sure if this forum is correct for me but it seems like it is more a driver issue than Windows problem. Any help would be greatly appreciated.

      My Computer

  2. Posts : 1
    Windows XP

    How to Connect wireless with Atheros 5007 802.11 B/G Wifi adapter

    Well your adapter Atheros 5007 802.11 B/G Wifi adapter on Vista has a Bug when connecting with WPA or WPA security
    Hence i would suggest u to change the Security to WEP on the Router, apply the settings & make a note of KEY 1
    on ur Computer clear the Preferred N/w from Manage Wireless N/w's
    Remove ur N/w name from List & try to scan & Connect to ur N/w
    Put in KEY 1 as ur passphrase or Security KEY, thats all u r Connected
      My Computer

  3. Posts : 1
    Vista Home Premium 64bit

    Fix for Atheros WIFI connection

    After having a VERY HARD time trying to get my verizon fivespot to connect via WIFI I finally figured out a solution. It would work by using the USB cable to the Fivespot and it would show up as a network but would not connect.

    The problem lies in the WIFI adapter. The Atheros AR5007.
    Not Vista, Not the Fivespot
    The drivers are probably not compatible and I could not find where people say that it is that the FiveSpot can't operate in "N" of 802.11 b/g/N. That is what my belkin is: a 802.11 b/g/n

    I took my Belkin USB WIFI antenna from my home computer and connected it to my laptop. It loaded the drivers and the Five Spot worked fine.

    So you need to go into the device manager
    then to network adapters
    disable the Atheros Adapter. Don't uninstall it as it will just reinstall the next time your start the computer. Plus this will allow you to keep it available to ENABLE again when you are connecting to another device that doesn't have the problem.

    So I am going to get another WIFI antenna that might be a small micro USB adapter to leave in there all the time.
    It uses a usb port but it made it work.

    Now I haven't tried it but I think by using a Verizon MIFI will work also.

    After two days and more than 60 minutes with Verizon tech support and about an hour at the Verizon store, many hours on the net with google. This has worked perfectly.

    Good luck.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:07.
Find Us