Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Able to ping out but unable to surf via ip or url

12 Nov 2010   #11

Windows 7 Ultimate x64

I have done that as well... I run my computer with the bare minimums it needs to run, not all the access programs I don't need. My laptop boots in under 30 seconds

My System SpecsSystem Spec
12 Nov 2010   #12

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer

Okay, you can download a live cd of ubuntu. Boot up and you should have Internet access. If not, it's a hardware problem. If you have access, then you may have to blow out the OS and reinstall.
My System SpecsSystem Spec
13 Nov 2010   #13

Windows 7 Ult, Windows 8.1 Pro,

Quote   Quote: Originally Posted by edith89 View Post
Hi there,

My fiance and I have both been puzzling over this one for a number of days.
I have a Toshiba Satellite L500, running a duo-core cpu and 3gb with Windows 7 Ultimate x64. We are both fairly advanced users and have tried everything we can think of/find with no avail so we are asking for help.

I generally run Firefox as my default browser but we have also tried IE8 with and without add-ons and are getting connection timed out errors and cannot access a website (wirelessly; a hard wire connection works fine). My belkin router is all setup and secured, and my laptop shows I am connected to both the network and internet. I can ping out to google and other sites just fine but I cannot surf using ip or url.

I disabled my firewall completely, ran Spybot, Malwarebytes, and Trend Micro House Call. they picked up a few cookies and such but nothing to affect connection.

We checked all proxy settings on both the router, and the browsers. Reinstalled the browsers. We are getting a valid ip, there are other PC's connected to the router (1 wired, 1 wireless)

I've done a netsh winsock reset, dns flush, reinstalled the wireless NIC multiple times, even tried System Restore.

I'm at my wits end and I'm hoping someone can help before I have to break down and reinstall my Windows.
Have you tried resetting the TCP/ip stack?
netsh int ip reset reset.log hit (reset TCP/IP stack)

Or you could try running this batch file which resets everything.
Download Renew IP + Reset Winsock Batch File

My System SpecsSystem Spec


 Able to ping out but unable to surf via ip or url

Thread Tools

Similar help and support threads
Thread Forum
Unable to test my connection ping on
Good morning everyone. Can I ask why can't I do ping test of my connection on They always saying that Java is not installed although I cleared histories, cookies and cache and reload the website for countless times. Besides that, my Java version is Version 8 Update 45 (build...
Network & Sharing
Network Nightmares. Unable to ping
Hello! First time here. I have four computers on a home network, two (A&B) running Win7 Home Premium 64bit. Two (C&D) running XP SP3. The two Win7's are recent installs but I had lot's of similar troubles with an earlier install of Win7 Ultimate, so I switched to Home hoping I could fix this....
Network & Sharing
Unable to run Ping and Traceroute
Hello I installed ibVPN trial version yesterday for a test run and within an hour of running it, I uninstalled it. However, since then, I am unable to run Ping and Traceroutes to any website through the CMD. I later noticed a TAP 2 network adapter being installed along with the VPN client,...
Network & Sharing
Wifi shows connected with full signal but unable to surf the internet
As shown here: I connected to HTC Aria Wifi Hotspot and on the task bar it shows full signal. On the network and sharing center, there was a 'RED CROSS' although it said Access Type : Internet. After I connected to the...
Network & Sharing
unable to ping win7 from virtual xp
I am using a virtual xp from Virtual PC 2007. I cannot ping to the Windows 7 host using the host name. If I use the IP address it works fine. I am trying to connect from the virtual xp to the Windows 7 SQL Server instance. I can connect using the IP address but given that it may change I would...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:02.
Twitter Facebook Google+