Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet is connected, everything works except browsers

18 Nov 2010   #11
Nighthacker

Windows 7 Ultimate x86
 
 

Quote   Quote: Originally Posted by tezlewis View Post
Sounds like Antivirus program preventing Internet explorer getting connection settings so will sit there until it does! Whats your antivirus program please? If you can update it shows a clear connection to the internet!

Have you tried this in safemode with networking? Worth a shot!
I have both microdoft security essentials and avast pro

Quote   Quote: Originally Posted by chev65 View Post
Quote   Quote: Originally Posted by Nighthacker View Post
I have windows 7 ultimate 32-bit. Wheni connect to the wireless network, it says connected, internet access. Everything works except the browsers, like the anti-virus updates, games,basically everything except the browsers. I use firefox and internet explorer by the way.
I'm using Windows virtual machine, XP mode to write this. This started about 2 days ago, and system retore was turned off when i checked so it would be impossible to that.
This problem can usually be fixed by resetting winsock. Try running both of the commands below one at a time in an elevated command prompt, reboot after each one.

netsh winsock reset catalog (reset winsock entries)
netsh int ip reset reset.log hit (reset TCP/IP stack)
thxs i'll try that


My System SpecsSystem Spec
.
18 Nov 2010   #12
Nighthacker

Windows 7 Ultimate x86
 
 

Quote   Quote: Originally Posted by Nighthacker View Post
Quote   Quote: Originally Posted by tezlewis View Post
Sounds like Antivirus program preventing Internet explorer getting connection settings so will sit there until it does! Whats your antivirus program please? If you can update it shows a clear connection to the internet!

Have you tried this in safemode with networking? Worth a shot!
I have both microdoft security essentials and avast pro

ok i tried safemode with networking and the browsers worked
Quote   Quote: Originally Posted by chev65 View Post
Quote   Quote: Originally Posted by Nighthacker View Post
I have windows 7 ultimate 32-bit. Wheni connect to the wireless network, it says connected, internet access. Everything works except the browsers, like the anti-virus updates, games,basically everything except the browsers. I use firefox and internet explorer by the way.
I'm using Windows virtual machine, XP mode to write this. This started about 2 days ago, and system retore was turned off when i checked so it would be impossible to that.
This problem can usually be fixed by resetting winsock. Try running both of the commands below one at a time in an elevated command prompt, reboot after each one.

netsh winsock reset catalog (reset winsock entries)
netsh int ip reset reset.log hit (reset TCP/IP stack)
thxs i'll try that
just tried it IE and FF still won't work in regular mode
My System SpecsSystem Spec
18 Nov 2010   #13
Nighthacker

Windows 7 Ultimate x86
 
 

scrath that did the winsock again and now internet works!
My System SpecsSystem Spec
.

18 Nov 2010   #14
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by Nighthacker View Post
scrath that did the winsock again and now internet works!

I've seen this same problem many times before so I had a pretty good idea how to fix it. Glad it worked for you Nighthacker.
My System SpecsSystem Spec
26 Mar 2012   #15
JJackman

7 64 bit
 
 

Chev65 - thanks for your post, I ran into this problem on a new install of Win 7 64 bit and was utterly baffled by the fact that some browsers could connect and others could not. Your solution was what I needed!
My System SpecsSystem Spec
26 Mar 2012   #16
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by JJackman View Post
Chev65 - thanks for your post, I ran into this problem on a new install of Win 7 64 bit and was utterly baffled by the fact that some browsers could connect and others could not. Your solution was what I needed!
I'm glad you could fix the browser problem by just finding this page Jackman.
My System SpecsSystem Spec
10 Feb 2016   #17
blopa

Windows 10
 
 

Quote   Quote: Originally Posted by chev65 View Post
Quote   Quote: Originally Posted by Nighthacker View Post
I have windows 7 ultimate 32-bit. Wheni connect to the wireless network, it says connected, internet access. Everything works except the browsers, like the anti-virus updates, games,basically everything except the browsers. I use firefox and internet explorer by the way.
I'm using Windows virtual machine, XP mode to write this. This started about 2 days ago, and system retore was turned off when i checked so it would be impossible to that.
This problem can usually be fixed by resetting winsock. Try running both of the commands below one at a time in an elevated command prompt, reboot after each one.

netsh winsock reset catalog (reset winsock entries)
netsh int ip reset reset.log hit (reset TCP/IP stack)

Thank you, that fixed my problem on Windows 10. Sorry for ressuracting this post, but I had to thank you.
My System SpecsSystem Spec
Reply

 Internet is connected, everything works except browsers




Thread Tools




Similar help and support threads
Thread Forum
Internet connected. Browsers don't work
Hello. I've tried everything I can think of, plus many recommendations online. For some reason, my desktop broadcasts, chrome Firefox and ie, will not open any webpages. What is the first step i should take?
Browsers & Mail
Connected to Internet, browsers not working
Windows 7, 64bit and using IE 11 and Firefox. Neither browser works. IE = Page can't be displayed. Firefox = Crash Reporter. I currently have it im my network. I can ping websites by name (i.e. google.com) and get responses just fine, I can run Windows updates and it communicates fine. ...
Browsers & Mail
I am connected to the internet but unable to use the browsers
I have a Dell Inspiron 1545 with a wireless connection. Although my laptop tells me I have excellent signal strength and my computer is connected, my browsers (Chrome, Firefox, IE) will not let me browse. Other programs I have, such as spotify and Itunes allow me to for a short period of time...
Network & Sharing
Connected to Internet - browsers won't load
Hi there, I am using windows 7 64 bit. I am connected to the Internet however IE nor Firefox will load? I am not sure what to do? I am a uni student and desperately need the Internet to complete an assignment, any help is much appreciated Cheers Kim
Network & Sharing
Internet works but not browsers
I'm using Windows 7 Home Premium 64-bit. Lately when I try connecting with any browser it says I can't like the internet is unplugged. But I can download and install Windows 7 updates. I was maybe thinking it was a virus so I installed Malwarebytes and Superantispyware. Malwarebytes wouldn't...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App