Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't connect to the wireless network

27 Nov 2010   #1

MS Windows 7 Home Premium 64-bit
Can't connect to the wireless network


I'm having a problem with my wireless network connections. Everything were working fine until this morning when I found out that my internet connections were suddenly disconnected. I tried everything, even to recover the system but still no luck. My wireless adapter (Intel Wifi Link 5300 AGN) can detect the wireless connections but can't connect. When I check the status of the hardware it was working properly.
My system is Alienware M15x with Win 7 Home Premiumx64m

My System SpecsSystem Spec
27 Nov 2010   #2

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)

hi and welcome to the forums
this is a problem that you will see on the threads quite frequently these are some the steps i take to resolve it
run windows troubleshooter
Reset to Default
Resetting your router or adapter back to factory default will erase any setting changes you have made. This is done because in theory this was the setting the router or adapter used when it was in working order. Reset to default if your wireless router or adapter is not transmitting a signal. This functions like the computer restore command for a computer.

In addition if your system runs Bonjour, or any other 3rd Network manager, remove them or disable them in local services

also try this
  1. Type Cmd in the Start Search text box.
  2. Press Ctrl-Shift-Enter keyboard shortcut to run a Command Prompt as an Administrator. Allow elevation.
  3. Type route delete press enter.
  4. Type ipconfig /flushdns press Enter
  5. Restart your Computer.

netsh winsock reset in the Command Prompt (run Command Prompt as Administrator)

1. Click on Start button.
2. Type Cmd in the Start Search text box.
3. Right click cmd in search results and click run as Administrator
4. Type netsh winsock reset in the Command Prompt shell, and then press the Enter key.
5. Restart the computer.

go to brinks tutorial here this will help reset settings
Wireless Network - Remove

Perform a SFC Scan

1. Click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow

2. Type the following command, and then press ENTER:

sfc /scannow

A message will appear stating that 'The system scan will begin'. Be patient because the scan may take some time

3. If any files require a replace SFC will replace them. You may be asked to insert your Windows 7 DVD for this process to continue

4. If everything is okay you should, after the scan, see the following message "Windows resource protection did not find any integrity violations"

5. After the scan has completed, close the command prompt window, restart the computer and check.

more information here
My System SpecsSystem Spec
27 Nov 2010   #3

MS Windows 7 Home Premium 64-bit

Thanks so much Brian.
It fixed my problem once and for all...
My System SpecsSystem Spec

27 Nov 2010   #4

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)

excellent what method done it for you ? so this thread is resolved?
My System SpecsSystem Spec
24 Feb 2014   #5


I know this thread is practically ancient, but I'm having the exact same problem with the same computer. I went through all of the steps you gave Brian, and I'm still having no luck. The modem works well with everything else, and it just stopped working with my M15x out of nowhere. Should I just take my computer to a repair guy? P.s. The only difference is that my computer says the modem is the problem, but the modem clearly transmits to every other wireless device. Double P.S. I don't quite know what the hell I did, but the internet is back on! Thanks for the interesting learning experience with command prompt though LOL
My System SpecsSystem Spec

 Can't connect to the wireless network

Thread Tools

Similar help and support threads
Thread Forum
can't connect to wireless network
Got a new laptop from university, had to mannually create network to connect to "eduroam" (maybe i didin't, but i did). Got home, connecting to home network and.. it is just spinning and just can't connect. I have another old laptop, and it connects freely without problems, same with smart...
Network & Sharing
still looses connect/doesn't connect - win 7 wireless home network
She keeps loosing connection, then has to wait until it decides it can connect again. She would wait about five minutes and then click on something and would gain access. the ...
Network & Sharing
Can't connect to wireless network
Since I installed Win 7 I am unable to connect to my wireless network. IP is Roadrunner and my wireless router is Linksys model WRT110. When running ipconfig from prompt it states the following: Wireless LAN adapter Wireless Network Connection: Media State . . . . . . . . . . . :...
Network & Sharing
Can see wireless network but won't connect
Can anyone please help. I have 3 computers all running 64bit Windows Home premium all have 802.11n cards. 2 have no problem connecting to the wireless network the 3rd can see the network but won't connect or has the dreaded yellow exclamation mark with limited connectivity. This seems to be...
Network & Sharing
Can see but can't connect to wireless network
I know you guys are probably sick of hearing about this stuff. Sorry I'm using an Eeepc 900hd, just loaded windows 7 ultimate on it. My wireless driver is up to date (so it says, although I've tried to install a new driver, but it "doesn't work on this operation syste,"). I turned off my...
Network & Sharing
Can see wireless network but can't connect
My Vista Ultimate desktop can see my wireless network, but for whatever reason it is unable to connect to it. I tried system restore, and disabled windows firewall all to no avail. The only change that has been made since it worked to now it's not working is that I connected it to WIn7 homegroup...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:54.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App