Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: usb adapter only connects at 48Mbps when it says 150mbps usb adapter?

19 Dec 2010   #1

Windows 7 Professional x64 (6.1.7600)
usb adapter only connects at 48Mbps when it says 150mbps usb adapter?

i have a EDIMAX 150Mbps b/g/n usb adapter. and only connects at 48mbps. it should at least do 54mbps with a G router? somebody help

My System SpecsSystem Spec
19 Dec 2010   #2

Windows 7 Professional x64

You don't even download at 48 Mbps so you don't need to worry about anything...
My System SpecsSystem Spec
19 Dec 2010   #3

Win7 & Win8 64bit

Hello again,

I believe that you have a similar Thread going on here.

Anyway, I'll just post here, maybe a Mod can merge your 2 Threads if needed.

To answer you question, you may change the Mode of your wireless network adapter, by default, the settings is on Auto or Mixed Mode, you may change it to a 'G' Mode and see if that helps.
My System SpecsSystem Spec

19 Dec 2010   #4

Windows 7 Professional x64 (6.1.7600)

my router is set to connect at 54 but my usb adapter only connects at 48 but i guess its not slowing me down. cause i had a laptop at 54 and it downloaded torrents at 1.5MB/s :) and this still hits 1.5 connected at 48. so owell thank you guys how do you delete threads that are solved? so people dont waste here time looking at them . save them time you know :)
My System SpecsSystem Spec

 usb adapter only connects at 48Mbps when it says 150mbps usb adapter?

Thread Tools

Similar help and support threads
Thread Forum
Wifi adapter could not bind IP protocol stack to network adapter
Hello! I registered to forums to get help to solve wireless adapter issue I am having. I have been looking for help in Lenovo forums and AV provider: problem is still on. Background I changed AV software from Symantec to F-Secure. I uninstalled Symantec software and installed F-Secure...
Hardware & Devices
Bluetooth USB adapter - PS4 controller no longer connects wirelessly
Hello. I was previously trying to solve a problem where, when plugging in my USB Bluetooth adapter to my computer, Windows would show both the Bluetooth adapter (labelled as CSR8510 A10) and a "Wireless Controller" in my Devices and Printers panel, even though there was no controller connected....
Hardware & Devices
Wireless adapter connects to network, however no internet connection
Hey everyone. This is my first time venturing for assistance. Typically I can fix things on my own but at this point I am stumped. I recently got a new router(Asus RT-ac3200), and upon setting it up my desktop pc no longer can connect to the internet. My wireless adapter is the TP Link...
Network & Sharing
AWUS036H adapter can't find specific network but inbuilt adapter can
Hello I have my AWUS036H for a few months now and it worked perfect until now. My landlord has a router in his appartment and I need to connect to that router to get access to the internet. I bought this adapter for a better signal but this week I got a very weird problem. My adapter can find...
Network & Sharing
display adapter is stuck on standard vga adapter
I know there are several threads but they are with different cards and they didn't solve my issue... I bought a new MEDION AKOYA P5334E and the system arrived installed normally with win7 home edition. I've installed on the computer the win7 enterprise edition (x64) and many drivers could...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:48.
Twitter Facebook Google+