Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can see, but cant connect to, Wireless Router Win7

20 Dec 2010   #1

Windows 7 Home Premium 64bit.
Can see, but cant connect to, Wireless Router Win7

I have a Toshiba A505-S6980 laptop running Windows 7 64bit version.

All was working well a couple of months ago, connecting wirelessly to my O2 Wireless 2 router (the Laptop has a REALTEK RTL8191SE wireless adapter card).

I also have a desktop running XP that I use to connect to the same router. Whilst on the desktop, I noticed several weeks ago that the router was set up with WEP security rather than WPA, so I decided to change the router to WPA. The Desktop PC was fine with this but the laptop complained and would not connect, failing authentication and just stating "Unable to connect to xxxxx". At the time I assumed it just couldn't handle the WPA authentication for some reason and decided that I'd probably turn it back to WEP at a later date to get it working again. At some point, I did remove an 'O2 Connection Manager' that had been installed when I bought an O2 3G dongle, in case it was confusing the issue but it made no difference. In the mean time, I tried connecting the Laptop using a wired connection and that worked fine.

However I have now (several weeks later) decided I wanted to use the Laptop wirelessly again so set the router back to WEP expecting this to work, but it didn't. As per with WPA, it does not get past authentication when I put the security key in. So, I'm trying to figure out the problem.........

What's happening;

1) The laptop CAN wirelessly see my router (and my neighbours), but just cannot connect.

2) I can connect using a Wireless USB Adapter on the same Laptop.

3) I can connect the Laptop to the router using a wired connection and there is no problem.

4) My desktop running XP can connect to the router wirelessly as WEP or WPA so router is ok.

5) It was working several weeks ago!

What I have tried;

1) I have installed the latest REALTEK RTK8191SE driver.

2) I have tried turning security off on the router, no joy.

3) I have removed all network profiles on the Laptop.

4) I have tried it with Norton Virus Scanner and Firewall turned off (but haven't uninstalled it) but no help.

5) I have tried doing a system restore to the earliest possible point and no help.

5) I have uninstalled the wireless adapter and its driver in Device Manager......... Windows 7 then see's it after a reboot and re-installs it (using the default older driver) but this doesn't work. I have then re-installed the latest version from REALTEK to make sure it's up to date.

What is odd is that

1) it works ok using a USB Wireless Adapter

2) the internal REALTEK wireless adapter works to a point as it can SEE my router, just not connect

3) it fails authentication almost instantly

My suspicions are that a Windows 7 automatic update or the O2 Connection Manager has somehow screwed it up. I have uninstalled the O2 Connection Manager and have tried un-installing the automatic updates but there are loads of them and I'm not sure how far back I need to go. Also, because it fails the authentication straight away, it seems it's not giving it a chance to actually work.

Does anyone have any ideas on how I can proceed or had a similar problem?!

My System SpecsSystem Spec
20 Dec 2010   #2

Win 7 Ultimate 32bit

Tried turning off or unplugging the router for a few moments and plug it back in / turn it on?

Could it be a bad/flaky keyboard typing in wrong characters?

Yes, you could have a wireless device see routers but not connect.
To test and be sure, find a free wifi hotspot and try to connect.
If same, with everything else you have tried, it's a bad WIFI NIC on the laptop.

Or after reading more carefully,,, yes, it could be a compatibility issue with the Router Connection Manager and Windows 7. Why do you need the connection manager installed?
Generally, IMO ,,, all 3rd party connection managers are garbage and cause issues at some point.

I would try a different WIFI connection spot and use Windows Built-In Wireless Manager. (aka WLAN AutoConfig) ... Might need to uninstall that connection manager and make sure the WLAN AutoConfig service is started.
My System SpecsSystem Spec
20 Dec 2010   #3

Windows 7 Home Premium 64bit.

Thanks for the pointers guys.

I am sure the encryption key is correct - I use the same one on the same laptopn but using a USB wireless adapter instead of the internal one and it works.

Sorry Tepid I may not have made it clear but I have removed the O2 Connection Manager. And it was only ever on there as it was required for my 3G Wireless pay as you go dongle for when I am out and about.

The router should be fine as it works using another PC and also same PC but using thr USB adapater instead of the internal Realtek one.

The only things I have left to try is
a) safe mode with networking (as TooCrooked advised)
b) try the laptop on another router (neighbours or family's)

If that all fails, then I will maybe have to re-install Windows 7 from scratch - a pain as I wasnt given discs with the Laptop and also having to back everything up.
My System SpecsSystem Spec


 Can see, but cant connect to, Wireless Router Win7

Thread Tools

Similar help and support threads
Thread Forum
Cant connect to Wireless SKY router
Hi all I know you get this all day every day and i have done some research.... but here's my problem: I recently built my own gaming pc, spec'd as follows: Asus Rampage IV Formula Win 7 Ultimate 64 bit I73930k GTX 680
Network & Sharing
Cant connect to wireless router
my computer wont connect to my router. i have 2 others that do connect. one is windows 7 and the other is vista. all have avg free AV I can connect to other networks but not mine. it is currently unsecured until i resolve my problem. things Ive tried so far: 1. uninstalled drivers and...
Network & Sharing
Cant Connect to my Wireless Router
Hi, So I just brought a Toshiba laptop with windows 7 premium. I cant seem to connect to my NETGEAR Wireless router. My previous laptops connected fine. When I search for a wireless device it picks it up, Then I click Connect, Shortly after I just get a trouble shoot message that doesnt help me at...
Network & Sharing
Can see wireless router, but cant connect
So I upgraded to windows7 a couple of days ago, and am completely unable to connect to the wireless router. I have tried numerous drivers. My wireless network adapter is a realtek rtl8187 wireless. Im able to see the networks, but everytime i go to connect it just wont. Whenever i use a wired...
Network & Sharing
cannot connect to my wireless router
I just loaded windows 7 connected my laptop to my router with network cable but cannot connect wireless. I'm right next to it I see it when I hit connect it just goes away and says it has problems connecting.
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:58.
Twitter Facebook Google+