Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Problem with wireless adapter - I really hope someone can help!

12 Jan 2011   #1

Windows 7 Home Premium 64bit
Problem with wireless adapter - I really hope someone can help!

I ordered a Tenda W311U (exactly the same one that I've had working perfectly on my system for a year or so) for my nephew's laptop and at first, I thought it was going to work - plugged it in and was connected straight away. I went for that adapter because it seems to be the only one that wants to work with my system - I've tried others that are supposed to be Win 7 compatible, yet the Tenda is the only one that wants to work.

So then, I plugged the other one into my PC and that dropped the connection on the laptop (full five bars, but with a yellow exclamation mark)! Upon checking with ipconfig /all, I discovered that the laptop was reading the new adapter with the old one's MAC Address - so I assumed that must be what's causing the issue.

So, I uninstalled the adapter, driver and all - hoping that plugging in the new adapter would now read as its proper MAC Address (because each adapter is supposed to have its own one, isn't it?) Now, the damn thing won't 'connect' at all. I tried it in my system, same thing. I tried installing drivers from the disk, drivers from online, I tried rebooting the router, tried various security settings and nothing works - the only adapter that wants to work either with my system or my nephew's is the old W311U! I know this can't possibly be the case, but it's like the machines have formed some kind of relationship with this particular adapter!

Along with the slowdown and typing lag I seem to be getting, I'm beginning to think of doing a fresh Windows 7 installation - not formatting the disk, just reinstalling Windows 7 in the hope that'll 'reset' everything and it'll recognise the new adapter - as well as get rid of the typing lag problem. It's worth a shot; I doubt if the new adapter is faulty, because as I said, it was connecting before provided my PC wasn't online, so if I send it back, they'll probably test it as not being faulty, so I'll incur the postage charge and still be stuck with an adapter that I can't get to work.

I'm at my wits end with these bloody adapters, so if anyone can help that would be great. If you reckon a fresh Win 7 installation might sort everything out, then that's what I'll have to do.

I've scanned for malware etc - all is clean.

My System SpecsSystem Spec
12 Jan 2011   #2

Windows 7 Home Premium 64bit

56 views and no replies - hasn't anyone got an idea what's going on here? If the damn thing just refused to connect at all when I first got it, then it would be obvious that it's faulty - but that wasn't the case!
My System SpecsSystem Spec
12 Jan 2011   #3

Windows 10 Pro X64

You said "So, I uninstalled the adapter, driver and all". When you uninstalled it, that removed it from the system.

Did you then reinstall the driver? Did it come with a CD?
My System SpecsSystem Spec

12 Jan 2011   #4

Windows 7 Home Premium 64bit

Mate, I know the basics of operating a PC. Of course I reinstalled it - I tried both with the CD that came with it and with drivers downloaded from the internet - neither worked; I also tried allowing Windows to install the drivers automatically - that worked when I first used my own adapter in the laptop, but it didn't work with this one.

I just tried turning the router off and unplugging all its wires, leaving it for 30 minutes - that didn't work either. Next, I'm going to give resetting the router a shot - in other words, resetting it back to its default settings, and changing the wireless keys back to the defaults as well (temporarily). If that doesn't work, I'm going to return the laptop to its factory defaults (it's only a couple of weeks old, so it's much less of a chore than doing the same to my system).

If none of that works, then the damn thing must somehow be faulty - but as I outlined in my post, it seemed to work at first.

All this would've been avoided if the built in wireless adapter in the laptop agreed to co-operate.
My System SpecsSystem Spec
12 Jan 2011   #5

Windows 7 Home Premium 64bit

Complete success! Resetting the router to factory did the trick. Both machines up, online, nice strong signal. Feels good sorting something out that you've battled with for a while. :) Changed all the security stuff back to what it was and everything's still fine. :)
My System SpecsSystem Spec

 Problem with wireless adapter - I really hope someone can help!

Thread Tools

Similar help and support threads
Thread Forum
Problem with wireless adapter, wireless network disconnects abruptly
Mine is Dell Inspiron 3537, Os: Windows 7 Ultimate x64. My laptop wifi works fine for some period of time, but suddenly the current wireless connection gets disconnected and no wireless networks appear in the list. The network connection icon in taskbar changes to no network connection (small...
Network & Sharing
Wireless adapter problem
Guays, sry for my bad grammer, cuz i am just learning it, and sry if i posted in wrong section, but didnt know where to write, so i took CRASHES and ... I have very, very similar problem as this guay, but unfortunately, i didnt fix my problem. Only diference from he and me is that he had extra...
Network & Sharing
Belkin wireless adapter problem
Hi, I have recently purchased a belkin F6D4050 N150 Enhanced Wireless USB Network Adapter and installed the driver from belkins site. The adapter stays disabled regardless of me trying to enable it. I have been trying to solve this for days!! I have followed your instructions and the ones on the...
Network & Sharing
"Wireless Adapter Not Found!" - Internet Adapter Problem
Hi, I bought the D-Link Xtreme N Dual Band USB Adapter (Model: DWA-160) and installed the drivers and such, and my computer detects the actual USB Adapter fine, but the software that came with the device doesn't, and gives me the message "Wireless Adapter Not Found!"... It does say that it's...
Hardware & Devices
BELKIN Wireless G USB adapter Problem- again
Hi all members. I read alot topics on this forum to try solve my problem. I found in here 2 topics about Belkin Wireless G USB adapter , but still i have a problem I describe whats the problem . I try to instal on my Windows 7 x64 b.7000 drivers for belkin w g usb adapter f5d7050 I...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:54.
Twitter Facebook Google+