Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot Connect To Group Policy Client Service.

19 Jan 2011   #1

Windows 7 Pro 32-bit
Cannot Connect To Group Policy Client Service.

Hello All,

I have been receiving the following error when a normal user logs into a win7 pro 32bit computer, authenticating to a Windows Server 2003 R2 domain:

"Windows could not connect to the Group Policy Client Service. Please consult your system administrator."

It follows by logging them off.

So when I log on as an administrator everything is fine except i get a bubble message stating Windows couldn't connect to the group policy service.(please see attached file, top picture)

So my first idea was to disjoin it from the domain then rejoin it, but when i go into computer properties I get a message saying The RPC Server is unavailable.(see middle picture in attached file) It still allows me to get to the change domain menu but our domain (ISD) doesn't show up, it just says *Unknown* as the domain. (see bottom picture of attached file) It doesn't allow me to change the domain.

The RPC Service in services.msc is started and it doesn't have an error message. What is peculiar is the service called Server is missing. Don't know how to get that back.

Any help would be much appreciated, this is happening on several machines in our domain and I have been bashing my head trying to figure this out.

Thank you for your time,

Attached Thumbnails
Cannot Connect To Group Policy Client Service.-error-all.jpg  
My System SpecsSystem Spec
19 Jan 2011   #2

windows 7 enterprise 32bit

things usually to check when troubleshooting any problems occuring within an AD authentication/logon are DNS DNS and once more DNS. Did I mention DNS ? you could check that...

Also you may find that it is simply a timing issue. Synchronisation differences between domain controllers themselves and also between clients and DCs can cause all manner of oddities.

Although your indication that alls well when you logon using an admin account could indicate that it is a GPO specific issue.

what I would suggest is logon to the machine using a local admin accout and checking out the event logs for both security and system for the times around a specific user logon. google is your friend here, just google the event id with the provider. or click the link that MS have provided in the newer versions of windows.

this missing server service may be simply related to a GPO security setting or could be something more sinister, is the machine protected with Anti Virus and Malware ? is it upto date ?

hope at least some of this helps...

let us know how you get on.


My System SpecsSystem Spec
19 Jan 2011   #3

windows 7 enterprise 32bit

oh and one more thing,
I have experienced problems similar to this after Windows update has decided to update the NIC drivers.

you can roll those mother hubbards back !! lol.
My System SpecsSystem Spec

19 Jan 2011   #4

Windows 7 Pro 32-bit

Thank you for your advice, I checked the dns both on the machine and the server, all is true.

The computer account is placed in AD where the default domain policy is the only policy affecting it. The only policies I have enabled that could affect it is 'Run Logon Scripts Synchronously'(enabled) and Scripts policy processing'(enabled)

It is av protected with all windows updates. I am going to try to uninstall the av.

It doesn't seem to have received an update for the nic card, roll back was greyed out. I will try an update the nic card.
My System SpecsSystem Spec
19 Jan 2011   #5

windows 7 enterprise 32bit

Failing everything else you should have some idea of where it's going wrong from the event log. you could check both AD Controllers and your client machines.

Also to remove GPO completely from the equation you could move both user and computer objects into a newly created OU which you have "Blocked Inheritance" upon.

again let us know about the errors in event log.
My System SpecsSystem Spec
20 Jan 2011   #6

Windows 7 Pro 32-bit

It was the av, there were files on the machine that matched the conflickr virus. The av was designed to disable certain windows services. We were on the phone with their tech support and they gave us a new av program that worked!

Thank you for your help!!
My System SpecsSystem Spec
20 Jan 2011   #7

windows 7 enterprise 32bit

sweet, that's ace !!

glad you're up and running.
My System SpecsSystem Spec
17 Feb 2013   #8

Windows 7 64 bit

The crash of your computer during Windows Updates has caused that !
I had this issue on my laptop since November, and it really bugged me. I sifted through the event log and found the pattern of events that preceded the issue, and, probably, caused it.

In short, the pattern is as follows: Windows updates run automatically as scheduled, and when reboot is initiated after the updates are finished, the computer crashes (probably during reboot sequence). When it boots up, it reports that the last shutdown was unexpected, and the issue begins to occur.

I spent 2 days trying to dig out a solution from the Internet, to no avail, until I came across this page. It doesn't say anything about this particular problem, but it gives more information about SVCHOST process that starts many services, including Group Policy Client. It looks like during reboot a vital registry settings were lost during crash and Group Policy Client "don't know" how to start. Let me explain:

There are two places to look in the registry:
  1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services this path should contain gpsvc key (a folder), which is responsible for service parameters and configuration. I found that the key was intact, so, you do not touch anything here - just check that the key exists.
  2. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SVCHOST This is the most important path you should look into, as it must contain the keys and values referred in the key #1. Below are descriptions what must be present there.
  • There must be Multi-String value called GPSvcGroup. My laptop was missing it. So, you should create multi-string value named GPSvcGroup and assign it value GPSvc.
  • Next, you must create a key (a folder) and name it GPSvcGroup - this key normally should be there, but, again, it was missin on my laptop.
  • Then open newly-created GPSvcGroup folder and create 2 DWORD values:
  1. First called AuthenticationCapabilities and you must give it a value of 0x00003020 (or 12320 in decimal)
  2. Second is called CoInitializeSecurityParam and it must have value of 1.
Once you complete all steps above, reboot the computer and the problem will be fixed.
Video walkthrough for those who are not very technical is here: "Windows cannot connect to Group Policy Client services" how to fix. - YouTube
I am so relieved I was able to fix it, and hope this will help others with the similar issue.
My System SpecsSystem Spec
20 Feb 2013   #9

Windows 7 Ultimate x64

Quote   Quote: Originally Posted by PLX View Post
It's been a year since i last logged in, i just wanted to say a big THANK YOU !

Your solution was also valid for an friends Laptop that i just re-installed Win 7.
My System SpecsSystem Spec
20 Feb 2013   #10

Windows 7
Window Could not connect to Group Policy Client [SOLVED]

I received this error since 3 months ago.

I finally was able to reach this topic and this address my issue on the nail.

Thank you very much!!

I was reading the svchost link refered above and I still cannot figure out how the solution came about, perhaps the good Samaritan could explain it a bit more how he was able to find all the keys and parameters related to the Group Policy Client.

Now onto my BSOD problem...

I have Windows 7 Ultimate and as I recall the cause was also during an Windows Update process. UNBELIEVABLE!!!

A word of advice to current user: if your system is working fine, don't update/upgrade for no reason.
My System SpecsSystem Spec

 Cannot Connect To Group Policy Client Service.

Thread Tools

Similar help and support threads
Thread Forum
Group Policy Client Service
What is it? How did it get activated? Do I need it? If not, how do I get rid of it? I have never heard of it before. This is a single user computer. No Homegrouping. Asus G72 Gamer's Notebook Windows 7 Home Premium 64 Bit
General Discussion
Cannot connect to the Group Policy Client service
Hi all, I have a problem with very annoying pop-up that appears on every system startup. It is titled: "Failed to connect to a windows service" and it's written: "Windows could not connect to the Group Policy Client service. This problem prevents standard users from logging on to the system. As...
General Discussion
Failed to Connect to a windows service... Group Policy Client
Okay, I know other people have posted this same error; but my case is slightly different. In my case, this is a brand new computer I just built, just installed Windows 7 Home Premium. Have not installed any programs except the basic stuff like Chrome, Security Essentials, Windows Updates, Drivers,...
General Discussion
The group policy client service failed the logon
Hello everyone ! Im using win 7 professional x64! i was stupid deleted some files like ( ntuser.dat ... ) in C:\User\Username folder And now , i can not log in to my desktop screen. I took most 7hrs to searched and tried tried tried , but i did not work. 1. I can not create New Profile when...
BSOD Help and Support
Cannot connect to Windows Group Policy Client Service
I got a call from my wife saying... Hannah (my 1 year old daughter) did something to the computer. LOL When I got home the PC now says " Windows could not connect to the group policy client service" Also I have no sound and it says no sound is enabled, but in my device manager it shows all...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:22.
Twitter Facebook Google+