Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: VPN troubles

20 Jan 2011   #1

Windows 7 Ultimate X64
VPN troubles

Hi, i recently upgraded from XP to 7 ultimate on my PC, and after doing so I can't get my VPN (windows native software) to function. I can connect from my laptop (also windows 7 ult) to my PC and do get a VPN connection, but the PC does not appear to give me any IPv4 or IPv6 access (IPv4: not connected IPv6: not connected Media State: Connected). On the client side, the connection status details reads:
Device Name: WAN Miniport (PPTP)
Device Type: vpn
Authentication: MS CHAP V2
Encryption: MPPE 128
Compression: (none)
PPP multilink framing: Off
Client IPv4 address:
Server IPv4 address:
NAP State: Not NAP-capable
Origin address: (uknown)
Destination address: my home IP

On the server side (my PC) there is nothing, details is a blank page. I setup with the same settings on XP, which work fine when I run on XP on PC(dual boot). Ports 1723 47 and 500 are forwarded. Running Kaspersky Internet Security, doesn't work even if protection is paused and windows firewall is off. one thing I noticed is when setting up "New Incoming Connection" on PC side there is no Client for Microsoft Networks under Network components. Sorry for the long post, any help appreciated. Thanks.

My System SpecsSystem Spec
03 Apr 2011   #2

Windows7 pro 64

Hi SimmaD

I've just upgraded from xp pro 64 to w7 pro 64 and have experienced the same issues as you with my VPN.

Namely: with XP, clients connect fine, VPN server acquires ip address (ipv4) and VPN client allocated next ip address. Data transfer commences as expected. With W7, clients appear to connect, server acquires ip as per Xp but the client is not allocated an ip address. Consequently no data transfer is enabled between client, server and underlying network of server.

Much googling has shown many similar problems but none show 'solved'.

I'm interested if you're now quiet because you solved it or found an alternative (like reverting to XP)?
My System SpecsSystem Spec
03 Apr 2011   #3

Windows 7 Ultimate x64

How do you have your network set up? I mean do you have your computer connected directly to your Cable/DSL modem and your computer is obtaining the IP address from the ISP or are you running through a router/switch that is giving your computer a Class A (, B (172) , C (192.168) private address?

I just set up the VPN with my friend from japan and he connected Just fine! So if i can know how you have your network I can help you with the settings.

Also, to make things easier.. there is a third party software that makes things a little easier without using the native Windows software...

TeamViewer - Free Remote Access and Remote Desktop Sharing over the Internet
My System SpecsSystem Spec

07 Apr 2011   #4

Windows7 pro 64

My System SpecsSystem Spec
07 Apr 2011   #5

Windows7 pro 64

Thanks for taking an interest. I can post some ipconfigs on Tuesday whe I'm back at home (I'm on the road a couple of days) but to keep things going here's the setup:

DLink router:
W7 PC. (static)
VPN Server (running on W7 PC): (VPN range allocation to 115)

All necessary ports are forwarded on the router (when I boot back on XP everything works well)

When I compare arp -a between an XP boot and a W7 Boot , the results are quite different. W7 has about 3 different 255.xx Entries. XP just has the expected; the gateway (192....1 and the PC 192....102)

Subnets, I suspect are my problem but I've not a clue how to deal with them as it seems XP does a better job of taking care of everything (less sophisticated I suppose?)

I have noticed two subnet addresses for the server and the PC and Svr: I've also set VPN server to allocate in 10. IP Range, all to no avail.

I've also tried a loop back adapter, but I might have well tried a spoon as I didn't really know what I was doing with it! It stopped all connectivity!

Any help welcome!

My System SpecsSystem Spec
07 Apr 2011   #6

Windows 7 Ultimate x64

Just curious... what VPN device are you using to set up all of these Subnets and Ranges.

I know that if you are using Windows 7 Pro, you are only allowed a few outgoing / incoming VPN. If you want more, you have to obtain Windows Server 2003 or 2008.
My System SpecsSystem Spec
14 Apr 2011   #7

Windows7 pro 64


I use a dlink dir-655 as a router, switch and DHCP. It's ok but caused major headaches when setting up and having to experiment with port forwarding / virtual server options... it kept crashing and nothing would render as I attempted to navigate its menu options. Hard-reset and reconfigure was the only option, MANY times. If you have a choice for another gigabit domestic router; look there first.

Now, VPN... I had absolutely no luck with Windows 7... many hours fiddling to no avail.

So I took your advice and gave Server 2008 R2 a go. Within an hour, once I figured what server roles to install, VPN'ing started no trouble.

I couldn't fathom what was different between the two setups, and still can't. S2008 seems a little more componentised in how you can interact with it, probably no different to W7 but I was able to understand a bit more what was going on.

Cheers for your help,

My System SpecsSystem Spec

 VPN troubles

Thread Tools

Similar help and support threads
Thread Forum
SSD Troubles
I am truly stumped. I am trying replace my C drive with an SSD. I purchased a Samsung SSD 840 Pro, 256 GB. The install was straight forward, I used Samsung's Migration software to clone the OS onto the new drive. When I disconnect the old C Drive and try to boot from the SSD, the machine will...
Hardware & Devices
Ram Troubles
Alright, here's the rundown: I have 3GB installed and working. I add a 2GB Stick into the open slot, turn my computer back on, check properties of My Computer, and it says 5GB installed, 3GB Usable. Can anyone explain this? I am running Windows 7 Pro, 32-bit. Much thanks.
Hardware & Devices
RAM Troubles
I have here an Acer Aspire T180-UB7Z, and it has a stick of RAM that isn't listed on the RAM manufacturer's website as being compatible with the motherboard. I don't know if this is because they haven't tested this particular stick with this motherboard, or if it is incompatible. Basically, no...
Hardware & Devices
Log on troubles
I have an unusual situation. I have a normal logon screen with four users, call them A, B, C and D. Once the computer enters sleep mode, when I rewake it, instead of going to the general login screen, it automatically logs on user C regardless of the fact that all users were loged off before it...
General Discussion
So W7 troubles...
ok I have the ISO let me "back-it-up" to 5 discs, tried restoring it, failed miserably... when done downloading, it opens "NTI CD DVD MAKER"...go to do data cd, it says the iso file is too large to copy to disk. Im trying to get file to burn to the disc but keep getting...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:23.
Twitter Facebook Google+