Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: LAN Connection Doesn't Have Valid IP

31 Jan 2011   #1
madre

Windows 7 Home Premium 64 bit
 
 
LAN Connection Doesn't Have Valid IP

Help! I am not great at networks and routers. I want to keep my desktop connected to the DSL and be able to use my laptop and iPad elsewhere in my house. I purchased a Linksys as my old router had a very weak signal. Please lead me by the hand if I need more information for you to be able to help. I appreciate you all!

Windows 7 Home Premium 64 bit
Westel 2200 modem Verizon DSL
Linksys E1000 wireless router

I did this to get the router to work:
Changed VC config in modem utility to 0/35 bridge mode
Turned off DHCP server
In router PPPoE area, changed the log on to my verizon username and password.

Connected computer DSL line to wireless modem in the internet slot
Connected modem to 1 of 4 ports on router.
Can connect through broadband by clicking connect
Wireless connection shows but has no internet access

When I try to set up LAN, I get this message:

Local Area Connection doesn't have a valid IP configuration


I have read the many other posts concerning this but I don't want to start trying things without a plan. I have never had to ask for help before! I usually can figure it out with the help of these forums.


My System SpecsSystem Spec
.
01 Feb 2011   #2
wilywombat

win7
 
 

Try following the instructions here to setup your system:-
How do I set up a Westell to work with a hub or switch. AT&T Southeast Forum FAQ | DSLReports.com, ISP Information

If you still have problems come back and we'll try to sort them out
My System SpecsSystem Spec
01 Feb 2011   #3
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by madre View Post
Help! I am not great at networks and routers. I want to keep my desktop connected to the DSL and be able to use my laptop and iPad elsewhere in my house. I purchased a Linksys as my old router had a very weak signal. Please lead me by the hand if I need more information for you to be able to help. I appreciate you all!

Windows 7 Home Premium 64 bit
Westel 2200 modem Verizon DSL
Linksys E1000 wireless router

I did this to get the router to work:
Changed VC config in modem utility to 0/35 bridge mode
Turned off DHCP server
In router PPPoE area, changed the log on to my verizon username and password.

Connected computer DSL line to wireless modem in the internet slot
Connected modem to 1 of 4 ports on router. <This needs to be plugged into the WAN port on the router.
Can connect through broadband by clicking connect
Wireless connection shows but has no internet access

When I try to set up LAN, I get this message:

Local Area Connection doesn't have a valid IP configuration


I have read the many other posts concerning this but I don't want to start trying things without a plan. I have never had to ask for help before! I usually can figure it out with the help of these forums.
On potential problem is in bold red above. You should also turn DHCP back on then set your router to use WPA2-AES security "not mixed" and set up your SSID "name of wireless network" and set up your wireless security password.

After doing all that in your routers set up window you should go to the network and sharing center in Windows 7 and choose "set up a new connection or network" go through the set up making sure to use the same settings you used when you set up your router. You should have no problem connecting wirelessly after that.
My System SpecsSystem Spec
.

01 Feb 2011   #4
madre

Windows 7 Home Premium 64 bit
 
 

That was easy! Problem seems to be fixed. THANK YOU!
Now if I can get rid of the "guest" account!
My System SpecsSystem Spec
02 Feb 2011   #5
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

I'm glad that worked for you.

It's best to just disable the guest account but don't delate it as it's a built in feature.
My System SpecsSystem Spec
Reply

 LAN Connection Doesn't Have Valid IP




Thread Tools




Similar help and support threads
Thread Forum
local connection doesn't have a valid ip configuration
I desperately need help with this error I have read all the different guides on how to solve this problem and have yet to find a way to solve it it also doesn't help that I am not tech savvy. Any information would help
Network & Sharing
wireless network connection doesn't have a valid ip configuration
One afternoon my laptop decided to have "an initentified network" after having no problems previously with our dsl router. I am working from my functional desktop computer, so I will not be able to download any new drivers, etc. on the dysfunctional laptop since obviously I have no internet...
Network & Sharing
Local Area Connection doesn't have a valid IP
one day about 2 weeks ago, my net stopped working just randomly. I get the error 'Local Area Connection doesn't have a valid IP' when i try to use the router, and some 'unidentified network' shows up, i cannot connect to it. I reset everything and unplugged everything but couldnt get it to...
Network & Sharing
Local Area Connection doesn't have a valid IP configuration
Recently, I can't connect to the internet. when I tried to troubleshoot the problem, it gave me the following line : "Local Area Connection doesn't have a valid IP configuration" I have two PCs and when I connect the mothem/router to the second PC, everything is okay and internet is on (So I am...
Network & Sharing
Wireless Connection- IP doesn't have a valid configurat
Hello, I've been reading several posts in the forum, and seen so many cases like mine. Still, even after I've followed the steps like, reset the laptop, disable de Ipv6, disable and enable the connection again, still my laptop doesn't connect to the internet anymore. I'm sure that the...
Network & Sharing
Connection doesn't have a valid IP configuration.
Hey guys, little problem here. I just bought my wife a new laptop with Windows 7 on it. When I first got a hold of it, I proceeded to remove all the HP bloatware that was installed. I went to Add/Remove programs and uninstalled everything that had HP beside it. Next, I tried to have the...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:38.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App