Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: rtl8187l is enabled but cannot connect

06 Feb 2011   #1

Windows 7 x64
rtl8187l is enabled but cannot connect


I have a laptop with built in Broadcom 802.1g wlan which works absolutely fine. Due to my distance from the wireless router, I purchased a USB Wireless adapter with 9db antenna in hope that I will get good signals. It has rtl8187l chipset.

I have windows 7 x64. When I plugged the adapter, windows searched online and installed the drivers automatically. The adapter is enabled and the properties shows that the device is working fine. But I cannot connect it to available networks. Infact, when I disable my built in wifi adapter, I cannot see any connections to connect with.

So I installed Realtek driver and utility pack for win7. It installs but when I point the cursor to the realtek red bars icon in system tray, it shows the message 'rtl8187 is disconnected'.

I tried everything, even uninstalled the builtin adapter drivers. Then windows installed my Broadcom drivers but it had exact problem, i.e. it was enabled, but I cannot see any available network connections. I was in total loss with no internet so I had to perform system restore and atleast I have internet access and I am back where I started.

I wish if somehow, windows manages to control the connections for my USB wireless adaptor. Or ANY 3rd party utility / software that make my new adapter work!!


My System SpecsSystem Spec
06 Feb 2011   #2

Windows 7 x64

After 3 days of continuous research and just after posting the above (original) post, I found the solution.

I just unchecked the firewall from the Adapter properties which in my case was Kaspersky Internet security.

Disabled the built in card, Restarted the computer and there it is, all network connections appeared !!

Now I have unchecked the firewall of my built in adapter and checked the firewall of my USB wifi adapter that I am now using. Enjoying Excellent signals.

My System SpecsSystem Spec
19 Sep 2012   #3

windows 7

"I just unchecked the firewall from the Adapter properties which in my case was Kaspersky Internet security."

And just exactly how did you do this? I may be having the same problem
My System SpecsSystem Spec


 rtl8187l is enabled but cannot connect

Thread Tools

Similar help and support threads
Thread Forum
ICS cannot be enabled
I have 2 wireless adapters, one integrated in laptop and one external. I want to connect with integrated adapter to my wifi router, and then create adhoc on external adapter and share my internet. I successfully create adhoc and connect other laptops, but there is no internet acess. When i want to...
Network & Sharing
Can't connect to internet - IP's are all 0's & DHCP is not enabled
Hi, I'm working on a friends laptop & at first thought that she had this new Malware virus, but when I look at the IP config all of the IP addresses are zeros. DHCP is disabled for all adapters. When attempting to load IE page I get Error 105 - Unable to resolve the server's DNS address. I'm not...
Network & Sharing
Cant connect to wireless router when wpa-psk security enabled
Hi all This issue may have been posted before, but i couldnt find any posts relating to this by searching. The problem i have been having and cannot solve is this. My windows 7 Professional 32bit desktop pc has a pci wireless network card. The pc is able to find my wireless router and the...
Network & Sharing
USB enabled but not enabled ?
just connected my ipod to my system but the system doesn't alert me that its been connected. The ipods charging, and it even shows up in device manager but when going to enable it, see pictures below it says cannot start service. plug and play is enabled and bios has usb as enabled ??? tried fix...
Hardware & Devices
alfa awus036h (RTL8187L) win 7 64 bit driver.
hi... has any of you have had any luck finding RTL8187L driver for win 7 64 bit.. i have a ALFA AWUS036h wireless adapter that uses a (RTL8187L) chipset but it doesnt work for 64 bit.. it would only work on 32 bit win 7.. HELP PLEASE!!!!

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:07.
Twitter Facebook Google+