Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to get internet on W7 Starter

05 Mar 2011   #1

WIN 7 Ultimate x64
Unable to get internet on W7 Starter

I have a home network (MSHOME) where I connect 3 XP home and 1 W7 Ultimate x64 computers and have file, printer and internet sharing . Belkin N+ Router and ADSL modem.

My setup works great. Now my Sister is visiting and I can not get her (Donna PC) Eeepc 1015PE with W7 Starter, online.
As with the W7 Ultimate computer I had to use a static IP to get on my LAN. With Donna-PC I can connect to the LAN and see the other W7 computer but not the XP ones.
Can not connect to the internet with IE or Firefox. With Donna-PC I can interrogate my Belkin router as with the other computers with HTTP://
Ipv6 is ticked off and a static address of
is set in ipv4 with gateway as and no alternate. My DHNS pool is from - .6

The network map on Donna-pc shows this pc connected to to the Belkin router with a red X between the router and the internet. The network is unidentified, public. Have not been able to name it MSHOME or change it to a home network.
I can double click on the unidentified network and a box comes up and invites me to change the network name but I can not.

I suspect the problem with no internet access is because this computer insists it is on a public network and not a home network. As I am networking with XP and W7 computers I am using the old MSHOME name and not W7 work group. Works fine on all but this guest Donna-pc.

I need advice on this one. Thanks in advance.


P.S. I am using all wired connections. I have tried wireless for this Donna-pc with the same problem.

My System SpecsSystem Spec
05 Mar 2011   #2
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit

Not particularly familiar with Win7 Starter -- but have you tried creating a second Home network on her PC?

Maybe it just won't let you change an existing network but will let you create a new one.
My System SpecsSystem Spec

 Unable to get internet on W7 Starter

Thread Tools

Similar help and support threads
Thread Forum
Unable to update Internet Explorer, SFC unable to fix corruption
Hi there! There are similar threads about this problem but since the solution is always system specific, I figured I'd start a new thread. I'm having issues with a few Windows updates, sometimes they work sometimes they don't but the Internet Explorer update never works. I had IE9,...
Windows Updates & Activation
Unable to open files that I created & saved in Word starter 2010
Problem started "mid September I believe". I purchased my laptop few years back, Never had any problems opening my docs. Thought i solved this with system restore to earlier date. this worked and i was able to open those files. I now no longer can use system restore because it wont go back to...
Microsoft Office
Unable to change screensaver on Windows 7 Starter. Please help.
Hi guys, My name is Dario and this is my first post. Great to be here! Been spending hours trying to get my screensaver changed on my windows 7 starter edition. Have seen previous threads on this forum about it and searched the internet for hours, but still no solution. I can access the...
General Discussion
unable to connect to wireless with windows 7 starter
hi, i am unable to connect to my a specific wireless connection. When i do try and connect it will not allow me to enter the security code to enable the wireless, instead it say something about windows not recogonising the connection. My windows is also in spanish which is driving me mad(bought...
Network & Sharing
Win 7 Starter Internet Connection Sharing...
I have a netbook that has a USB modem from clear and windows 7 starter. I have several other laptops with windows 7 premium within range of the netbook. I got the adhoc network set up and had it working. Though it told me that I did not have the permission to start ICS. I even went through the...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:41.
Twitter Facebook Google+