Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Printer on 7 not being accessed by XP

30 Jun 2009   #1

Windows 7
Printer on 7 not being accessed by XP

My main pc is using Windows 7 64 bit build 7100, my kids pc is using XP Pro. Previously we had the networking with my main pc using Vista working perfectly, the XP pc could print on the printer connected to my pc, since I put Windows 7 on this pc I have the networking with file sharing etc working great but cannot get the XP pc to be able to print anymore. The printer is an Epson RX690 Any help would be appreciated

My System SpecsSystem Spec
02 Jul 2009   #2

XP, Seven, 2008R2

can you get as far as connecting to the printer?
My System SpecsSystem Spec
03 Jul 2009   #3

Windows 7

no the xp pc doesn't see the printer at all
My System SpecsSystem Spec

03 Jul 2009   #4

Windows 7 Rc Build 7264 x86, Ubuntu

I'm going to assume that you have setup the printer share in your Homegroup?
My System SpecsSystem Spec
03 Jul 2009   #5

Windows 7

tried and I get a box coming up with "Printer settings could not be saved. Operation could not be completed (error 0x000006d9) the printer works perfectly in windows 7 though
My System SpecsSystem Spec
03 Jul 2009   #6

Windows 10 Pro X64 Insider Preview (Skip Ahead) latest build

Is it a networked printer or one connected via USB / IEEE1384 (aka Printer cable)?
My System SpecsSystem Spec
03 Jul 2009   #7

Windows 7

connected standard via the usb cable
My System SpecsSystem Spec
03 Jul 2009   #8

Windows 10 Pro X64 Insider Preview (Skip Ahead) latest build

Are you using the driver supplied by the manufacturer or the native Windows 7 driver?
My System SpecsSystem Spec
14 Jan 2010   #9

XP & Win 7

In my case this was caused my having Windows Firewall Disabled.

You can marked this issue as solved!
The offending program causing this error is Windows Firewall, here's what you need to do to resolve this issue....
If like me you have disabled windows firewall, I use ZoneAlarm's Security Suite, you need to re-enable the firewall in order to share the printer.

If you have disabled or turned off Windows Firewall. (and this error in my case was caused by exactly that EXACTLY this Error code)
Step #1 - Disable any other firewall you may have installed. Stop it from loading at boot and restart your PC.

Step #2 - Go to the Admin Tools Folder >> Services >> Windows Firewall >> Double click and either set it to Manual or Automatic and Save.

Step #3 - Open Control Panel >> System & Security >> Windows Firewall >> Turn Windows Firewall On or Off >> (Enable) Turn on Windows Firewall >> Save
Then go to Restore Defaults >> Click Restore Defaults Button >> Save
(you only need to do this IF you changed any settings for the firewall, but it's still a good idea and will ensure there are no problems when proceeding)

Step #4 - Click Control Panel Home >> View Devices & Printers >> Select/Click your Printer >> Display Printer Properties >> Sharing >> Share this Printer >> OK

Step #5 - Go Back to Windows Firewall and Turn it back off >> Save

Step #6 - Go Back to Services >> And set Windows Firewall to Manual (or disable if you prefer, I recommend Manual)

Step #7 - Restart & Re-enable your preferred firewall to start at Boot >> Reboot

Step #8 - Take a deep breath and sigh with relief! :)
My System SpecsSystem Spec

 Printer on 7 not being accessed by XP

Thread Tools

Similar help and support threads
Thread Forum
Windows Installer could not be accessed
Recently after windows update, updated my computer I started to get Windows Installer could not be accessed error whenever I try to install anything. I tried to system restore but for some reason all my restore points were gone. No viruses found by Sophos Protection Current system: Windows...
BSOD Help and Support
Your Location Has Been Accessed
On the right side of the Task Bar next to the Flag Icon there is a Triange. There is an icon in it that has just appeared. It says "My Location Has Been Accessed". I am not sure what that means. I had just ran Windows Update before I noticed it. Can someone fill me in on what this means? ...
General Discussion
Log of files accessed
Does Win 7 Home Premium maintain a log of shared files being accessed and which machine they were accessed from? I am getting tired of telling my users about new files being available, only to have them tell me they already know about them. If not, is there some third party app that can monitor...
Network & Sharing
Windows Installer Cannot Be Accessed
I am getting an error when I am attempting to install the C++ Redistributable Package that says: "Windows Installer Service cannot be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance." I have attempted to look up...
General Discussion
MSI could not be accessed
So yeah I'm getting the old MSI could not be accessed crap whenever I try to install *any* MSI file I've tried all the fixes involving the registry and putting an _ infront of the key but the problem there is I *dont* have that registry key there all thats there is default I've tried...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:17.
Twitter Facebook