Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7, hub, dsl internet access

07 Apr 2011   #1
plumbers crack

Windows 7 Home Premium 64bit.
Windows 7, hub, dsl internet access

I have a 4 port wired hub that runs voip phone and a xp computer to a single port dsl modem. If I connect the comp with windows 7 direct to the modem, it get internet, if connected to the hub, it says unidentified network and no internet access.

I've tryed a lot of different stuff from this site but nothing works.

This problem started yesterday and it happened all by it's self, nothing changed by me, I left the house with it working and came home to this. Please help because it's my fathers comp and he's driving me nut with out his internet.

My System SpecsSystem Spec
07 Apr 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 x64

Check that the firewall isn't blocking any windows services.

Also run
ipconfig /flushdns
My System SpecsSystem Spec
07 Apr 2011   #3
plumbers crack

Windows 7 Home Premium 64bit.

Just did that and it said "Successfully flushed the DNS Resolver Cache."

Shut down both anti viris and windows firewall. Still nothing.
My System SpecsSystem Spec

07 Apr 2011   #4

Windows Seven x64

All other computers work and can successfully connect to the Internet when all of them are connected to this hub right?

Check the ports on the hub by connecting other devices to the port where the Windows 7 computer was plugged into can you get access to the Internet with the other devices?

On the first screen shot Windows 7 cannot connect to the network, so it uses a 169.254.x.x address. On the Windows 7 computer on the Ethernet jack do you see lights (green and orange) when you connect to the hub?

Hope this Helps,
My System SpecsSystem Spec
07 Apr 2011   #5
plumbers crack

Windows 7 Home Premium 64bit.

All the port work fine, tested each one. The green light is lit and the orange flashes every so often.

I'm finding it weird that the hub is stopping it from getting the DNS suffix,
lease info, default gateway, DNS server and things like that.

I can just plug it directly into the modem and it works, than plug it back into the hub and than it doesn't work. This is all without restarting.

Should I just do a clean install and be done with it?
My System SpecsSystem Spec
07 Apr 2011   #6

Windows 7

That is strange - with the hub connected you are operating within a different subnet... The hub should not be able to assign any IP's if it is just a hub...

First question -> Is it connected properly, many hubs have a specific port for the internet connection to be plugged into, and the other ports for the use of the PC's..

If that is all ok, you could assign an IP on your PC yourself:

Network & Sharing Center -> Change Adapter Settings -> Right Click Properties on LAN connection -> Select Internet Protocol V4 and Properties button -> Then select use the following settings: (Looking at the image this should work:

Default Gateway:
DNS Server:

That should work I think...
My System SpecsSystem Spec
07 Apr 2011   #7
plumbers crack

Windows 7 Home Premium 64bit.

The hub is just a hub and it's been connected this way for 5 years now. This comp has been using the hub for a little over a month now with out any problem until now. The Vista comp he had before and my XP comp have had no issues ether.

I put the info you said in and still no connection.
My System SpecsSystem Spec
07 Apr 2011   #8

Windows 7

Can you verify the settings are being recognised, ipconfig in cmd like the original screenshots will do... Im not on a windows 7 PC but where you set those menus I think there is a checkbox to verify the settings on exit... Maybe worth a try...

Reflush the DNS after the change may be required -> The settings I gave were based on the screenshot of it plugged into the modem directly, maybe I made a mistake but I cant see it... So someone please feel free to check.
My System SpecsSystem Spec
07 Apr 2011   #9

Windows 7 Pro x64

Is your modem a router also?
I know most are but if you have it set to Bridged Ethernet or it is just a model then it is passing the public IPs to whatever is connected to it.

I haven't looked at your screen shots yet so take what I said above with a grain of salt.

OK I looked at the SS. Very weird.
The only thing I can come up with is something changed on the modem/router and for some reason you have used up the available IP address being handed out by the modem/router DHCP server.

One way to check that is to turn everything off, even the modem. Then turn the modem on then that one problem PC. It then get a valid IP turn the other pieces of equipment on one at a time and see if all of them get a IP.
My System SpecsSystem Spec
07 Apr 2011   #10
plumbers crack

Windows 7 Home Premium 64bit.

After manually putting in the ip the default gateway showed, but there's still no lease, DHCP enabled is no, DHCP server or DNS Suffix.

The modem is set up in router mode I believe.
My System SpecsSystem Spec

 Windows 7, hub, dsl internet access

Thread Tools

Similar help and support threads
Thread Forum
Cable connected to modem, ipv6 no internet access ipv4 no network
Hello Guys, I've been searching for the past 2 days a solution, but nothing came up to work. Tried different things, nothing good yet. So I'm directly connected to a modem, cable, and well, my computer takes time to identify and then identifies it first a a public network (i was able to...
Network & Sharing
issue with internet access after new modem (and router) installed
Problem with my cousins network again. The modem finally called it quits. He was told by AT&T to buy a new one and he bought a Netgear DM111PSP. It wouldn't work. I went there and after 1/2 hour it's working (I think he had the user name incorrect). The internet works fine when the computer is...
Network & Sharing
Internet access problem via usb modem problem
I need your help. I can’t seem to connect to the internet with my USB ‘dongle’ modem on my new laptop. My service provider says that the problem is not a problem with coverage. The device is working properly, according to Windows 7 and I can also access the internet on another older laptop that has...
Network & Sharing
'No Internet Access' IP address shows router not the modem IP address
Hey everyone. I've ran into a problem that I can't quite figure out. My internet connection shows 'no internet access' even though my ISP shows the connection is coming into the house just fine. I usually use a router (NetGear-WNR3500U) but I right now I have the Ethernet connection plugged...
Network & Sharing
No internet access after resetting modem
Hi to you all, Can someone please help me with this internet issue? In order to change my password a service provider had to reset my modem. I can go on the internet with my desktop, but I am having difficulties going on the internet with my laptop. It seems that my wireless router has to be...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 20:28.
Twitter Facebook Google+