Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet speed loss

19 Apr 2011   #1
PRiMO

Windows7
 
 
Internet speed loss

Hey there guys. So here's my problem :
I've been experiencing in the last 5-6 months a progressive loss of internet speed. I've called my ISP tech support and they told me to do a reset to the modem for about 10s. It worked lol. For about 1 or 2 days -.- Then it went to it's same position again, a low speed internet. My package grants me 10mb/s and in my isp speedtest it gives my the 9.75 mb/s of download speed it should give and a lame 0.20 mb/s of upload speed. The thing is that when im downloading stuff, it gives me a speed of like 67kb/s, when it should give me from 600kb/s to 1mb/s. I dont know if it can be the modem or the router but one thing is granted, im losing allot of internet speed. My modem is the ARRIS Touchstone TM502G and my router is the SMCWBR14S-N2.
The house internet is used by 3-4 people, but only 2 of them require more internet, because of the online games. Even though only mine requires more, because the other's games I dont think it requires too much bandwith.

What should or can I do to fix this please? If you need any more information please tell me.

Thanks


My System SpecsSystem Spec
.
19 Apr 2011   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by PRiMO View Post
Hey there guys. So here's my problem :
I've been experiencing in the last 5-6 months a progressive loss of internet speed. I've called my ISP tech support and they told me to do a reset to the modem for about 10s. It worked lol. For about 1 or 2 days -.- Then it went to it's same position again, a low speed internet. My package grants me 10mb/s and in my isp speedtest it gives my the 9.75 mb/s of download speed it should give and a lame 0.20 mb/s of upload speed. The thing is that when im downloading stuff, it gives me a speed of like 67kb/s, when it should give me from 600kb/s to 1mb/s. I dont know if it can be the modem or the router but one thing is granted, im losing allot of internet speed. My modem is the ARRIS Touchstone TM502G and my router is the SMCWBR14S-N2.
The house internet is used by 3-4 people, but only 2 of them require more internet, because of the online games. Even though only mine requires more, because the other's games I dont think it requires too much bandwith.

What should or can I do to fix this please? If you need any more information please tell me.

Thanks
would you by chance be downloading from a torrent site? Or perhaps using homegroup for networking?

Your ISP rates your connection @ 10 Mb and speedtest shows 9.75 as advertised. The upload speed is a little low but not much. Have you tried speed tests when the others are online gaming, and when they arent?


Ken
My System SpecsSystem Spec
19 Apr 2011   #3
PRiMO

Windows7
 
 

I am not by any chance downloading any torrent at all. That homegroup part I didn't quite understand it. You mean if my network is set up as homegroup?

I have done 2 speedtests while playing Battlefield : Bad Company 2 only, one of these is speedtest.com and the other is the speedtest on my isp website. They both gave me the same numbers. But ingame I had 300+ ping.
My System SpecsSystem Spec
.

Reply

 Internet speed loss




Thread Tools




Similar help and support threads
Thread Forum
PCI-E internet card not working well, Slow speed / Connection loss
I got a: PCI-E Wireless 802.11n 150Mbps Network Interface Card So It somewhat works but only a 2 MBPS download speed I know that my wireless network gives off 30 MBPS as my old external wireless USB was getting, but that is broke. With that broke all I have left is the internal card with...
Network & Sharing
recurring loss of internet wifi and ethernet speed
problem as above - every couple of weeks or so my internet slows to a snails pace, it usually lasts for 3 or 4 days then its back on full speed again, really cant figure this one out! Ive released ip and flushed dns! my ping is always around 10ms and my upload is always around 4mb which are...
Network & Sharing
Evening Internet Connection Loss -- Unable To Identify Source Of Loss?
I need your help!!! I got a real challenge for you! I am confused! I cannot locate the Internet connection loss source. Every night for the past 5 late evenings my Windows 7 Pro 64-bit has been losing my Internet connection on my desktop computer anywhere between 8 PM-12 AM (Last 3 nights: 11:05...
Network & Sharing
Internet speed loss, can't find solution
I'm having some serious issues with my internet speed. I am on Virgin Media 60mb with the ISP provided router. We have 4 computer connected via wires and several wireless devices. In the last month my computer has been suffering some serious internet issues. My regular connection on...
Network & Sharing
Can anyone explain this speed loss?
I recently had to relocate my router to have a wired connection in the house, then returned it to where it was after the project was finished. My laptop lost a lot of connection speed that didn't affect the other computers on our network. I had been getting "same IP address being used" errors...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App