Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Wifi disabled on startup

30 Apr 2011   #1

Windows 7 Home Premium
Wifi disabled on startup

On the advice of a friend, 4 days ago we changed the security settings on our home router/network from WPA2- Personal TKIP+AES to just AES. I then changed my Asus UL80vt-A1 wireless adapter settings (Atheros AR9285) to match (from TKIP to AES).

This was the ONLY change I made to the system.

Then the fun began.

First off a new adapter appeared in my Network connections. It is Wireless Network Connection 2- Microsoft Virtual WiFi Miniport Adapter. Well, that was not there before I made the changes to the security settings. Googling results indicate it is a normal part of Windows 7, it really had never been there before.

Restarting the computer the wireless adapter shows as disabled, and I have to run the network diagnostics to re-enable it. It does not matter if I do a shut down or hibernate (my preferred way of shutting down the laptop before going somewhere).

So I thought I should change the security settings back to what I had (TKIP+AES) and set my notebook to TKIP. I also did a Windows Update just in case. I ran a scan with Avast Antivirus, Microsoft Security Essential and Malware Bytes to see if something evil had gotten in, all were clean.

Now when I hibernate my laptop it takes 4-5 minutes to shutdown. When I restart it takes 4-5 minutes to restart. I am staring at the intro screen waiting for the logon to appear. Once I get logged in the wifi adapter appears connected, but the computer is acting like it is hung up until all the open programs have finished loading. I can't do anything until the 27 open tabs in Firefox have completely finished being restored. Takes another 3-4 minutes.

Something is seriously wrong here. I do not think it is hardware related, something in my system software got noodled, but how the heck am I going to figure what it is?

Any ideas will be appreciated.

My System SpecsSystem Spec
30 Apr 2011   #2


Do you have a valid restore point made prior to changing the system settings?
My System SpecsSystem Spec
30 Apr 2011   #3

Windows 7 Home Premium


I could not have imagined that changing the Wifi adapter from TKIP to AES would screw the system up.

I am going to reinstall the Asus wifi drivers and see if that helps.
My System SpecsSystem Spec

01 May 2011   #4

Windows 7 Home Premium

I just had a breakthrough. Of sorts.

After reinstalling Power4Gear I did not finish customizing all the different setups. Under High Performance it was set as "Lid close action- Plugged in: Hibernate". Well, I thought it was set to "Do nothing", closed the lid while I had dinner expecting it to stay running, it went into hibernate mode perfectly. Came out of hibernate mode correctly, the wifi started up, all was well.

It has been very repeatable. The problem only occurs when I try to use the "Fn+F1" sleep button (which is set to Hibernate). I changed other power plan settings for "Lid close action" to Hibernate, and it will hibernate properly when I close the lid, but not when I use the Sleep Button.

Unfortunately I sometimes use this computer with my TV so having the ability to close the screen and stay running is something I would like to keep. But I want to use the Hibernate function.

Does anyone know what is going wrong? How to fix it?
My System SpecsSystem Spec

 Wifi disabled on startup

Thread Tools

Similar help and support threads
Thread Forum
Wifi Works, Ethernet doesn't (even with wifi disabled)
Hi! After moving to a new home, I'm having trouble getting a wired connection working. Same modem and router as the previous home, same PC. Different ISP, but both are Shaw cable re-packagers. router CISCO Linksys E900, Factory Reset, with latest firmware 1.0.06 modem THOMPSON DCM 475 ...
Network & Sharing
Alienware Wifi card.. Disabled?
I don't know if this thread best suits windows 10 or windows 7 but it's occurring in windows 7 so i hope someone can help me. Here's what happened. I attempted to install windows 10, i black screened, tried everything people in the windows 10 fourms told me to do to fix the black screen and...
Network & Sharing
Can this bios startup item be disabled at computer startup
The attached jpg is the 1st item that launches in the bios screens at system star-up. This I think is the driver for a pci card I have installed in a slot in the box that controls (ie-adds another ide port) a second ide CD/DVD drive. Besides removing the card from the there a way in...
Hardware & Devices
Wifi disabled, can't manually start it.
So, I got home tonight after work, was going to play some Diablo 3, than noticed my laptop would not connect to the internet. I am currently using an ethernet cable... The Wifi light is off on my laptop... I use the key on the keyboard to try and enable it, with no success. I try to manual enable...
Network & Sharing
Wifi is disabled?
I have a Lenovo laptop and I all the sudden can't connect to the internet. I downloaded Speccy to check what is my NIC so maybe I can update the driver but the only thing I see is "You are not connected to the internet". and then "Wi-Fi not enabled". Also the Windows says that the wireless utility...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:19.
Twitter Facebook Google+