Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "local area connection" doesn't have a valid ip configuration?

23 May 2011   #1
blackprimehunte

Windows 7 Home Premium x64
 
 
"local area connection" doesn't have a valid ip configuration?

Yesterday and today, my computer randomly disconnected to the internet and when I tried to troubleshoot the problem, it fixed the internet connection and told me that:

"local area connection" doesn't have a valid ip configuration

What does this mean, why is this happening. I know it's not a big deal. but it stats to get really annoying >.>. Is someone trying to hack into my computer ?!?!!?(sorry, I can be a little paranoid).


My System SpecsSystem Spec
.
23 May 2011   #2
TheReaper

Windows 7 Ultimate x64
 
 

Hello. Welcome to Seven Forums.
First, do you have a router?
Take a look at this: internet troubleshooting guide.
My System SpecsSystem Spec
23 May 2011   #3
blackprimehunte

Windows 7 Home Premium x64
 
 

Hey, thanks for replying!

Yes, I do have a router, but this issue only happens occasionally and it can be really frustrating if I am doing something such as, let's say, playing an online game. The game would be frozen until I clicked "troubleshoot problem" on the network menu, and then I would have to refresh the entire page and wait for the game to load before continuing, not to mention that sometimes you lose progress and have to start again.

I know it sounds like a minor problem, but it can become a headache and I don't know why it's happening, I check out that link and my IP and everything seems to be fine.

Maybe I really am getting hacked

In all seriousness, do you think that this COULD potentially be a hack attack? Is this the sign of someone trying to break into the network?

Sorry for being so paranoid, I just don't feel save knowing that my personal data could be at risk (even though there's probably nothing to sorry about, it would help me sleep easier at night if I knew that I wasn't being hacked)!
My System SpecsSystem Spec
.

23 May 2011   #4
TheReaper

Windows 7 Ultimate x64
 
 

No problem. Do you by any chance have a D-Link router?
You could try to:
1 - disable IPV 6 & keep IPV4 enabled in your network card settings .
2 - reset modem to factory default.

To ease your fear of being hacked, you can download & install malwarebytes free & do a full scan of your computer. Which antivirus program are you using? Do a full scan with that as well.
My System SpecsSystem Spec
23 May 2011   #5
blackprimehunte

Windows 7 Home Premium x64
 
 

I did what you said and so far the problem hasn't appeared again , but then again it hasn't been that long since I changed the settings, so we'll have to wait a while to see.

As for the anti-virus, I have Norton Security Suite, and I did a scan last night, it didn't come up with anything, so that's good I guess.

I'll keep you informed if the problem arises again, but hopefully it's fixed now lol, thanks again for the help!
My System SpecsSystem Spec
Reply

 "local area connection" doesn't have a valid ip configuration?




Thread Tools




Similar help and support threads
Thread Forum
"Local Area Connection" doesn't have a valid IP configuration
So a few days ago, our D-Link router completely failed and the wireless doesn't work; until the problem can be settled, the only way we can connect to the Internet is if we're hooked up to the modem with an Ethernet cable. Of course only one person can use it at a time, so if Person A needs the...
Network & Sharing
"local Area Connection 2 doesn't have a valid IP Configuration" <-- I
Hello, as I have searched I have not yet found a clear and concise answer to this problem, and I was wondering if someone could please help me with this situation; on my network I have a pc connected through ethernet that keeps giving me this error message while trying to connect to the internet...
Network & Sharing
"Local Area Connection" Doesn't have a valid IP configuration.
I'm running into an issue which is hindering the enjoyment I am getting out of my system. Quite frequently I am getting these issues where I lose connection to the internet at random times. I then "Trouble Shoot" problems with the connection and I get the fixed issue of: "Local Area Connection...
Network & Sharing
"Local Area Connection" doesn't have a valid IP configuration.
Howdy folks. Just moved back onto campus for the year and already running into some problems. I'm able to connect to the wireless internet in my dorm just fine, but it's just god awful, so I've always used a wired connection. When I try that now though, it always comes up as "Unidentified Network"...
Network & Sharing
ICS - "Local Area Connection" doesn't have a valid IP configuration
I set up ICS on my computer following the directions from http://windows.microsoft.com/en-US/windows-vista/Using-ICS-Internet-Connection-Sharing. I'm able to get network access, but no internet access. When I tell the computer to diagnose the problem, it tells me that the local area connection...
Network & Sharing
"Local Area Connection" doesn't have a valid IP configuration
Hi Having a problem connecting to the internet with a Ethernet connected desktop. I am getting the following error '"Local Area Connection" doesn't have a valid IP configuration'. I have tried everything I have found on internet using my laptop with no success. This is in an apartment building so...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App